summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-06-24 17:13:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-06-24 17:13:55 +0000
commita08a75f154e06e12c4d7fe85ea53f140ee175a35 (patch)
treea17770e699884203e644badf083c3a25d5b0bbc5 /games-emulation
parentFix samples readme install wrt#474614. (diff)
downloadgentoo-2-a08a75f154e06e12c4d7fe85ea53f140ee175a35.tar.gz
gentoo-2-a08a75f154e06e12c4d7fe85ea53f140ee175a35.tar.bz2
gentoo-2-a08a75f154e06e12c4d7fe85ea53f140ee175a35.zip
version bump (bug #474616)
(Portage version: 2.1.12.2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dgen-sdl/ChangeLog7
-rw-r--r--games-emulation/dgen-sdl/dgen-sdl-1.32.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/games-emulation/dgen-sdl/ChangeLog b/games-emulation/dgen-sdl/ChangeLog
index 732ff7d2c8df..1f131c81066f 100644
--- a/games-emulation/dgen-sdl/ChangeLog
+++ b/games-emulation/dgen-sdl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/dgen-sdl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/ChangeLog,v 1.20 2013/01/22 17:49:05 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/ChangeLog,v 1.21 2013/06/24 17:13:55 mr_bones_ Exp $
+
+*dgen-sdl-1.32 (24 Jun 2013)
+
+ 24 Jun 2013; Michael Sterrett <mr_bones_@gentoo.org> +dgen-sdl-1.32.ebuild:
+ version bump (bug #474616)
*dgen-sdl-1.31 (22 Jan 2013)
diff --git a/games-emulation/dgen-sdl/dgen-sdl-1.32.ebuild b/games-emulation/dgen-sdl/dgen-sdl-1.32.ebuild
new file mode 100644
index 000000000000..366d1c1bd29c
--- /dev/null
+++ b/games-emulation/dgen-sdl/dgen-sdl-1.32.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/dgen-sdl-1.32.ebuild,v 1.1 2013/06/24 17:13:55 mr_bones_ Exp $
+
+EAPI=5
+inherit games
+
+DESCRIPTION="A Linux/SDL-Port of the famous DGen MegaDrive/Genesis-Emulator"
+HOMEPAGE="http://dgen.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dgen/files/${P}.tar.gz"
+
+LICENSE="dgen-sdl BSD BSD-2 free-noncomm LGPL-2.1+ GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="joystick opengl"
+
+RDEPEND="media-libs/libsdl[joystick?]
+ app-arch/libarchive
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+src_configure() {
+ egamesconf \
+ $(use_enable x86 asm) \
+ $(use_enable joystick) \
+ $(use_enable opengl)
+}
+
+src_compile() {
+ emake -C musa m68kops.h
+ emake
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README sample.dgenrc" default
+ prepgamesdirs
+}