summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-27 03:16:24 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-27 03:16:24 +0000
commita5c22dead95083dd2ce8ae1475b20c064e25111f (patch)
tree3596e471382a71b3bcfc3029bca9ca4caceb551b /games-emulation
parentfix install location of hal scripts - in a better way (diff)
downloadgentoo-2-a5c22dead95083dd2ce8ae1475b20c064e25111f.tar.gz
gentoo-2-a5c22dead95083dd2ce8ae1475b20c064e25111f.tar.bz2
gentoo-2-a5c22dead95083dd2ce8ae1475b20c064e25111f.zip
version bump
(Portage version: 2.1.6.4/cvs/Linux 2.6.28.1 i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/ChangeLog9
-rw-r--r--games-emulation/stella/stella-2.7.1.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index ba5788ed354a..0e10c75bbf94 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.32 2008/09/29 16:24:20 mr_bones_ Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.33 2009/01/27 03:16:24 mr_bones_ Exp $
+
+*stella-2.7.1 (27 Jan 2009)
+
+ 27 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> +stella-2.7.1.ebuild:
+ version bump
29 Sep 2008; Michael Sterrett <mr_bones_@gentoo.org>
files/stella-2.6.1-gcc43.patch:
diff --git a/games-emulation/stella/stella-2.7.1.ebuild b/games-emulation/stella/stella-2.7.1.ebuild
new file mode 100644
index 000000000000..6e90c4d6b0d2
--- /dev/null
+++ b/games-emulation/stella/stella-2.7.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-2.7.1.ebuild,v 1.1 2009/01/27 03:16:24 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl
+ media-libs/libpng
+ opengl? ( virtual/opengl )"
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/STRIP/d' \
+ -e "/icons/d" \
+ -e '/INSTALL.*DOCDIR/d' \
+ -e '/INSTALL.*\/applications/d' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_configure() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl gl) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon src/common/stella.png
+ make_desktop_entry stella Stella
+ dohtml -r docs/*
+ dodoc Announce.txt Changes.txt Copyright.txt README-GP2X.txt README-SDL.txt Readme.txt Todo.txt
+ prepgamesdirs
+}