summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-08 15:08:40 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-08 15:08:40 +0000
commitc7603d76f33132c7c61f83550d2d253e468712a7 (patch)
tree6d51d29a09f17932869980176865cfcea8767640 /games-emulation
parentversion bump (diff)
downloadgentoo-2-c7603d76f33132c7c61f83550d2d253e468712a7.tar.gz
gentoo-2-c7603d76f33132c7c61f83550d2d253e468712a7.tar.bz2
gentoo-2-c7603d76f33132c7c61f83550d2d253e468712a7.zip
old
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/advancemame/advancemame-0.61.1.ebuild95
-rw-r--r--games-emulation/advancemame/advancemame-0.70.0.ebuild113
-rw-r--r--games-emulation/advancemame/advancemame-0.76.0.ebuild67
-rw-r--r--games-emulation/advancemame/advancemame-0.77.2.ebuild43
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.61.12
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.70.03
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.76.02
7 files changed, 15 insertions, 310 deletions
diff --git a/games-emulation/advancemame/advancemame-0.61.1.ebuild b/games-emulation/advancemame/advancemame-0.61.1.ebuild
deleted file mode 100644
index 81bef166fd96..000000000000
--- a/games-emulation/advancemame/advancemame-0.61.1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.61.1.ebuild,v 1.2 2004/01/06 03:53:00 mr_bones_ Exp $
-
-# This build we configure to explicitly use SDL, as it is very
-# difficult to get it working with fb or svgalib support. Anyway,
-# it do not look as good ;-)
-
-# Snapshot support
-SNAPSHOT="20020824"
-
-MY_PV="$(echo ${PV} | cut -d. -f1,2)"
-S="${WORKDIR}/advmame"
-DESCRIPTION="GNU/Linux port of the MAME emulator, with GUI menu."
-# Handle snapshots differently
-if [ -z "${SNAPSHOT}" ] ; then
- SRC_URI="mirror://sourceforge/advancemame/${P}.zip"
- MY_A="${P}.zip"
-else
- SRC_URI="mirror://gentoo/${PN}-${SNAPSHOT}.tar.bz2"
- MY_A="${PN}-${SNAPSHOT}.tar.bz2"
-fi
-SRC_URI="${SRC_URI}
- http://mbnet.fi/~gridle/mame${MY_PV/\.}s.zip
- http://www.mame.net/zips/mame${MY_PV/\.}s.zip
- http://roms.mame.dk/emu/mame${MY_PV/\.}s.zip"
-HOMEPAGE="http://advancemame.sourceforge.net/"
-
-LICENSE="GPL-2 xmame"
-SLOT="0"
-KEYWORDS="x86 -ppc"
-
-DEPEND="virtual/x11
- app-arch/unzip
- >=dev-lang/nasm-0.98
- >=media-libs/libsdl-1.2.3"
-
-src_unpack() {
- unpack mame${MY_PV/\.}s.zip
-
- mkdir -p ${S}
-
- cd ${S}
- # Unpack mame and advacemame
- unzip -aa ${WORKDIR}/MAME.ZIP || die
- # Handle snapshots differently
- if [ -z "${SNAPSHOT}" ] ; then
- unzip -aa -o ${DISTDIR}/${P}.zip || die
- else
- tar -jxf ${DISTDIR}/${PN}-${SNAPSHOT}.tar.bz2 || die
- fi
-
- # This one is from MAME.ZIP, and breaks things if present
- rm -f makefile
-
- cd ${S}/src
- # Apply the advancemame patch to the mame sources
- patch -p1 < ../advance/advmame.dif || die
-
- # Fix manpage/doc install location
- cp ${S}/advance/advance.mak ${S}/advance/advance.mak.orig
- sed -e 's:$(PREFIX)/doc/advance:$(PREFIX)/share/doc/$(PF):g' \
- -e 's:$(PREFIX)/man/man1:$(PREFIX)/share/man/man1:g' \
- ${S}/advance/advance.mak.orig > ${S}/advance/advance.mak
-}
-
-src_compile() {
- # Configure with explicit SDL support
- # NOTE: do not use econf, as we should not
- # pass --host ...
- ./configure \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --with-system=sdl \
- --enable-pthread \
- ${myconf} || die
-
- emake || die
-}
-
-src_install() {
- # The install script do not create this one
- dodir /usr/bin
- make PREFIX=${D}/usr install || die
-
- dodoc COPYING whatsnew.txt
- dodoc docs/{ctrlr.txt,listinfo.txt,mame.txt}
- # Zip the docs that was installed by 'make install'
- gzip ${D}/usr/share/doc/${PF}/*.txt
-
- # Move the html pages the the correct location
- dodir /usr/share/doc/${PF}/html
- mv ${D}/usr/share/doc/${PF}/*.html ${D}/usr/share/doc/${PF}/html
-}
diff --git a/games-emulation/advancemame/advancemame-0.70.0.ebuild b/games-emulation/advancemame/advancemame-0.70.0.ebuild
deleted file mode 100644
index 2448b4fe4403..000000000000
--- a/games-emulation/advancemame/advancemame-0.70.0.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.70.0.ebuild,v 1.4 2004/01/06 03:53:00 mr_bones_ Exp $
-
-inherit eutils
-
-# This build we configure to explicitly use SDL, as it is very
-# difficult to get it working with fb or svgalib support. Anyway,
-# it do not look as good ;-)
-
-ADVMNU_VER="2.2.7"
-
-MY_PV="$(echo ${PV} | cut -d. -f1,2)"
-S="${WORKDIR}/advmame"
-DESCRIPTION="GNU/Linux port of the MAME emulator, with GUI menu."
-SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz
- mirror://sourceforge/advancemame/advancemenu-${ADVMNU_VER}.tar.gz
- http://mbnet.fi/~gridle/mame${MY_PV/\.}s.zip
- http://www.mame.net/zips/mame${MY_PV/\.}s.zip
- http://roms.mame.dk/emu/mame${MY_PV/\.}s.zip"
-HOMEPAGE="http://advancemame.sourceforge.net/"
-
-LICENSE="GPL-2 xmame"
-SLOT="0"
-KEYWORDS="~x86"
-
-RDEPEND="virtual/glibc
- app-arch/unzip
- >=dev-lang/nasm-0.98
- >=media-libs/libsdl-1.2.3
- slang? ( sys-libs/slang )
- svga? ( >=media-libs/svgalib-1.9 )"
-DEPEND="${RDEPEND}
- sys-kernel/linux-headers"
-
-src_unpack() {
- unpack ${A}
-
- mkdir -p ${S}
-
- cd ${S}
- # Unpack mame and advacemame
- unzip -qaa ${WORKDIR}/mame.zip || die
- cp -adf ${WORKDIR}/${P}/* .
- cp -adf ${WORKDIR}/advancemenu-${ADVMNU_VER}/* .
-
- # This one is from MAME.ZIP, and breaks things if present
- rm -f makefile
-
- cd ${S}/src
- # Apply the advancemame patch to the mame sources
- epatch ../advance/advmame.dif
-
- for x in os.c vslang.c
- do
- cp -f ${S}/advance/linux/${x} ${S}/advance/linux/${x}.orig
- sed -e 's:slang/slang.h:slang.h:' \
- ${S}/advance/linux/${x}.orig > ${S}/advance/linux/${x}
- rm -f ${S}/advance/linux/${x}.orig
- done
-
- # Fix manpage/doc install location
- cp -f ${S}/advance/advance.mak ${S}/advance/advance.mak.orig
- sed -e 's:$(PREFIX)/doc/advance:$(PREFIX)/share/doc/$(PF):g' \
- -e 's:$(PREFIX)/man/man1:$(PREFIX)/share/man/man1:g' \
- ${S}/advance/advance.mak.orig > ${S}/advance/advance.mak
- rm -f ${S}/advance/advance.mak.orig
-}
-
-src_compile() {
- local myconf=
-
- use fbcon || myconf="${myconf} --disable-fb"
-
- use oss || myconf="${myconf} --disable-oss"
-
- use alsa || myconf="${myconf} --disable-alsa"
-
- use slang || myconf="${myconf} --disable-slang"
-
- use svga || myconf="${myconf} --disable-svgalib"
-
- # Configure with explicit SDL support
- # NOTE: do not use econf, as we should not
- # pass --host ...
- ./configure \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --with-system=sdl \
- --enable-pthread \
- ${myconf} || die
-
- emake || die
-}
-
-src_install() {
- # The install script do not create this one
- dodir /usr/bin
- make PREFIX=${D}/usr install || die
-
- dodir /usr/share/advance/{artwork,diff,image,rom,sample,snap}
-
- dodoc COPYING HISTORY README RELEASE whatsnew.txt
- dodoc docs/{ctrlr.txt,listinfo.txt,mame.txt}
- # Zip the docs that was installed by 'make install'
- gzip ${D}/usr/share/doc/${PF}/*.txt
-
- # Move the html pages the the correct location
- dodir /usr/share/doc/${PF}/html
- mv -f ${D}/usr/share/doc/${PF}/*.html ${D}/usr/share/doc/${PF}/html
-}
-
diff --git a/games-emulation/advancemame/advancemame-0.76.0.ebuild b/games-emulation/advancemame/advancemame-0.76.0.ebuild
deleted file mode 100644
index b359bb5e5444..000000000000
--- a/games-emulation/advancemame/advancemame-0.76.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.76.0.ebuild,v 1.5 2004/01/06 03:53:00 mr_bones_ Exp $
-
-inherit games eutils
-
-DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
-HOMEPAGE="http://advancemame.sourceforge.net/"
-SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
-
-LICENSE="GPL-2 xmame"
-SLOT="0"
-KEYWORDS="~x86 ~ppc"
-
-RDEPEND="virtual/glibc
- app-arch/unzip
- x86? ( >=dev-lang/nasm-0.98 )
- media-libs/libsdl
- slang? ( sys-libs/slang )
- alsa? ( media-libs/alsa-lib )
- svga? ( >=media-libs/svgalib-1.9 )"
-DEPEND="${RDEPEND}
- virtual/os-headers"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- sed -i \
- 's:slang/slang\.h:slang.h:' \
- advance/linux/{os,vslang}.c
-}
-
-src_compile() {
- export PATH="${PATH}:${T}"
- ln -s `which nasm` ${T}/${CHOST}-nasm >& /dev/null
- egamesconf \
- --host="" \
- `use_enable debug` \
- `use_enable static` \
- `use_enable x86 asm` \
- `use_enable svga svgalib` \
- `use_enable fbconf fb` \
- `use_enable alsa` \
- `use_enable oss` \
- `use_enable slang` \
- `use_enable sdl` \
- --with-system=sdl \
- --enable-pthread \
- --with-emu=${PN/advance} \
- || die
- emake || die
-}
-
-src_install() {
- dogamesbin adv*
-
- dodir ${GAMES_DATADIR}/advance/{artwork,diff,image,rom,sample,snap}
- insinto ${GAMES_DATADIR}/advance
- doins support/event.dat
-
- dodoc HISTORY README RELEASE obj/doc/*.txt
- dohtml obj/doc/*.html
- for m in obj/doc/*.1 ; do
- newman ${m} ${m/.1/.6}
- done
-}
diff --git a/games-emulation/advancemame/advancemame-0.77.2.ebuild b/games-emulation/advancemame/advancemame-0.77.2.ebuild
index 2daac573f9dc..229ecb6005ea 100644
--- a/games-emulation/advancemame/advancemame-0.77.2.ebuild
+++ b/games-emulation/advancemame/advancemame-0.77.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.77.2.ebuild,v 1.1 2004/01/06 03:53:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.77.2.ebuild,v 1.2 2004/01/08 15:08:39 vapier Exp $
-inherit games
+inherit games eutils
DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
HOMEPAGE="http://advancemame.sourceforge.net/"
@@ -10,7 +10,8 @@ SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
LICENSE="GPL-2 xmame"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~ppc"
+IUSE="debug static svga fbcon alsa oss slang"
RDEPEND="virtual/glibc
app-arch/unzip
@@ -20,53 +21,39 @@ RDEPEND="virtual/glibc
alsa? ( media-libs/alsa-lib )
svga? ( >=media-libs/svgalib-1.9 )"
DEPEND="${RDEPEND}
- >=sys-apps/sed-4
virtual/os-headers"
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- sed -i \
- -e 's:slang/slang\.h:slang.h:' advance/linux/{os,vslang}.c \
- || die "sed failed"
-}
-
src_compile() {
export PATH="${PATH}:${T}"
- ln -s `which nasm` ${T}/${CHOST}-nasm >& /dev/null
+ ln -s `which nasm` ${T}/${CHOST}-nasm
egamesconf \
- --host="" \
`use_enable debug` \
`use_enable static` \
`use_enable x86 asm` \
`use_enable svga svgalib` \
- `use_enable fbconf fb` \
+ `use_enable fbcon fb` \
`use_enable alsa` \
`use_enable oss` \
`use_enable slang` \
- `use_enable sdl` \
- --with-system=sdl \
- --enable-pthread \
--with-emu=${PN/advance} \
- || die
- emake || die "emake failed"
+ || die
+ emake || die
}
src_install() {
- local m
-
dogamesbin adv* || die "dogamesbin failed"
dodir ${GAMES_DATADIR}/advance/{artwork,diff,image,rom,sample,snap}
insinto ${GAMES_DATADIR}/advance
- doins support/event.dat || die "doins failed"
+ doins support/event.dat
- dodoc HISTORY README RELEASE obj/doc/*.txt || die "dodoc failed"
- dohtml obj/doc/*.html || die "dohtml failed"
+ dodoc HISTORY README RELEASE
cd obj/doc
+ dodoc *.txt
+ dohtml *.html
for m in *.1 ; do
- newman ${m} ${m/.1/.6} || die "newman ${m} ${m/.1/.6} failed"
+ newman ${m} ${m/1/6}
done
+
prepgamesdirs
}
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.61.1 b/games-emulation/advancemame/files/digest-advancemame-0.61.1
deleted file mode 100644
index 95c7b989eaec..000000000000
--- a/games-emulation/advancemame/files/digest-advancemame-0.61.1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 189bcf88588017461ed8eafa0c086f58 advancemame-20020824.tar.bz2 943470
-MD5 069ba445724b236b315b1706bedfdb30 mame061s.zip 6072159
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.70.0 b/games-emulation/advancemame/files/digest-advancemame-0.70.0
deleted file mode 100644
index 5c4ac2245b1d..000000000000
--- a/games-emulation/advancemame/files/digest-advancemame-0.70.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 3f91dbe77df5d7ffd563d9f4eee4eb07 advancemame-0.70.0.tar.gz 1078285
-MD5 4dfd42997184969dbb9a9df77f78e20e advancemenu-2.2.7.tar.gz 1138523
-MD5 e400f8e6c50a0826d2da9113be725958 mame070s.zip 8655728
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.76.0 b/games-emulation/advancemame/files/digest-advancemame-0.76.0
deleted file mode 100644
index 7a22878780ee..000000000000
--- a/games-emulation/advancemame/files/digest-advancemame-0.76.0
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 a1171a694daae75aea427180be1ade60 advancemame-0.76.0.tar.gz 9988910
-MD5 22cc67451dd90c68bddd67157e5728d3 advancemenu-2.2.13.tar.gz 1207317