summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-10-22 18:18:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-10-22 18:18:25 +0000
commitcf535260d17e02177decc3aa66a6ef1068871f26 (patch)
tree420bef74c5b6a8a4e9c9f89932253ff3ff99566b /games-emulation
parentppc64 stable wrt #333421 (diff)
downloadgentoo-2-cf535260d17e02177decc3aa66a6ef1068871f26.tar.gz
gentoo-2-cf535260d17e02177decc3aa66a6ef1068871f26.tar.bz2
gentoo-2-cf535260d17e02177decc3aa66a6ef1068871f26.zip
Avoid linking against gtk+ (used by the built-in debugger) unless USE=debug is specified (bug #336062)
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/sdlmame/ChangeLog7
-rw-r--r--games-emulation/sdlmame/sdlmame-0.139_p4.ebuild29
2 files changed, 21 insertions, 15 deletions
diff --git a/games-emulation/sdlmame/ChangeLog b/games-emulation/sdlmame/ChangeLog
index 1b8917eda2c3..a5c5517336a0 100644
--- a/games-emulation/sdlmame/ChangeLog
+++ b/games-emulation/sdlmame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/sdlmame
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/sdlmame/ChangeLog,v 1.37 2010/10/20 08:10:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/sdlmame/ChangeLog,v 1.38 2010/10/22 18:18:25 mr_bones_ Exp $
+
+ 22 Oct 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ sdlmame-0.139_p4.ebuild:
+ Avoid linking against gtk+ (used by the built-in debugger) unless
+ USE=debug is specified (bug #336062)
*sdlmame-0.139_p4 (20 Oct 2010)
diff --git a/games-emulation/sdlmame/sdlmame-0.139_p4.ebuild b/games-emulation/sdlmame/sdlmame-0.139_p4.ebuild
index d0953651f69e..64226f2aa9de 100644
--- a/games-emulation/sdlmame/sdlmame-0.139_p4.ebuild
+++ b/games-emulation/sdlmame/sdlmame-0.139_p4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/sdlmame/sdlmame-0.139_p4.ebuild,v 1.1 2010/10/20 08:10:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/sdlmame/sdlmame-0.139_p4.ebuild,v 1.2 2010/10/22 18:18:25 mr_bones_ Exp $
EAPI=2
inherit eutils flag-o-matic games
@@ -24,14 +24,14 @@ IUSE="debug opengl"
RDEPEND=">=media-libs/libsdl-1.2.10[audio,joystick,opengl?,video]
dev-libs/expat
- x11-libs/libXinerama
debug? (
x11-libs/gtk+:2
gnome-base/gconf
+ x11-libs/libXinerama
)"
DEPEND="${RDEPEND}
app-arch/unzip
- x11-proto/xineramaproto"
+ debug? ( x11-proto/xineramaproto )"
S=${WORKDIR}
@@ -47,7 +47,7 @@ disable_feature() {
enable_feature() {
sed -i \
-e "/^#.*$1.*=/s:^# ::" \
- "${S}"/makefile \
+ "${S}"/${2:-makefile} \
|| die "sed failed"
}
@@ -87,28 +87,29 @@ src_prepare() {
fi
if use debug; then
- einfo "Enabling DEBUG support"
+ einfo "Enabling debug support"
enable_feature DEBUG
+ else
+ einfo "Disabling debug support"
+ enable_feature NO_X11 src/osd/sdl/sdl.mak
+ fi
+
+ if ! use opengl ; then
+ einfo "Disabling opengl support"
+ enable_feature NO_OPENGL src/osd/sdl/sdl.mak
fi
}
src_compile() {
- local make_opts
-
- use opengl || make_opts="${make_opts} NO_OPENGL=1"
-
emake \
NAME="${PN}" \
OPT_FLAGS='-DINI_PATH=\"\$$HOME/.'${PN}'\;'"${GAMES_SYSCONFDIR}/${PN}"'\"'" ${CXXFLAGS}" \
CC="${CXX}" \
- SUFFIX="" \
- ${make_opts} \
- all \
- || die "emake failed"
+ all || die
}
src_install() {
- dogamesbin ${PN}$(use amd64 && echo 64) || die
+ newgamesbin ${PN}$(use amd64 && echo 64)$(use debug && echo d) ${PN} || die
# Avoid collision on /usr/games/bin/jedutil
exeinto "$(games_get_libdir)/${PN}"