summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-11-08 20:25:24 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-11-08 20:25:24 +0000
commitd34e0a2feeb5fe9a6520164ce35aeb2ef3b6f534 (patch)
treec9cb98596b6e7707f013fd218cd4b8dc0ec42e37 /games-emulation
parenttouch (diff)
downloadgentoo-2-d34e0a2feeb5fe9a6520164ce35aeb2ef3b6f534.tar.gz
gentoo-2-d34e0a2feeb5fe9a6520164ce35aeb2ef3b6f534.tar.bz2
gentoo-2-d34e0a2feeb5fe9a6520164ce35aeb2ef3b6f534.zip
old
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/atari800/atari800-1.3.4.ebuild91
-rw-r--r--games-emulation/atari800/atari800-1.3.5.ebuild91
-rw-r--r--games-emulation/atari800/files/digest-atari800-1.3.42
-rw-r--r--games-emulation/atari800/files/digest-atari800-1.3.52
4 files changed, 0 insertions, 186 deletions
diff --git a/games-emulation/atari800/atari800-1.3.4.ebuild b/games-emulation/atari800/atari800-1.3.4.ebuild
deleted file mode 100644
index e5324617c30f..000000000000
--- a/games-emulation/atari800/atari800-1.3.4.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/atari800/atari800-1.3.4.ebuild,v 1.2 2005/03/29 01:04:48 luckyduck Exp $
-
-inherit games
-
-DESCRIPTION="Atari 800 emulator"
-HOMEPAGE="http://atari800.sourceforge.net/"
-SRC_URI="mirror://sourceforge/atari800/${P}.tar.gz
- mirror://sourceforge/atari800/xf25.zip"
-
-LICENSE="GPL-1"
-SLOT="0"
-KEYWORDS="x86 ppc sparc alpha"
-IUSE="sdl"
-
-RDEPEND="virtual/x11
- sdl? ( >=media-libs/libsdl-1.2.0 )"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # remove some not-so-interesting ones
- rm -f DOC/{INSTALL.*,*.in,CHANGES.OLD}
-}
-
-src_compile() {
- local target="x11"
- use sdl && target="sdl"
-
- cd src && \
- egamesconf \
- --enable-crashmenu \
- --enable-break \
- --enable-hints \
- --enable-asm \
- --enable-cursorblk \
- --enable-led \
- --enable-displayled \
- --enable-sndclip \
- --enable-linuxjoy \
- --enable-sound \
- --target=${target} \
- || die
- emake || die "emake failed"
-}
-
-src_install () {
- dogamesbin src/atari800 || die "dogamesbin failed"
- newman src/atari800.man atari800.6
- dodoc README.1ST DOC/*
- insinto "${GAMES_DATADIR}/${PN}"
- doins "${WORKDIR}/"*.ROM || die "doins failed (ROM)"
- insinto /etc
- doins "${FILESDIR}/atari800.cfg" || die "doins failed (cfg)"
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- if use sdl ; then
- echo
- echo
- einfo 'The emulator has been compiled using the SDL libraries. By default,'
- einfo 'atari800 switches to fullscreen mode, so a 400x300 entry in your'
- einfo 'XF86Config-4 file is recommended. Otherwise, the emulated Atari'
- einfo 'screen is postage-stamp sized in the middle of your display.'
- echo
- einfo 'For example, in the "Screen" section of your /etc/XF86Config-4 file,'
- einfo 'add the entry "400x300" to the end of the list of modes:'
- echo
- einfo ' Section "Screen"'
- einfo ' [...]'
- einfo
- einfo ' Subsection "Display"'
- einfo ' Depth 16'
- einfo ' Modes "1600x1200" "1024x768" "400x300"'
- einfo ' ViewPort 0 0'
- einfo ' EndSubsection'
- einfo ' EndSection'
- echo
- einfo 'You should not need to specify a modeline for this mode,'
- einfo 'since in most cases it is a standard mode calculated by'
- einfo 'the X server.'
- echo
- echo
- echo
- fi
-}
diff --git a/games-emulation/atari800/atari800-1.3.5.ebuild b/games-emulation/atari800/atari800-1.3.5.ebuild
deleted file mode 100644
index ea1b1ed670f7..000000000000
--- a/games-emulation/atari800/atari800-1.3.5.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/atari800/atari800-1.3.5.ebuild,v 1.2 2005/03/29 01:04:48 luckyduck Exp $
-
-inherit games
-
-DESCRIPTION="Atari 800 emulator"
-HOMEPAGE="http://atari800.sourceforge.net/"
-SRC_URI="mirror://sourceforge/atari800/${P}.tar.gz
- mirror://sourceforge/atari800/xf25.zip"
-
-LICENSE="GPL-1"
-SLOT="0"
-KEYWORDS="x86 ppc sparc alpha ~amd64"
-IUSE="sdl"
-
-RDEPEND="virtual/x11
- sdl? ( >=media-libs/libsdl-1.2.0 )"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # remove some not-so-interesting ones
- rm -f DOC/{INSTALL.*,*.in,CHANGES.OLD}
-}
-
-src_compile() {
- local target="x11"
- use sdl && target="sdl"
-
- cd src && \
- egamesconf \
- --enable-crashmenu \
- --enable-break \
- --enable-hints \
- --enable-asm \
- --enable-cursorblk \
- --enable-led \
- --enable-displayled \
- --enable-sndclip \
- --enable-linuxjoy \
- --enable-sound \
- --target=${target} \
- || die
- emake || die "emake failed"
-}
-
-src_install () {
- dogamesbin src/atari800 || die "dogamesbin failed"
- newman src/atari800.man atari800.6
- dodoc README.1ST DOC/*
- insinto "${GAMES_DATADIR}/${PN}"
- doins "${WORKDIR}/"*.ROM || die "doins failed (ROM)"
- insinto /etc
- doins "${FILESDIR}/atari800.cfg" || die "doins failed (cfg)"
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- if use sdl ; then
- echo
- echo
- einfo 'The emulator has been compiled using the SDL libraries. By default,'
- einfo 'atari800 switches to fullscreen mode, so a 400x300 entry in your'
- einfo 'XF86Config-4 file is recommended. Otherwise, the emulated Atari'
- einfo 'screen is postage-stamp sized in the middle of your display.'
- echo
- einfo 'For example, in the "Screen" section of your /etc/XF86Config-4 file,'
- einfo 'add the entry "400x300" to the end of the list of modes:'
- echo
- einfo ' Section "Screen"'
- einfo ' [...]'
- einfo
- einfo ' Subsection "Display"'
- einfo ' Depth 16'
- einfo ' Modes "1600x1200" "1024x768" "400x300"'
- einfo ' ViewPort 0 0'
- einfo ' EndSubsection'
- einfo ' EndSection'
- echo
- einfo 'You should not need to specify a modeline for this mode,'
- einfo 'since in most cases it is a standard mode calculated by'
- einfo 'the X server.'
- echo
- echo
- echo
- fi
-}
diff --git a/games-emulation/atari800/files/digest-atari800-1.3.4 b/games-emulation/atari800/files/digest-atari800-1.3.4
deleted file mode 100644
index 9ceb438ff9f4..000000000000
--- a/games-emulation/atari800/files/digest-atari800-1.3.4
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 e971d58d0cc272c5891ffb0160c779c5 atari800-1.3.4.tar.gz 1005741
-MD5 4dc3b6b4313e9596c4d474785a37b94d xf25.zip 188942
diff --git a/games-emulation/atari800/files/digest-atari800-1.3.5 b/games-emulation/atari800/files/digest-atari800-1.3.5
deleted file mode 100644
index e822fe35ddd3..000000000000
--- a/games-emulation/atari800/files/digest-atari800-1.3.5
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 299922f3a1086410302eafe35c76b1cb atari800-1.3.5.tar.gz 1007863
-MD5 4dc3b6b4313e9596c4d474785a37b94d xf25.zip 188942