summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-04-17 04:49:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-04-17 04:49:09 +0000
commitf86817462ad1dc21291c803cf2e5341ddcdce0b2 (patch)
tree26e321746e583f5a33784186da25f2544cf7da46 /games-emulation
parentgcc4 fix, okay'ed by Obz (diff)
downloadgentoo-2-f86817462ad1dc21291c803cf2e5341ddcdce0b2.tar.gz
gentoo-2-f86817462ad1dc21291c803cf2e5341ddcdce0b2.tar.bz2
gentoo-2-f86817462ad1dc21291c803cf2e5341ddcdce0b2.zip
version bump (bug #88896)
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gxmame/ChangeLog8
-rw-r--r--games-emulation/gxmame/Manifest4
-rw-r--r--games-emulation/gxmame/files/digest-gxmame-0.35_beta21
-rw-r--r--games-emulation/gxmame/gxmame-0.35_beta2.ebuild67
4 files changed, 78 insertions, 2 deletions
diff --git a/games-emulation/gxmame/ChangeLog b/games-emulation/gxmame/ChangeLog
index 129ba0429f08..cfc840e31437 100644
--- a/games-emulation/gxmame/ChangeLog
+++ b/games-emulation/gxmame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/gxmame
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gxmame/ChangeLog,v 1.11 2005/03/02 00:25:49 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gxmame/ChangeLog,v 1.12 2005/04/17 04:49:09 mr_bones_ Exp $
+
+*gxmame-0.35_beta2 (17 Apr 2005)
+
+ 17 Apr 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +gxmame-0.35_beta2.ebuild:
+ version bump (bug #88896)
*gxmame-0.35_beta1 (01 Mar 2005)
diff --git a/games-emulation/gxmame/Manifest b/games-emulation/gxmame/Manifest
index d082f4a7f67f..3a7855b09538 100644
--- a/games-emulation/gxmame/Manifest
+++ b/games-emulation/gxmame/Manifest
@@ -1,6 +1,8 @@
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 4baea7d1680b95ea8543555f1da4dc24 gxmame-0.35_beta2.ebuild 1529
MD5 f977092e819e2bf5b59e19556d19c201 ChangeLog 2123
MD5 3c391220e1273d53b76461723213693f gxmame-0.34b.ebuild 970
-MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 4baea7d1680b95ea8543555f1da4dc24 gxmame-0.35_beta1.ebuild 1529
MD5 fc586b42205f2bfd474e189d0a04c930 files/digest-gxmame-0.34b 64
+MD5 853a1274f81d89c374aa86897c827e8d files/digest-gxmame-0.35_beta2 68
MD5 0115ef1fc76d84d56929cf1b5f00c40f files/digest-gxmame-0.35_beta1 68
diff --git a/games-emulation/gxmame/files/digest-gxmame-0.35_beta2 b/games-emulation/gxmame/files/digest-gxmame-0.35_beta2
new file mode 100644
index 000000000000..5bc306b79326
--- /dev/null
+++ b/games-emulation/gxmame/files/digest-gxmame-0.35_beta2
@@ -0,0 +1 @@
+MD5 2ef166272fe2d6b0dfe51dd1616a851c gxmame-0.35beta2.tar.gz 697013
diff --git a/games-emulation/gxmame/gxmame-0.35_beta2.ebuild b/games-emulation/gxmame/gxmame-0.35_beta2.ebuild
new file mode 100644
index 000000000000..c3f2a28303b4
--- /dev/null
+++ b/games-emulation/gxmame/gxmame-0.35_beta2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gxmame/gxmame-0.35_beta2.ebuild,v 1.1 2005/04/17 04:49:09 mr_bones_ Exp $
+
+inherit games
+
+MY_P="${PN}-${PV/_beta/beta}"
+DESCRIPTION="frontend for XMame using the GTK library"
+HOMEPAGE="http://gxmame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gxmame/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls joystick"
+RESTRICT="nostrip"
+
+DEPEND="virtual/x11
+ dev-libs/expat
+ >=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.4
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:-O2 -fomit-frame-pointer -ffast-math:${CFLAGS}:" \
+ -e "s:-O2:${CFLAGS}:" \
+ configure \
+ || die "sed failed"
+ sed -i \
+ -e 's:COPYING::' \
+ -e "s:^docdir = .*:docdir = /usr/share/doc/${PF}:" \
+ -e "s:^htmldir = .*:htmldir = /usr/share/doc/${PF}/html:" \
+ -e "s:^icondir = .*:icondir = /usr/share/icons:" \
+ -e "s:^pixmapdir = .*:pixmapdir = /usr/share/pixmaps:" \
+ -e "s:^gnulocaledir = .*:gnulocaledir = /usr/share/locale:" \
+ -e "s:^icon2dir = .*:icon2dir = /usr/share/icons/mini:" \
+ -e "s:^Graphicsdir = .*:Graphicsdir = /usr/share/applications:" \
+ -e "/DDATADIR/s:\$(datadir):/usr/share/pixmaps:" \
+ -e "/DPACKAGE_LOCALE_DIR/s:\$(datadir):/usr/share:" \
+ Makefile.in html/Makefile.in src/Makefile.in po/Makefile.in.in \
+ || die "sed failed"
+ sed -i \
+ -e 's/"gxmame"/""/' src/gui.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ $(use_enable joystick) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+ prepgamesdirs
+}