summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-07-31 01:45:09 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-07-31 01:45:09 +0000
commit6a6bf127aae8c0d8cf2cb39d9cb82ba339f9c5c2 (patch)
tree006df1888470184137acebaaf2095e1f4d347a7a /games-engines/odamex
parentVersion bump to 1.23. Bump to EAPI=5. (diff)
downloadgentoo-2-6a6bf127aae8c0d8cf2cb39d9cb82ba339f9c5c2.tar.gz
gentoo-2-6a6bf127aae8c0d8cf2cb39d9cb82ba339f9c5c2.tar.bz2
gentoo-2-6a6bf127aae8c0d8cf2cb39d9cb82ba339f9c5c2.zip
version bump, remove old
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-engines/odamex')
-rw-r--r--games-engines/odamex/ChangeLog12
-rw-r--r--games-engines/odamex/files/1-odamex-0.6.4-install-rules.patch79
-rw-r--r--games-engines/odamex/files/2-odamex-0.6.4-cmake-options.patch77
-rw-r--r--games-engines/odamex/files/3-odamex-0.6.4-wad-search-path.patch59
-rw-r--r--games-engines/odamex/files/4-odamex-0.6.4-odalauncher-bin-path.patch51
-rw-r--r--games-engines/odamex/files/odamex-0.6.1-build.patch212
-rw-r--r--games-engines/odamex/odamex-0.6.4.ebuild (renamed from games-engines/odamex/odamex-0.6.1.ebuild)17
7 files changed, 289 insertions, 218 deletions
diff --git a/games-engines/odamex/ChangeLog b/games-engines/odamex/ChangeLog
index e5c21361fc1b..f42dd2918b93 100644
--- a/games-engines/odamex/ChangeLog
+++ b/games-engines/odamex/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for games-engines/odamex
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/odamex/ChangeLog,v 1.11 2013/07/06 16:25:05 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/odamex/ChangeLog,v 1.12 2013/07/31 01:45:09 hasufell Exp $
+
+*odamex-0.6.4 (31 Jul 2013)
+
+ 31 Jul 2013; Julian Ospald <hasufell@gentoo.org> -odamex-0.6.1.ebuild,
+ -files/odamex-0.6.1-build.patch, +odamex-0.6.4.ebuild,
+ +files/2-odamex-0.6.4-cmake-options.patch,
+ +files/1-odamex-0.6.4-install-rules.patch,
+ +files/4-odamex-0.6.4-odalauncher-bin-path.patch,
+ +files/3-odamex-0.6.4-wad-search-path.patch:
+ version bump, remove old
06 Jul 2013; Agostino Sarubbo <ago@gentoo.org> odamex-0.6.3.ebuild:
Stable for x86, wrt bug #474376
diff --git a/games-engines/odamex/files/1-odamex-0.6.4-install-rules.patch b/games-engines/odamex/files/1-odamex-0.6.4-install-rules.patch
new file mode 100644
index 000000000000..48205033d621
--- /dev/null
+++ b/games-engines/odamex/files/1-odamex-0.6.4-install-rules.patch
@@ -0,0 +1,79 @@
+commit 04fff802ee72c08d2e1730c6c5506fc2e708d5fe
+Author: hasufell <hasufell@gentoo.org>
+Date: Wed Jul 31 03:34:29 2013 +0200
+
+ BUILD: add unix install rules
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b77096a..f49a1e8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -2,6 +2,8 @@
+ project(Odamex)
+ cmake_minimum_required(VERSION 2.8)
+
++# cmake modules
++include( GNUInstallDirs )
+ set(PROJECT_VERSION 0.6.4)
+ set(PROJECT_COPYRIGHT "2006-2013")
+
+@@ -64,3 +66,8 @@ add_subdirectory(odalaunch)
+ if(NOT NO_AG-ODALAUNCH_TARGET)
+ add_subdirectory(ag-odalaunch)
+ endif()
++
++# global install rules
++if(UNIX)
++ install(FILES odamex.wad DESTINATION ${CMAKE_INSTALL_DATADIR})
++endif()
+diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
+index 5dd5d43..1fde0ff 100644
+--- a/client/CMakeLists.txt
++++ b/client/CMakeLists.txt
+@@ -168,5 +168,8 @@ if(SDL_FOUND AND SDLMIXER_FOUND)
+ " )
+ endif()
+
++ # UNIX install rules
++ elseif(UNIX)
++ install( TARGETS odamex DESTINATION ${CMAKE_INSTALL_BINDIR} )
+ endif()
+ endif()
+diff --git a/master/CMakeLists.txt b/master/CMakeLists.txt
+index c1c3853..3e94b34 100644
+--- a/master/CMakeLists.txt
++++ b/master/CMakeLists.txt
+@@ -12,3 +12,8 @@ if(WIN32)
+ elseif(SOLARIS)
+ target_link_libraries(odamast socket nsl)
+ endif()
++
++# install rules
++if(UNIX)
++ install( TARGETS odamast DESTINATION ${CMAKE_INSTALL_BINDIR} )
++endif()
+diff --git a/odalaunch/CMakeLists.txt b/odalaunch/CMakeLists.txt
+index ff9b6e3..d2d2171 100644
+--- a/odalaunch/CMakeLists.txt
++++ b/odalaunch/CMakeLists.txt
+@@ -61,3 +61,8 @@ if(wxWidgets_FOUND)
+ )
+ endif()
+ endif()
++
++# install rules
++if(UNIX)
++ install( TARGETS odalaunch DESTINATION ${CMAKE_INSTALL_BINDIR} )
++endif()
+diff --git a/server/CMakeLists.txt b/server/CMakeLists.txt
+index 2284a8a..a079434 100644
+--- a/server/CMakeLists.txt
++++ b/server/CMakeLists.txt
+@@ -61,3 +61,7 @@ if(UNIX AND NOT APPLE)
+ target_link_libraries(odasrv rt)
+ endif()
+
++# install rules
++if(UNIX)
++ install( TARGETS odasrv DESTINATION ${CMAKE_INSTALL_BINDIR} )
++endif()
diff --git a/games-engines/odamex/files/2-odamex-0.6.4-cmake-options.patch b/games-engines/odamex/files/2-odamex-0.6.4-cmake-options.patch
new file mode 100644
index 000000000000..de0f0784ca97
--- /dev/null
+++ b/games-engines/odamex/files/2-odamex-0.6.4-cmake-options.patch
@@ -0,0 +1,77 @@
+commit 7abf37ed186701f0170bded26df8cbb8a99a21e1
+Author: hasufell <hasufell@gentoo.org>
+Date: Wed Jul 31 03:35:46 2013 +0200
+
+ BUILD: add various cmake options
+
+ to control building client/server/odalaunch
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f49a1e8..ca01bba 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -3,7 +3,15 @@ project(Odamex)
+ cmake_minimum_required(VERSION 2.8)
+
+ # cmake modules
++include( CMakeDependentOption )
+ include( GNUInstallDirs )
++
++# options
++option(BUILD_CLIENT "Build client target" 1)
++option(BUILD_SERVER "Build server target" 1)
++option(BUILD_MASTER "Build master server target" 1)
++cmake_dependent_option( BUILD_ODALAUNCH "Build odalaunch target" 1 BUILD_CLIENT 0 )
++cmake_dependent_option( ENABLE_PORTMIDI "Enable portmidi support" 1 BUILD_CLIENT 0 )
+ set(PROJECT_VERSION 0.6.4)
+ set(PROJECT_COPYRIGHT "2006-2013")
+
+@@ -56,10 +64,22 @@ endmacro(define_platform)
+ set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/modules)
+
+ # Subdirectories for individual projects
+-add_subdirectory(client)
+-add_subdirectory(server)
+-add_subdirectory(master)
+-add_subdirectory(odalaunch)
++if(BUILD_CLIENT)
++ add_subdirectory(client)
++endif()
++if(BUILD_SERVER)
++ add_subdirectory(server)
++endif()
++if(BUILD_MASTER)
++ add_subdirectory(master)
++endif()
++if(BUILD_ODALAUNCH)
++ add_subdirectory(odalaunch)
++endif()
++
++if(NOT BUILD_CLIENT AND NOT BUILD_SERVER AND NOT BUILD_MASTER)
++ message(FATAL_ERROR "No target chosen, doing nothing.")
++endif()
+
+ # Disable the ag-odalaunch target completely: -DNO_AG-ODALAUNCH_TARGET
+ # This is only really useful when setting up a universal build.
+diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
+index 1fde0ff..9f06fa6 100644
+--- a/client/CMakeLists.txt
++++ b/client/CMakeLists.txt
+@@ -48,7 +48,7 @@ endif()
+
+ # PortMidi configuration
+ find_package(PortMidi)
+-if(PORTMIDI_FOUND)
++if(PORTMIDI_FOUND AND ENABLE_PORTMIDI)
+ include_directories(${PORTMIDI_INCLUDE_DIR})
+ add_definitions(-DPORTMIDI)
+ else()
+@@ -95,7 +95,7 @@ if(SDL_FOUND AND SDLMIXER_FOUND)
+ target_link_libraries(odamex ${SDL_LIBRARY})
+ target_link_libraries(odamex ${SDLMIXER_LIBRARY})
+
+- if(PORTMIDI_FOUND)
++ if(PORTMIDI_FOUND AND ENABLE_PORTMIDI)
+ target_link_libraries(odamex ${PORTMIDI_LIBRARIES})
+ endif()
+
diff --git a/games-engines/odamex/files/3-odamex-0.6.4-wad-search-path.patch b/games-engines/odamex/files/3-odamex-0.6.4-wad-search-path.patch
new file mode 100644
index 000000000000..3eb6953cfe85
--- /dev/null
+++ b/games-engines/odamex/files/3-odamex-0.6.4-wad-search-path.patch
@@ -0,0 +1,59 @@
+commit 3a5209e2595e459a31c111f6040dbac347df1967
+Author: hasufell <hasufell@gentoo.org>
+Date: Wed Jul 31 03:38:10 2013 +0200
+
+ add odamex.wad install destination to wad search path
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ca01bba..83a0e30 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -12,6 +12,16 @@ option(BUILD_SERVER "Build server target" 1)
+ option(BUILD_MASTER "Build master server target" 1)
+ cmake_dependent_option( BUILD_ODALAUNCH "Build odalaunch target" 1 BUILD_CLIENT 0 )
+ cmake_dependent_option( ENABLE_PORTMIDI "Enable portmidi support" 1 BUILD_CLIENT 0 )
++
++configure_file (
++ "${PROJECT_SOURCE_DIR}/config.h.in"
++ "${PROJECT_BINARY_DIR}/config.h"
++ )
++
++include_directories(
++ ${PROJECT_BINARY_DIR}
++)
++
+ set(PROJECT_VERSION 0.6.4)
+ set(PROJECT_COPYRIGHT "2006-2013")
+
+diff --git a/common/d_main.cpp b/common/d_main.cpp
+index 010bdcb..6dc2e5f 100644
+--- a/common/d_main.cpp
++++ b/common/d_main.cpp
+@@ -23,6 +23,7 @@
+ //-----------------------------------------------------------------------------
+
+ #include "version.h"
++#include "config.h"
+
+ #include <sstream>
+ #include <string>
+@@ -493,6 +494,7 @@ static std::string BaseFileSearch(std::string file, std::string ext = "", std::s
+ D_AddSearchDir(dirs, getenv("DOOMWADDIR"), separator);
+ D_AddSearchDir(dirs, getenv("DOOMWADPATH"), separator);
+ D_AddSearchDir(dirs, getenv("HOME"), separator);
++ D_AddSearchDir(dirs, CMAKE_WADDIR, separator);
+
+ // [AM] Search additional paths based on platform
+ D_AddPlatformSearchDirs(dirs);
+diff --git a/config.h.in b/config.h.in
+new file mode 100644
+index 0000000..e91b3a6
+--- /dev/null
++++ b/config.h.in
+@@ -0,0 +1,6 @@
++#ifndef CONFIG_H
++#define CONFIG_H
++
++#define CMAKE_WADDIR "@CMAKE_INSTALL_DATADIR@"
++
++#endif
diff --git a/games-engines/odamex/files/4-odamex-0.6.4-odalauncher-bin-path.patch b/games-engines/odamex/files/4-odamex-0.6.4-odalauncher-bin-path.patch
new file mode 100644
index 000000000000..22244987d458
--- /dev/null
+++ b/games-engines/odamex/files/4-odamex-0.6.4-odalauncher-bin-path.patch
@@ -0,0 +1,51 @@
+commit a6c55c51dc251924be7eccf6637fc719a2b7ace0
+Author: hasufell <hasufell@gentoo.org>
+Date: Wed Jul 31 03:38:24 2013 +0200
+
+ use CMAKE_BINDIR as default bin patch in odalauncher
+
+diff --git a/config.h.in b/config.h.in
+index e91b3a6..7019a02 100644
+--- a/config.h.in
++++ b/config.h.in
+@@ -2,5 +2,6 @@
+ #define CONFIG_H
+
+ #define CMAKE_WADDIR "@CMAKE_INSTALL_DATADIR@"
++#define CMAKE_BINDIR "@CMAKE_INSTALL_BINDIR@"
+
+ #endif
+diff --git a/odalaunch/src/dlg_main.cpp b/odalaunch/src/dlg_main.cpp
+index 915b527..f01224a 100644
+--- a/odalaunch/src/dlg_main.cpp
++++ b/odalaunch/src/dlg_main.cpp
+@@ -27,6 +27,7 @@
+ #include "str_utils.h"
+
+ #include "md5.h"
++#include "config.h"
+
+ #include <wx/settings.h>
+ #include <wx/menu.h>
+@@ -42,6 +43,7 @@
+ #include <wx/process.h>
+ #include <wx/toolbar.h>
+ #include <wx/xrc/xmlres.h>
++#include <wx/string.h>
+ #include <wx/cmdline.h>
+
+ #ifdef __WXMSW__
+@@ -200,10 +202,12 @@ dlgMain::dlgMain(wxWindow* parent, wxWindowID id)
+ }
+ #endif
+
++ const char *cmake_bindir_str = CMAKE_BINDIR;
++ wxString cmake_bindir = wxString::FromAscii(cmake_bindir_str);
+ launchercfg_s.get_list_on_start = 1;
+ launchercfg_s.show_blocked_servers = 0;
+ launchercfg_s.wad_paths = wxGetCwd();
+- launchercfg_s.odamex_directory = wxGetCwd();
++ launchercfg_s.odamex_directory = cmake_bindir;
+
+ m_LstCtrlServers = XRCCTRL(*this, "Id_LstCtrlServers", LstOdaServerList);
+ m_LstCtrlPlayers = XRCCTRL(*this, "Id_LstCtrlPlayers", LstOdaPlayerList);
diff --git a/games-engines/odamex/files/odamex-0.6.1-build.patch b/games-engines/odamex/files/odamex-0.6.1-build.patch
deleted file mode 100644
index 152d19211200..000000000000
--- a/games-engines/odamex/files/odamex-0.6.1-build.patch
+++ /dev/null
@@ -1,212 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Sun Jul 15 10:08:51 UTC 2012
-Subject: build system
-
-a. add install rules and make paths modifiable
-b. add odamex.wad install destination to wad search path
-c. add various cmake options
-d. use CMAKE_BINDIR as default bin patch in odalauncher
-
---- odamex-src-0.6.1/CMakeLists.txt
-+++ odamex-src-0.6.1/CMakeLists.txt
-@@ -2,6 +2,26 @@
- project(Odamex)
- cmake_minimum_required(VERSION 2.8)
-
-+# cmake modules
-+include( CMakeDependentOption )
-+include( GNUInstallDirs )
-+
-+# options
-+option(BUILD_CLIENT "Build client target" 1)
-+option(BUILD_SERVER "Build server target" 1)
-+option(BUILD_MASTER "Build master server target" 1)
-+cmake_dependent_option( BUILD_ODALAUNCH "Build odalaunch target" 1 BUILD_CLIENT 0 )
-+cmake_dependent_option( ENABLE_PORTMIDI "Enable portmidi support" 1 BUILD_CLIENT 0 )
-+
-+configure_file (
-+ "${PROJECT_SOURCE_DIR}/config.h.in"
-+ "${PROJECT_BINARY_DIR}/config.h"
-+ )
-+
-+include_directories(
-+ ${PROJECT_BINARY_DIR}
-+)
-+
- set(PROJECT_VERSION 0.6.1)
- set(PROJECT_COPYRIGHT "2006-2012")
-
-@@ -40,13 +60,31 @@
- set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/modules)
-
- # Subdirectories for individual projects
--add_subdirectory(client)
--add_subdirectory(server)
--add_subdirectory(master)
--add_subdirectory(odalaunch)
-+if(BUILD_CLIENT)
-+ add_subdirectory(client)
-+endif()
-+if(BUILD_SERVER)
-+ add_subdirectory(server)
-+endif()
-+if(BUILD_MASTER)
-+ add_subdirectory(master)
-+endif()
-+if(BUILD_ODALAUNCH)
-+ add_subdirectory(odalaunch)
-+endif()
-+
-+if(NOT BUILD_CLIENT AND NOT BUILD_SERVER AND NOT BUILD_MASTER)
-+ message(FATAL_ERROR "No target chosen, doing nothing.")
-+endif()
-+
-
- # Disable the ag-odalaunch target completely: -DNO_AG-ODALAUNCH_TARGET
- # This is only really useful when setting up a universal build.
- if(NOT NO_AG-ODALAUNCH_TARGET)
- add_subdirectory(ag-odalaunch)
- endif()
-+
-+# global install rules
-+if(UNIX)
-+ install(FILES odamex.wad DESTINATION ${CMAKE_INSTALL_DATADIR})
-+endif()
---- odamex-src-0.6.1/client/CMakeLists.txt
-+++ odamex-src-0.6.1/client/CMakeLists.txt
-@@ -52,7 +52,7 @@
-
- # Portmidi configuration
- find_package(PortMidi)
--if(PortMidi_FOUND)
-+if(PortMidi_FOUND AND ENABLE_PORTMIDI)
- include_directories(${PortMidi_INCLUDE_DIR})
- ADD_DEFINITIONS(-DPORTMIDI ${PortMidi_CFLAGS})
- else()
-@@ -141,5 +141,8 @@
- " )
- endif()
-
-+ # UNIX install rules
-+ elseif(UNIX)
-+ install( TARGETS odamex DESTINATION ${CMAKE_INSTALL_BINDIR} )
- endif()
- endif()
---- odamex-src-0.6.1/master/CMakeLists.txt
-+++ odamex-src-0.6.1/master/CMakeLists.txt
-@@ -12,3 +12,9 @@
- elseif(SOLARIS)
- target_link_libraries(odamast socket nsl)
- endif()
-+
-+# install rules
-+if(UNIX)
-+ install( TARGETS odamast DESTINATION ${CMAKE_INSTALL_BINDIR} )
-+endif()
-+
---- odamex-src-0.6.1/odalaunch/CMakeLists.txt
-+++ odamex-src-0.6.1/odalaunch/CMakeLists.txt
-@@ -61,3 +61,9 @@
- )
- endif()
- endif()
-+
-+# install rules
-+if(UNIX)
-+ install( TARGETS odalaunch DESTINATION ${CMAKE_INSTALL_BINDIR} )
-+endif()
-+
---- odamex-src-0.6.1/server/CMakeLists.txt
-+++ odamex-src-0.6.1/server/CMakeLists.txt
-@@ -39,3 +39,8 @@
- elseif(SOLARIS)
- target_link_libraries(odasrv socket nsl)
- endif()
-+
-+# install rules
-+if(UNIX)
-+ install( TARGETS odasrv DESTINATION ${CMAKE_INSTALL_BINDIR} )
-+endif()
---- /dev/null
-+++ odamex-src-0.6.1/config.h.in
-@@ -0,0 +1,7 @@
-+#ifndef CONFIG_H
-+#define CONFIG_H
-+
-+#define CMAKE_WADDIR "@CMAKE_INSTALL_DATADIR@"
-+#define CMAKE_BINDIR "@CMAKE_INSTALL_BINDIR@"
-+
-+#endif
---- odamex-src-0.6.1/client/src/d_main.cpp
-+++ odamex-src-0.6.1/client/src/d_main.cpp
-@@ -25,6 +25,7 @@
- //-----------------------------------------------------------------------------
-
- #include "version.h"
-+#include "config.h"
-
- #include <sstream>
- #include <string>
-@@ -836,6 +837,7 @@
- D_AddSearchDir(dirs, getenv("DOOMWADPATH"), separator);
- D_AddSearchDir(dirs, getenv("HOME"), separator);
- D_AddSearchDir(dirs, waddirs.cstring(), separator);
-+ D_AddSearchDir(dirs, CMAKE_WADDIR, separator);
-
- dirs.erase(std::unique(dirs.begin(), dirs.end()), dirs.end());
-
---- odamex-src-0.6.1/server/src/d_main.cpp
-+++ odamex-src-0.6.1/server/src/d_main.cpp
-@@ -25,6 +25,7 @@
- //-----------------------------------------------------------------------------
-
- #include "version.h"
-+#include "config.h"
-
- #include <sstream>
- #include <string>
-@@ -628,9 +629,9 @@
- D_AddSearchDir(dirs, Args.CheckValue("-waddir"), separator);
- D_AddSearchDir(dirs, getenv("DOOMWADDIR"), separator);
- D_AddSearchDir(dirs, getenv("DOOMWADPATH"), separator);
-- D_AddSearchDir(dirs, getenv("HOME"), separator);
-- D_AddSearchDir(dirs, waddirs.cstring(), separator);
--
-+ D_AddSearchDir(dirs, getenv("HOME"), separator);
-+ D_AddSearchDir(dirs, waddirs.cstring(), separator);
-+ D_AddSearchDir(dirs, CMAKE_WADDIR, separator);
-
- dirs.erase(std::unique(dirs.begin(), dirs.end()), dirs.end());
-
---- odamex-src-0.6.1/odalaunch/src/dlg_main.cpp
-+++ odamex-src-0.6.1/odalaunch/src/dlg_main.cpp
-@@ -27,6 +27,7 @@
- #include "str_utils.h"
-
- #include "md5.h"
-+#include "config.h"
-
- #include <wx/settings.h>
- #include <wx/menu.h>
-@@ -42,6 +43,7 @@
- #include <wx/process.h>
- #include <wx/toolbar.h>
- #include <wx/xrc/xmlres.h>
-+#include <wx/string.h>
-
- #ifdef __WXMSW__
- #include <windows.h>
-@@ -190,10 +192,12 @@
- }
- #endif
-
-+ const char *cmake_bindir_str = CMAKE_BINDIR;
-+ wxString cmake_bindir = wxString::FromAscii(cmake_bindir_str);
- launchercfg_s.get_list_on_start = 1;
- launchercfg_s.show_blocked_servers = 0;
- launchercfg_s.wad_paths = wxGetCwd();
-- launchercfg_s.odamex_directory = wxGetCwd();
-+ launchercfg_s.odamex_directory = cmake_bindir;
-
- m_LstCtrlServers = XRCCTRL(*this, "Id_LstCtrlServers", LstOdaServerList);
- m_LstCtrlPlayers = XRCCTRL(*this, "Id_LstCtrlPlayers", LstOdaPlayerList);
diff --git a/games-engines/odamex/odamex-0.6.1.ebuild b/games-engines/odamex/odamex-0.6.4.ebuild
index ff4531bfc1dc..d8110e9cc705 100644
--- a/games-engines/odamex/odamex-0.6.1.ebuild
+++ b/games-engines/odamex/odamex-0.6.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/odamex/odamex-0.6.1.ebuild,v 1.3 2012/09/23 08:04:24 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/odamex/odamex-0.6.4.ebuild,v 1.1 2013/07/31 01:45:09 hasufell Exp $
-EAPI=4
+EAPI=5
WX_GTK_VER="2.8"
inherit cmake-utils eutils gnome2-utils wxwidgets games
@@ -13,22 +13,29 @@ SRC_URI="mirror://sourceforge/${PN}/Odamex/${PV}/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
IUSE="dedicated +odalaunch master portmidi server"
RDEPEND="
+ dedicated? ( >=net-libs/miniupnpc-1.8 )
!dedicated? (
>=media-libs/libsdl-1.2.9[X,audio,joystick,video]
>=media-libs/sdl-mixer-1.2.6
odalaunch? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
portmidi? ( media-libs/portmidi )
+ server? ( >=net-libs/miniupnpc-1.8 )
)"
DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/1-${P}-install-rules.patch \
+ "${FILESDIR}"/2-${P}-cmake-options.patch \
+ "${FILESDIR}"/3-${P}-wad-search-path.patch \
+ "${FILESDIR}"/4-${P}-odalauncher-bin-path.patch
+
+ epatch_user
}
src_configure() {