summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-01-02 07:21:42 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-01-02 07:21:42 +0000
commitaee2550885a661c9a9738a3da4c167aeda91948c (patch)
tree42c2cbb8f1adfcefb74c977645c415b6e53554c8 /games-engines/qtads/qtads-1.6c.ebuild
parentStable for HPPA (bug #203290). (diff)
downloadgentoo-2-aee2550885a661c9a9738a3da4c167aeda91948c.tar.gz
gentoo-2-aee2550885a661c9a9738a3da4c167aeda91948c.tar.bz2
gentoo-2-aee2550885a661c9a9738a3da4c167aeda91948c.zip
use eqmake3 to avoid trying to build against qt4
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-engines/qtads/qtads-1.6c.ebuild')
-rw-r--r--games-engines/qtads/qtads-1.6c.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/games-engines/qtads/qtads-1.6c.ebuild b/games-engines/qtads/qtads-1.6c.ebuild
index bfe8183ed62e..6ff5eb5369b4 100644
--- a/games-engines/qtads/qtads-1.6c.ebuild
+++ b/games-engines/qtads/qtads-1.6c.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/qtads/qtads-1.6c.ebuild,v 1.4 2007/01/26 08:32:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/qtads/qtads-1.6c.ebuild,v 1.5 2008/01/02 07:21:42 mr_bones_ Exp $
inherit flag-o-matic qt3 games
@@ -23,12 +23,10 @@ src_unpack() {
src_compile () {
append-flags -fno-strict-aliasing
- addpredict "${QTDIR}"/etc/settings
- qmake \
- BIN_INSTALL="${GAMES_BINDIR}" \
- DOC_INSTALL=/usr/share/doc/${PF} \
- DATA_INSTALL="${GAMES_DATADIR}" \
- qtads.pro
+ BIN_INSTALL="${GAMES_BINDIR}" \
+ DOC_INSTALL=/usr/share/doc/${PF} \
+ DATA_INSTALL="${GAMES_DATADIR}" \
+ eqmake3 qtads.pro
emake || die "emake failed"
}