summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-06-26 17:14:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-06-26 17:14:22 +0000
commit1e6eb0765f4c6132796b2c2a6746905d7ef48c28 (patch)
tree3f39dac99e2f86aefbec4d756deeffc7a52f5a0c /games-engines
parentDrop alpha/ia64 keyword as we don't have hardware to test (diff)
downloadgentoo-2-1e6eb0765f4c6132796b2c2a6746905d7ef48c28.tar.gz
gentoo-2-1e6eb0765f4c6132796b2c2a6746905d7ef48c28.tar.bz2
gentoo-2-1e6eb0765f4c6132796b2c2a6746905d7ef48c28.zip
version bump
(Portage version: 2.1.2.7)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog8
-rw-r--r--games-engines/scummvm/files/digest-scummvm-0.10.03
-rw-r--r--games-engines/scummvm/scummvm-0.10.0.ebuild90
3 files changed, 100 insertions, 1 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index addb5d8dd08a..3d71c19e31a3 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-engines/scummvm
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.46 2007/05/12 03:46:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.47 2007/06/26 17:14:22 mr_bones_ Exp $
+
+*scummvm-0.10.0 (26 Jun 2007)
+
+ 26 Jun 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +scummvm-0.10.0.ebuild:
+ version bump
12 May 2007; Michael Sterrett <mr_bones_@gentoo.org> scummvm-0.9.1.ebuild:
patch from Marek Szuba to make the engine find its data files in the
diff --git a/games-engines/scummvm/files/digest-scummvm-0.10.0 b/games-engines/scummvm/files/digest-scummvm-0.10.0
new file mode 100644
index 000000000000..36f25dec9795
--- /dev/null
+++ b/games-engines/scummvm/files/digest-scummvm-0.10.0
@@ -0,0 +1,3 @@
+MD5 398bbd5616a54aae8dbe7d9e6c55f064 scummvm-0.10.0.tar.bz2 4756977
+RMD160 6de5ecbf1006f47287fd665acaf6af1fdaf27b8b scummvm-0.10.0.tar.bz2 4756977
+SHA256 c9d1c68937cde4e4f2ba01c9b43bc745721fdd6c89064b3a60cf5ba2d7263126 scummvm-0.10.0.tar.bz2 4756977
diff --git a/games-engines/scummvm/scummvm-0.10.0.ebuild b/games-engines/scummvm/scummvm-0.10.0.ebuild
new file mode 100644
index 000000000000..82bc446875d5
--- /dev/null
+++ b/games-engines/scummvm/scummvm-0.10.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.10.0.ebuild,v 1.1 2007/06/26 17:14:22 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa debug flac fluidsynth mp3 ogg vorbis zlib"
+RESTRICT="test" # it only looks like there's a test there #77507
+
+RDEPEND=">=media-libs/libsdl-1.2.2
+ >media-libs/libmpeg2-0.3.1
+ ogg? ( media-libs/libogg media-libs/libvorbis )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ mp3? ( media-libs/libmad )
+ flac? ( media-libs/flac )
+ fluidsynth? ( media-sound/fluidsynth )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if use x86 ; then
+ local f
+ for f in graphics/scaler/{hq3x_i386.asm,hq2x_i386.asm}
+ do
+ cat >> $f <<EOF
+ %ifidn __OUTPUT_FORMAT__,elf
+ section .note.GNU-stack noalloc noexec nowrite progbits
+ %endif
+EOF
+ done
+ fi
+}
+
+src_compile() {
+ local myconf="--backend=sdl" # x11 backend no worky (bug #83502)
+
+ # let the engine find its data files in the right place (bug #178116)
+ myconf="${myconf} --datadir=${GAMES_DATADIR}"
+
+ ( use vorbis || use ogg ) \
+ && myconf="${myconf} --enable-vorbis" \
+ || myconf="${myconf} --disable-vorbis --disable-mpeg2"
+
+ # bug #137547
+ use fluidsynth || myconf="${myconf} --disable-fluidsynth"
+
+ # NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
+ # mpeg2 support needs vorbis (bug #79149) so turn it off if -oggvorbis
+ ./configure \
+ $(use_enable debug) \
+ $(use_enable alsa) \
+ $(use_enable mp3 mad) \
+ $(use_enable flac) \
+ $(use_enable zlib) \
+ $(use_enable x86 nasm) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin scummvm || die "dobin failed"
+ doman dists/scummvm.6
+ dodoc AUTHORS NEWS README TODO
+ insinto "${GAMES_DATADIR}"/${PN}/engines
+ doins gui/themes/modern.*
+ doicon icons/scummvm.xpm
+ make_desktop_entry scummvm ScummVM scummvm.xpm "Game;AdventureGame"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "If you want to use the new \"modern\" theme for ${PN},"
+ elog "add the following line to the [scummvm] section of"
+ elog "your ~/.scummvmrc file (after running scummvm once):"
+ elog "themepath=${GAMES_DATADIR}/${PN}/engines/"
+}