summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-05 22:53:08 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-05 22:53:08 +0000
commit042cfd671c6cdc05870115f381f45eff97b4fed0 (patch)
tree4ae297f99f4100e9dc6ca886179fe13e8b7b4cc4 /games-fps/aaquake2
parentquake-data -> quake1 #111622 (diff)
downloadgentoo-2-042cfd671c6cdc05870115f381f45eff97b4fed0.tar.gz
gentoo-2-042cfd671c6cdc05870115f381f45eff97b4fed0.tar.bz2
gentoo-2-042cfd671c6cdc05870115f381f45eff97b4fed0.zip
quake2-data -> quake2 #111622
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'games-fps/aaquake2')
-rw-r--r--games-fps/aaquake2/aaquake2-0.1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/games-fps/aaquake2/aaquake2-0.1.ebuild b/games-fps/aaquake2/aaquake2-0.1.ebuild
index c7c0b9afda10..a1484b978c0e 100644
--- a/games-fps/aaquake2/aaquake2-0.1.ebuild
+++ b/games-fps/aaquake2/aaquake2-0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/aaquake2-0.1.ebuild,v 1.6 2005/09/26 18:07:01 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/aaquake2-0.1.ebuild,v 1.7 2005/11/05 22:50:48 vapier Exp $
inherit eutils games
@@ -20,11 +20,11 @@ RDEPEND="media-libs/aalib"
DEPEND="${RDEPEND}
app-arch/unzip"
-S="${WORKDIR}/quake2-3.21/linux"
+S=${WORKDIR}/quake2-3.21/linux
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${PV}-gentoo.patch
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
cd quake2-3.21/linux
sed -i \
-e "s:GENTOO_DIR:${GAMES_LIBDIR}/${PN}:" sys_linux.c
@@ -36,7 +36,7 @@ src_compile() {
mkdir -p releasei386-glibc/ref_soft
make \
GENTOO_CFLAGS="${CFLAGS}" \
- GENTOO_DATADIR=${GAMES_DATADIR}/quake2-data/baseq2/ \
+ GENTOO_DATADIR="${GAMES_DATADIR}"/quake2/baseq2/ \
build_release || die
}
@@ -44,15 +44,15 @@ src_install() {
cd release*
exeinto ${GAMES_LIBDIR}/${PN}
- doexe gamei386.so ref_softaa.so
+ doexe gamei386.so ref_softaa.so || die
dosym ref_softaa.so ${GAMES_LIBDIR}/${PN}/ref_softx.so
dosym ref_softaa.so ${GAMES_LIBDIR}/${PN}/ref_soft.so
exeinto ${GAMES_LIBDIR}/${PN}/ctf
- doexe ctf/gamei386.so
+ doexe ctf/gamei386.so || die
- newgamesbin quake2 aaquake2
+ newgamesbin quake2 aaquake2 || die
- dodir ${GAMES_DATADIR}/quake2-data
+ dodir ${GAMES_DATADIR}/quake2
insinto ${GAMES_SYSCONFDIR}
echo ${GAMES_LIBDIR}/${PN} > ${PN}.conf