summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-09 18:10:15 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-09 18:10:15 +0000
commitc22ea1f9962983b3583d00085024413d77102212 (patch)
treeacd80fa59d92f27b0609b3d58893ef500cd09925 /games-fps/cube
parentNew version 'n cleanup (diff)
downloadgentoo-2-c22ea1f9962983b3583d00085024413d77102212.tar.gz
gentoo-2-c22ea1f9962983b3583d00085024413d77102212.tar.bz2
gentoo-2-c22ea1f9962983b3583d00085024413d77102212.zip
games-fps uNF uNF uNF
Diffstat (limited to 'games-fps/cube')
-rw-r--r--games-fps/cube/ChangeLog18
-rw-r--r--games-fps/cube/Manifest8
-rw-r--r--games-fps/cube/cube-20021020-r1.ebuild71
-rw-r--r--games-fps/cube/cube-20021020-r2.ebuild86
-rw-r--r--games-fps/cube/cube-20021020.ebuild67
-rw-r--r--games-fps/cube/files/cube-20021020-add-custom-paths.patch43
-rw-r--r--games-fps/cube/files/digest-cube-200210201
-rw-r--r--games-fps/cube/files/digest-cube-20021020-r12
-rw-r--r--games-fps/cube/files/digest-cube-20021020-r22
9 files changed, 298 insertions, 0 deletions
diff --git a/games-fps/cube/ChangeLog b/games-fps/cube/ChangeLog
new file mode 100644
index 000000000000..4e68113f55ce
--- /dev/null
+++ b/games-fps/cube/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for app-games/cube
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/cube/ChangeLog,v 1.1 2003/09/09 18:10:14 vapier Exp $
+
+*cube-20021020-r2 (03 Mar 2003)
+
+ 03 Mar 2003; Mike Frysinger <vapier@gentoo.org> :
+ Added binaries per #12997 to fix public network playing.
+
+*cube-20021020-r1 (28 Dec 2002)
+
+ 28 Dec 2002; Mike Frysinger <vapier@gentoo.org> :
+ Added patch per #12997 to fix network hanging bug.
+
+*cube-20021020 (17 Dec 2002)
+
+ 17 Dec 2002; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me for #11975.
diff --git a/games-fps/cube/Manifest b/games-fps/cube/Manifest
new file mode 100644
index 000000000000..d51452ca4145
--- /dev/null
+++ b/games-fps/cube/Manifest
@@ -0,0 +1,8 @@
+MD5 ba53442437392745d60d1f5e331fcfcc ChangeLog 630
+MD5 38abc41b03eb0f0c22aa74fa11e5b343 cube-20021020-r1.ebuild 1584
+MD5 7a7c076bbe3db6c3a1bedb30555fa8e4 cube-20021020-r2.ebuild 2451
+MD5 bd75d826f3064b82b9e537d15566adff cube-20021020.ebuild 1489
+MD5 f57600187e8eaa8d782ffd82c4aca198 files/cube-20021020-add-custom-paths.patch 1423
+MD5 191852b587a809d38195d7173e786a84 files/digest-cube-20021020 65
+MD5 c82b120eb1a0db91fd7c53f9c8cc6b77 files/digest-cube-20021020-r1 131
+MD5 c82b120eb1a0db91fd7c53f9c8cc6b77 files/digest-cube-20021020-r2 131
diff --git a/games-fps/cube/cube-20021020-r1.ebuild b/games-fps/cube/cube-20021020-r1.ebuild
new file mode 100644
index 000000000000..a54a4a328060
--- /dev/null
+++ b/games-fps/cube/cube-20021020-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/cube/cube-20021020-r1.ebuild,v 1.1 2003/09/09 18:10:14 vapier Exp $
+
+inherit games
+
+MY_P="cube_2002_10_20"
+DESCRIPTION="Landscape-style engine that pretends to be an indoor first person shooter engine"
+HOMEPAGE="http://wouter.fov120.com/cube/"
+SRC_URI="http://ludo.uib.no/cube/${MY_P}.zip
+ http://www.idi.ntnu.no/~jonasf/cube/${MY_P}.zip
+ http://tunes.org/~eihrul/${MY_P}.zip
+ http://tunes.org/~eihrul/enet_2002_10_28.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+DEPEND="virtual/opengl
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ sys-libs/zlib
+ media-libs/libpng"
+
+S=${WORKDIR}
+CUBE_DATADIR=${GAMES_DATADIR}/${PN}/
+
+src_unpack() {
+ unpack ${A}
+
+ cd source
+ unzip -qn ${MY_P}_src.zip
+
+ # enet_2002_10_28.tar.gz patch
+ rm -rf enet
+ mv ../enet .
+
+ cd src
+ patch -p0 < ${FILESDIR}/${P}-add-custom-paths.patch || die
+ echo "#define GAMES_DATADIR \"${CUBE_DATADIR}\"" >> tools.h
+ echo "#define GAMES_DATADIR_LEN ${#CUBE_DATADIR}" >> tools.h
+ for f in sound worldio ; do
+ f="${f}.cpp"
+ cp ${f} ${f}.old
+ sed -e "s:packages/:${CUBE_DATADIR}packages/:" ${f}.old > ${f}
+ done
+
+ for f in *.cpp ; do
+ cp ${f}{,.old}
+ sed -e 's/
+$//' ${f}.old > ${f}
+ done
+}
+
+src_compile() {
+ cd source/src
+ make || die
+}
+
+src_install() {
+ dogamesbin source/src/cube_{client,server}
+
+ dodir ${CUBE_DATADIR}
+ mv *.cfg data packages ${D}/${CUBE_DATADIR}
+
+ dodoc source/src/CUBE_TODO.txt
+ dohtml -r docs/
+
+ prepgamesdirs
+}
diff --git a/games-fps/cube/cube-20021020-r2.ebuild b/games-fps/cube/cube-20021020-r2.ebuild
new file mode 100644
index 000000000000..909fcf4644a6
--- /dev/null
+++ b/games-fps/cube/cube-20021020-r2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/cube/cube-20021020-r2.ebuild,v 1.1 2003/09/09 18:10:14 vapier Exp $
+
+inherit eutils games
+
+MY_P="cube_2002_10_20"
+DESCRIPTION="Landscape-style engine that pretends to be an indoor first person shooter engine"
+HOMEPAGE="http://wouter.fov120.com/cube/"
+SRC_URI="http://ludo.uib.no/cube/${MY_P}.zip
+ http://www.idi.ntnu.no/~jonasf/cube/${MY_P}.zip
+ http://tunes.org/~eihrul/${MY_P}.zip
+ http://tunes.org/~eihrul/enet_2002_10_28.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+DEPEND="virtual/opengl
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ sys-libs/zlib
+ media-libs/libpng"
+
+S=${WORKDIR}
+CUBE_DATADIR=${GAMES_DATADIR}/${PN}/
+
+src_unpack() {
+ unpack ${A}
+
+ cd source
+ unzip -qn ${MY_P}_src.zip || die
+
+ # enet_2002_10_28.tar.gz patch
+ rm -rf enet
+ mv ../enet .
+
+ cd src
+ epatch ${FILESDIR}/${P}-add-custom-paths.patch || die
+ echo "#define GAMES_DATADIR \"${CUBE_DATADIR}\"" >> tools.h
+ echo "#define GAMES_DATADIR_LEN ${#CUBE_DATADIR}" >> tools.h
+ for f in sound worldio ; do
+ f="${f}.cpp"
+ cp ${f} ${f}.old
+ sed -e "s:packages/:${CUBE_DATADIR}packages/:" ${f}.old > ${f}
+ done
+ edos2unix *.cpp
+}
+
+src_compile() {
+ cd source/src
+ make || die
+}
+
+src_install() {
+ dogamesbin source/src/cube_{client,server}
+ if [ "${ARCH}" == "x86" ] ; then
+ newgamesbin bin_unix/linux_client cube_client-bin
+ newgamesbin bin_unix/linux_server cube_server-bin
+ elif [ "${ARCH}" == "ppc" ] ; then
+ newgamesbin bin_unix/ppc_linux_client cube_client-bin
+ newgamesbin bin_unix/ppc_linux_server cube_server-bin
+ fi
+ echo "#!/bin/bash"$'\n'"cd ${CUBE_DATADIR}"$'\n'"cube_client-bin $@" > ${T}/client
+ echo "#!/bin/bash"$'\n'"cd ${CUBE_DATADIR}"$'\n'"cube_server-bin $@" > ${T}/server
+ newgamesbin ${T}/client playcubeclient
+ newgamesbin ${T}/server playcubeserver
+
+ dodir ${CUBE_DATADIR}
+ mv *.cfg data packages ${D}/${CUBE_DATADIR}
+
+ dodoc source/src/CUBE_TODO.txt
+ dohtml -r docs/
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ einfo "You now have 3 clients and 3 servers:"
+ einfo "cube_client-bin prebuilt version (needed to play on public multiplayer servers)"
+ einfo "playcubeclient wrapper to setup path's for the prebuilt binary"
+ einfo "cube_client custom client built from source"
+ einfo "Parallel versions of the server have been installed"
+ games_pkg_postinst
+}
diff --git a/games-fps/cube/cube-20021020.ebuild b/games-fps/cube/cube-20021020.ebuild
new file mode 100644
index 000000000000..33bd228198da
--- /dev/null
+++ b/games-fps/cube/cube-20021020.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/cube/cube-20021020.ebuild,v 1.1 2003/09/09 18:10:14 vapier Exp $
+
+inherit games
+
+MY_P="cube_2002_10_20"
+DESCRIPTION="Landscape-style engine that pretends to be an indoor first person shooter engine"
+HOMEPAGE="http://wouter.fov120.com/cube/"
+SRC_URI="http://ludo.uib.no/cube/${MY_P}.zip
+ http://www.idi.ntnu.no/~jonasf/cube/${MY_P}.zip
+ http://tunes.org/~eihrul/${MY_P}.zip"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ sys-libs/zlib
+ media-libs/libpng"
+#RDEPEND=""
+
+S=${WORKDIR}
+CUBE_DATADIR=${GAMES_DATADIR}/${PN}/
+
+src_unpack() {
+ unpack ${A}
+
+ cd source
+ unzip -qn ${MY_P}_src.zip
+
+ cd src
+ patch -p0 < ${FILESDIR}/${P}-add-custom-paths.patch || die
+ echo "#define GAMES_DATADIR \"${CUBE_DATADIR}\"" >> tools.h
+ echo "#define GAMES_DATADIR_LEN ${#CUBE_DATADIR}" >> tools.h
+ for f in sound worldio ; do
+ f="${f}.cpp"
+ cp ${f} ${f}.old
+ sed -e "s:packages/:${CUBE_DATADIR}packages/:" ${f}.old > ${f}
+ done
+
+ for f in *.cpp ; do
+ cp ${f}{,.old}
+ sed -e 's/ $//' ${f}.old > ${f}
+ done
+}
+
+src_compile() {
+ cd source/src
+ make || die
+}
+
+src_install() {
+ dogamesbin source/src/cube_{client,server}
+
+ dodir ${CUBE_DATADIR}
+ mv *.cfg data packages ${D}/${CUBE_DATADIR}
+
+ dodoc source/src/CUBE_TODO.txt
+ dohtml -r docs/
+
+ prepgamesdirs
+}
diff --git a/games-fps/cube/files/cube-20021020-add-custom-paths.patch b/games-fps/cube/files/cube-20021020-add-custom-paths.patch
new file mode 100644
index 000000000000..594a0714e5fb
--- /dev/null
+++ b/games-fps/cube/files/cube-20021020-add-custom-paths.patch
@@ -0,0 +1,43 @@
+--- tools.cpp.orig 2002-12-17 09:35:55.000000000 -0500
++++ tools.cpp 2002-12-17 09:39:28.000000000 -0500
+@@ -100,8 +100,19 @@
+
+ ///////////////////////// misc tools ///////////////////////
+
++char *addfullpath(char *s) {
++ static char ret[256]; // choose a reasonable max buffer size
++ if (s[0] == '/') { return s; }
++ int slen = strlen(s);
++ memset(ret, 0x00, 256);
++ memcpy(ret, GAMES_DATADIR, GAMES_DATADIR_LEN);
++ memcpy(ret+GAMES_DATADIR_LEN, s, slen);
++ return ret;
++}
++
+ char *path(char *s)
+ {
++ s = addfullpath(s);
+ for(char *t = s; t = strpbrk(t, "/\\"); *t++ = PATHDIV);
+ return s;
+ };
+--- rendergl.cpp.orig 2002-12-17 09:48:00.000000000 -0500
++++ rendergl.cpp 2002-12-17 09:50:19.000000000 -0500
+@@ -59,6 +59,7 @@
+
+ bool installtex(int tnum, char *texname, int &xs, int &ys, bool clamp)
+ {
++ texname = addfullpath(texname);
+ SDL_Surface *s = IMG_Load(texname);
+ if(!s) { conoutf("couldn't load texture %s", (int)texname); return false; };
+ if(s->format->BitsPerPixel!=24) { conoutf("texture must be 24bpp: %s", (int)texname); return false; };
+--- tools.h.orig 2002-12-17 09:51:06.000000000 -0500
++++ tools.h 2002-12-17 09:50:59.000000000 -0500
+@@ -96,7 +96,7 @@
+ #endif
+
+
+-
++extern char *addfullpath(char *s);
+ extern char *path(char *s);
+ extern char *loadfile(char *fn, int *size);
+ extern void endianswap(void *, int, int);
diff --git a/games-fps/cube/files/digest-cube-20021020 b/games-fps/cube/files/digest-cube-20021020
new file mode 100644
index 000000000000..a6f7c23f4db0
--- /dev/null
+++ b/games-fps/cube/files/digest-cube-20021020
@@ -0,0 +1 @@
+MD5 4b08234b81d7bf55e7d289df97c7c949 cube_2002_10_20.zip 9059119
diff --git a/games-fps/cube/files/digest-cube-20021020-r1 b/games-fps/cube/files/digest-cube-20021020-r1
new file mode 100644
index 000000000000..0149ba680ade
--- /dev/null
+++ b/games-fps/cube/files/digest-cube-20021020-r1
@@ -0,0 +1,2 @@
+MD5 4b08234b81d7bf55e7d289df97c7c949 cube_2002_10_20.zip 9059119
+MD5 a2afc8eca949b84efc1d991be9a89777 enet_2002_10_28.tar.gz 22797
diff --git a/games-fps/cube/files/digest-cube-20021020-r2 b/games-fps/cube/files/digest-cube-20021020-r2
new file mode 100644
index 000000000000..0149ba680ade
--- /dev/null
+++ b/games-fps/cube/files/digest-cube-20021020-r2
@@ -0,0 +1,2 @@
+MD5 4b08234b81d7bf55e7d289df97c7c949 cube_2002_10_20.zip 9059119
+MD5 a2afc8eca949b84efc1d991be9a89777 enet_2002_10_28.tar.gz 22797