summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-28 05:25:34 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-28 05:25:34 +0000
commit761cb33daa5b362c8a2a054c4f291a4b389cf4cc (patch)
tree0f867de75f1fbd3e9124ed1caee0bae1adac73f0 /games-fps/fuhquake-bin
parentMoved "app-sci/euler" to "sci-mathematics". (diff)
downloadgentoo-2-761cb33daa5b362c8a2a054c4f291a4b389cf4cc.tar.gz
gentoo-2-761cb33daa5b362c8a2a054c4f291a4b389cf4cc.tar.bz2
gentoo-2-761cb33daa5b362c8a2a054c4f291a4b389cf4cc.zip
initial ebuild #69855
Diffstat (limited to 'games-fps/fuhquake-bin')
-rw-r--r--games-fps/fuhquake-bin/ChangeLog8
-rw-r--r--games-fps/fuhquake-bin/Manifest2
-rw-r--r--games-fps/fuhquake-bin/files/digest-fuhquake-bin-0.313
-rw-r--r--games-fps/fuhquake-bin/fuhquake-bin-0.31.ebuild46
-rw-r--r--games-fps/fuhquake-bin/metadata.xml5
5 files changed, 64 insertions, 0 deletions
diff --git a/games-fps/fuhquake-bin/ChangeLog b/games-fps/fuhquake-bin/ChangeLog
new file mode 100644
index 000000000000..6386bcabfb77
--- /dev/null
+++ b/games-fps/fuhquake-bin/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-fps/fuhquake-bin
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/fuhquake-bin/ChangeLog,v 1.1 2004/12/28 05:25:34 vapier Exp $
+
+*fuhquake-bin-0.31 (28 Dec 2004)
+
+ 28 Dec 2004; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Justin #69855.
diff --git a/games-fps/fuhquake-bin/Manifest b/games-fps/fuhquake-bin/Manifest
new file mode 100644
index 000000000000..7759be4f029e
--- /dev/null
+++ b/games-fps/fuhquake-bin/Manifest
@@ -0,0 +1,2 @@
+MD5 a03d2700388eb18c67a89130137a94b7 fuhquake-bin-0.31.ebuild 3351
+MD5 073dc58c3b27fc65dbeafdf60586cb34 files/digest-fuhquake-bin-0.31 204
diff --git a/games-fps/fuhquake-bin/files/digest-fuhquake-bin-0.31 b/games-fps/fuhquake-bin/files/digest-fuhquake-bin-0.31
new file mode 100644
index 000000000000..43f7edac0d50
--- /dev/null
+++ b/games-fps/fuhquake-bin/files/digest-fuhquake-bin-0.31
@@ -0,0 +1,3 @@
+MD5 479a6f8dad1174333819e850b3aca8c1 fuhquake-linux-v0.31.zip 4520020
+MD5 eb2a89c0f89b945705f1bc81124642b6 fuhquake-security-v0.31.zip 161267
+MD5 6426eed6e49a25230eacd2db73b40cbe fuhquake_locs.zip 239163
diff --git a/games-fps/fuhquake-bin/fuhquake-bin-0.31.ebuild b/games-fps/fuhquake-bin/fuhquake-bin-0.31.ebuild
new file mode 100644
index 000000000000..52731adf0379
--- /dev/null
+++ b/games-fps/fuhquake-bin/fuhquake-bin-0.31.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/fuhquake-bin/fuhquake-bin-0.31.ebuild,v 1.1 2004/12/28 05:25:34 vapier Exp $
+
+inherit games
+
+DESCRIPTION="quakeworld client with a plethora of gameplay/console/graphical improvements"
+HOMEPAGE="http://www.fuhquake.net/"
+SRC_URI="http://www.fuhquake.net/files/releases/v${PV}/fuhquake-linux-v${PV}.zip
+ http://www.fuhquake.net/files/releases/v${PV}/fuhquake-security-v${PV}.zip
+ http://maps.quakeworld.nu/locs/download/fuhquake_locs.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="opengl svga X"
+
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/x11
+ svga? ( media-libs/svgalib )
+ opengl? ( virtual/opengl )"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack fuhquake-linux-v${PV}.zip fuhquake-security-v${PV}.zip
+ rm -f gnu.txt fuhquake-security.dll
+ mkdir qw/locs && cd qw/locs
+ unpack fuhquake_locs.zip
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ dodir ${dir}
+
+ exeinto ${dir}
+ doexe fuhquake-gl.glx fuhquake.svga fuhquake.x11 fuhquake-security.so || die "doexe"
+ cp -r fuhquake qw "${D}/${dir}"/ || die "cp data"
+ dosym ${GAMES_DATADIR}/quake-data ${dir}/id1
+
+ for x in fuhquake-gl.glx fuhquake.svga fuhquake.x11 ; do
+ games_make_wrapper ${x} ./${x} ${dir}
+ done
+
+ prepgamesdirs
+}
diff --git a/games-fps/fuhquake-bin/metadata.xml b/games-fps/fuhquake-bin/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/fuhquake-bin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>