summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-13 09:53:58 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-13 09:53:58 +0000
commit5ccb40c0ee1818c2922a26e4038d9b659d25eeb7 (patch)
tree18929b29e539a762872c06e1a03439b91ca32f0e /games-fps/industri
parentUse mirrors for the patchset. (diff)
downloadgentoo-2-5ccb40c0ee1818c2922a26e4038d9b659d25eeb7.tar.gz
gentoo-2-5ccb40c0ee1818c2922a26e4038d9b659d25eeb7.tar.bz2
gentoo-2-5ccb40c0ee1818c2922a26e4038d9b659d25eeb7.zip
Respect LDFLAGS. Bug #335518
(Portage version: 2.1.9.14/cvs/Linux i686)
Diffstat (limited to 'games-fps/industri')
-rw-r--r--games-fps/industri/ChangeLog6
-rw-r--r--games-fps/industri/files/industri-1.01-ldflags.patch20
-rw-r--r--games-fps/industri/industri-1.01.ebuild16
3 files changed, 32 insertions, 10 deletions
diff --git a/games-fps/industri/ChangeLog b/games-fps/industri/ChangeLog
index cf0b2a77c6ac..718478768f23 100644
--- a/games-fps/industri/ChangeLog
+++ b/games-fps/industri/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/industri
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/ChangeLog,v 1.11 2010/03/10 22:35:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/ChangeLog,v 1.12 2010/10/13 09:53:58 tupone Exp $
+
+ 13 Oct 2010; Tupone Alfredo <tupone@gentoo.org> industri-1.01.ebuild,
+ +files/industri-1.01-ldflags.patch:
+ Respect LDFLAGS. Bug #335518 by flameeyes@gentoo.org
10 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> industri-1.01.ebuild:
Fix building with libpng14 wrt #308891 by Locke Shinseiko.
diff --git a/games-fps/industri/files/industri-1.01-ldflags.patch b/games-fps/industri/files/industri-1.01-ldflags.patch
new file mode 100644
index 000000000000..987d464f6b48
--- /dev/null
+++ b/games-fps/industri/files/industri-1.01-ldflags.patch
@@ -0,0 +1,20 @@
+--- linux/Makefile.old 2010-10-13 11:37:27.000000000 +0200
++++ linux/Makefile 2010-10-13 11:38:20.000000000 +0200
+@@ -42,7 +42,7 @@
+ RELEASE_CFLAGS = $(BASE_CFLAGS) -O2 -march=pentium4 -pipe -msse -mfpmath=sse \
+ -fomit-frame-pointer -fexpensive-optimizations
+ DEBUG_CFLAGS = $(BASE_CFLAGS) -g
+-LDFLAGS = -lm -ldl $(X11_LIBS) $(OPENGL_LIBS) $(PNG_LIBS) $(OPENAL_LIBS)
++LDLIBS = -lm -ldl $(X11_LIBS) $(OPENGL_LIBS) $(PNG_LIBS) $(OPENAL_LIBS)
+
+ DO_GL_CC = $(CC) $(CFLAGS) -o $@ -c $<
+ DO_GL_AS = $(CC) $(CFLAGS) -DELF -x assembler-with-cpp -o $@ -c $<
+@@ -156,7 +156,7 @@
+
+
+ $(BUILDDIR)/bin/industri.run : $(GLQUAKE_OBJS)
+- $(CC) $(CFLAGS) -o $@ $(GLQUAKE_OBJS) $(LDFLAGS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $(GLQUAKE_OBJS) $(LDLIBS)
+
+ $(BUILDDIR)/glquake/cl_demo.o : $(MOUNT_DIR)/cl_demo.c
+ $(DO_GL_CC)
diff --git a/games-fps/industri/industri-1.01.ebuild b/games-fps/industri/industri-1.01.ebuild
index cf8d665b0b13..9ed669e3c83f 100644
--- a/games-fps/industri/industri-1.01.ebuild
+++ b/games-fps/industri/industri-1.01.ebuild
@@ -1,6 +1,7 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/industri-1.01.ebuild,v 1.16 2010/03/10 22:35:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/industri-1.01.ebuild,v 1.17 2010/10/13 09:53:58 tupone Exp $
+EAPI="2"
inherit eutils toolchain-funcs games
@@ -30,15 +31,11 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/industri_BIN
-src_unpack() {
- unpack ${A}
-
- cd "${S}"/linux
- mv Makefile.i386linux Makefile
- sed -i -e "s:-mpentiumpro.*:${CFLAGS} \\\\:" Makefile || die "sed failed"
+src_prepare() {
+ mv linux/Makefile{.i386linux,}
+ sed -i -e "s:-mpentiumpro.*:${CFLAGS} \\\\:" linux/Makefile || die "sed failed"
# Remove duplicated typedefs #71841
- cd "${S}"
for typ in PFNGLFLUSHVERTEXARRAYRANGEAPPLEPROC PFNGLVERTEXARRAYRANGEAPPLEPROC ; do
if echo '#include <GL/gl.h>' | $(tc-getCC) -E - 2>/dev/null | grep -sq ${typ} ; then
sed -i \
@@ -52,7 +49,8 @@ src_unpack() {
-e 's:png_set_gray_1_2_4_to_8:png_set_expand_gray_1_2_4_to_8:g' \
gl_warp.c || die
- epatch "${FILESDIR}"/${P}-exec-stack.patch
+ epatch "${FILESDIR}"/${P}-exec-stack.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
}
src_compile() {