summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-16 22:48:55 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-16 22:48:55 +0000
commitc8137e585fbdc81cdc43b458a4b6924376b40152 (patch)
treed60ce9d35039f3db82506ee435be9e8d4033c9c0 /games-fps/quake1-rally
parentditch unmaintained player (diff)
downloadgentoo-2-c8137e585fbdc81cdc43b458a4b6924376b40152.tar.gz
gentoo-2-c8137e585fbdc81cdc43b458a4b6924376b40152.tar.bz2
gentoo-2-c8137e585fbdc81cdc43b458a4b6924376b40152.zip
initial import
(Portage version: 2.0.51-r13)
Diffstat (limited to 'games-fps/quake1-rally')
-rw-r--r--games-fps/quake1-rally/ChangeLog8
-rw-r--r--games-fps/quake1-rally/Manifest4
-rw-r--r--games-fps/quake1-rally/files/digest-quake1-rally-1.22
-rw-r--r--games-fps/quake1-rally/metadata.xml5
-rw-r--r--games-fps/quake1-rally/quake1-rally-1.2.ebuild40
5 files changed, 59 insertions, 0 deletions
diff --git a/games-fps/quake1-rally/ChangeLog b/games-fps/quake1-rally/ChangeLog
new file mode 100644
index 000000000000..b23c6c553699
--- /dev/null
+++ b/games-fps/quake1-rally/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-fps/quake1-rally
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-rally/ChangeLog,v 1.1 2005/01/16 22:48:55 vapier Exp $
+
+*quake1-rally-1.2 (16 Jan 2004)
+
+ 16 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-fps/quake1-rally/Manifest b/games-fps/quake1-rally/Manifest
new file mode 100644
index 000000000000..7c2a57e41bb9
--- /dev/null
+++ b/games-fps/quake1-rally/Manifest
@@ -0,0 +1,4 @@
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 c6b49b840c90e4a336c21bff0287ed4a ChangeLog 249
+MD5 fd1f05bc3adf2639fda99abe2e27f6d5 quake-rally-1.2.ebuild 897
+MD5 e053b7b67887b99e7f3e70754c9b4450 files/digest-quake-rally-1.2 109
diff --git a/games-fps/quake1-rally/files/digest-quake1-rally-1.2 b/games-fps/quake1-rally/files/digest-quake1-rally-1.2
new file mode 100644
index 000000000000..5cd12e448359
--- /dev/null
+++ b/games-fps/quake1-rally/files/digest-quake1-rally-1.2
@@ -0,0 +1,2 @@
+MD5 654fab05fe33029896e3c08d5d8796b2 qr12.zip 9885866
+MD5 22f550d4e6afe5f43ad4ec2679832bdc qrlo1.zip 4086037
diff --git a/games-fps/quake1-rally/metadata.xml b/games-fps/quake1-rally/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/quake1-rally/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-fps/quake1-rally/quake1-rally-1.2.ebuild b/games-fps/quake1-rally/quake1-rally-1.2.ebuild
new file mode 100644
index 000000000000..8a7ece3d8337
--- /dev/null
+++ b/games-fps/quake1-rally/quake1-rally-1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-rally/quake1-rally-1.2.ebuild,v 1.1 2005/01/16 22:48:55 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="TC which turns Quake into a Rally racing game"
+HOMEPAGE="http://www.quakerally.com/"
+SRC_URI="
+ mirror://gentoo/qr12.zip
+ mirror://gentoo/qrlo1.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+src_unpack() {
+ echo ">>> Unpacking qr12.zip to ${PWD}"
+ unzip -qoL "${DISTDIR}"/qr12.zip || die "unpacking qr12.zip failed"
+ echo ">>> Unpacking qrlo1.zip to ${PWD}"
+ unzip -qoL "${DISTDIR}"/qrlo1.zip || die "unpacking qrlo1.zip failed"
+ rm -f button.wav qrally.exe
+ cd rally
+ edos2unix $(find . -name '*.txt' -o -name '*.cfg')
+ mv rally{,.example}.cfg
+}
+
+src_install() {
+ local dir=${GAMES_DATADIR}/quake-data
+ dodir "${dir}"
+ insinto "${dir}"
+ doins -r *
+ prepgamesdirs
+}