summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-03-27 18:38:21 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-03-27 18:38:21 +0000
commitb3aa18f6a9633cb367c0f7997fec9bd0daa4fb11 (patch)
treee9a55fe5e1c528cfc683ced697be744c38df1e98 /games-fps/quake3
parentInitial import. Ebuild by me. Closing bug #112107. (diff)
downloadgentoo-2-b3aa18f6a9633cb367c0f7997fec9bd0daa4fb11.tar.gz
gentoo-2-b3aa18f6a9633cb367c0f7997fec9bd0daa4fb11.tar.bz2
gentoo-2-b3aa18f6a9633cb367c0f7997fec9bd0daa4fb11.zip
Added initial support for quake3-teamarena.
(Portage version: 2.1_pre6-r6)
Diffstat (limited to 'games-fps/quake3')
-rw-r--r--games-fps/quake3/ChangeLog6
-rw-r--r--games-fps/quake3/quake3-1.34_alpha632.ebuild12
-rw-r--r--games-fps/quake3/quake3-9999.ebuild12
3 files changed, 17 insertions, 13 deletions
diff --git a/games-fps/quake3/ChangeLog b/games-fps/quake3/ChangeLog
index 646233c6145f..e956b3486441 100644
--- a/games-fps/quake3/ChangeLog
+++ b/games-fps/quake3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/quake3
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.33 2006/03/24 22:13:30 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.34 2006/03/27 18:38:21 wolf31o2 Exp $
+
+ 27 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ quake3-1.34_alpha632.ebuild, quake3-9999.ebuild:
+ Added initial support for quake3-teamarena.
24 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
-quake3-1.33_alpha510.ebuild:
diff --git a/games-fps/quake3/quake3-1.34_alpha632.ebuild b/games-fps/quake3/quake3-1.34_alpha632.ebuild
index b980d2fc2d85..1171c84aa2ec 100644
--- a/games-fps/quake3/quake3-1.34_alpha632.ebuild
+++ b/games-fps/quake3/quake3-1.34_alpha632.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.34_alpha632.ebuild,v 1.2 2006/03/24 20:01:36 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.34_alpha632.ebuild,v 1.3 2006/03/27 18:38:21 wolf31o2 Exp $
# quake3-9999 -> latest svn
# quake3-9999.REV -> use svn REV
@@ -10,12 +10,12 @@
if [[ ${PV} == 9999* ]] ; then
[[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999./}"
ESVN_REPO_URI="svn://svn.icculus.org/quake3/trunk"
- inherit subversion games toolchain-funcs
+ inherit subversion toolchain-funcs eutils games
SRC_URI=""
S=${WORKDIR}/trunk
elif [[ ${PV} == *_alpha* ]] ; then
- inherit games toolchain-funcs
+ inherit toolchain-funcs eutils games
MY_PV=${PV/_alpha*/}
SNAP=${PV/*_alpha/}
@@ -23,7 +23,7 @@ elif [[ ${PV} == *_alpha* ]] ; then
SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
S=${WORKDIR}/${MY_P}
else
- inherit games toolchain-funcs
+ inherit toolchain-funcs eutils games
SRC_URI="http://icculus.org/quake3/${P}.tar.bz2"
fi
@@ -57,7 +57,8 @@ RDEPEND="opengl? (
x11-libs/libXdmcp )
virtual/x11 )
media-libs/libsdl )
- games-fps/quake3-data"
+ games-fps/quake3-data
+ teamarena? ( games-fps/quake3-teamarena )"
src_unpack() {
if [[ ${PV} == 9999* ]] ; then
@@ -108,7 +109,6 @@ src_install() {
pkg_postinst() {
games_pkg_postinst
- echo
ewarn "The source version of Quake 3 will not work with Punk Buster."
ewarn "If you need pb support, then use the quake3-bin package."
echo
diff --git a/games-fps/quake3/quake3-9999.ebuild b/games-fps/quake3/quake3-9999.ebuild
index f54b4b9b858f..cd544c2d558c 100644
--- a/games-fps/quake3/quake3-9999.ebuild
+++ b/games-fps/quake3/quake3-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-9999.ebuild,v 1.1 2006/01/20 01:20:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-9999.ebuild,v 1.2 2006/03/27 18:38:21 wolf31o2 Exp $
# quake3-9999 -> latest svn
# quake3-9999.REV -> use svn REV
@@ -10,12 +10,12 @@
if [[ ${PV} == 9999* ]] ; then
[[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999.}"
ESVN_REPO_URI="svn://svn.icculus.org/quake3/trunk"
- inherit subversion games toolchain-funcs
+ inherit subversion toolchain-funcs eutils games
SRC_URI=""
S=${WORKDIR}/trunk
elif [[ ${PV} == *_alpha* ]] ; then
- inherit games toolchain-funcs
+ inherit toolchain-funcs eutils games
MY_PV=${PV/_alpha*}
SNAP=${PV/*_alpha}
@@ -23,7 +23,7 @@ elif [[ ${PV} == *_alpha* ]] ; then
SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
S=${WORKDIR}/${MY_P}
else
- inherit games toolchain-funcs
+ inherit toolchain-funcs eutils games
SRC_URI="http://icculus.org/quake3/${P}.tar.bz2"
fi
@@ -57,7 +57,8 @@ RDEPEND="opengl? (
x11-libs/libXdmcp )
virtual/x11 )
media-libs/libsdl )
- games-fps/quake3-data"
+ games-fps/quake3-data
+ teamarena? ( games-fps/quake3-teamarena )"
src_unpack() {
if [[ ${PV} == 9999* ]] ; then
@@ -106,7 +107,6 @@ src_install() {
pkg_postinst() {
games_pkg_postinst
- echo
ewarn "The source version of Quake 3 will not work with Punk Buster."
ewarn "If you need pb support, then use the quake3-bin package."
echo