summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-08-01 16:11:04 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-08-01 16:11:04 +0000
commit090c8dd5ebbc795d602f908a38ab21c56703e1b2 (patch)
tree642bf6e20670c4e4f31b8a193ec2f06d340215c3 /games-fps/quake4-bin
parentVersion bump, bug #142373. (diff)
downloadgentoo-2-090c8dd5ebbc795d602f908a38ab21c56703e1b2.tar.gz
gentoo-2-090c8dd5ebbc795d602f908a38ab21c56703e1b2.tar.bz2
gentoo-2-090c8dd5ebbc795d602f908a38ab21c56703e1b2.zip
Version bump to 1.3, now get out there fragging...
(Portage version: 2.1.1_pre4-r1)
Diffstat (limited to 'games-fps/quake4-bin')
-rw-r--r--games-fps/quake4-bin/ChangeLog8
-rw-r--r--games-fps/quake4-bin/files/digest-quake4-bin-1.33
-rw-r--r--games-fps/quake4-bin/quake4-bin-1.3.ebuild104
3 files changed, 114 insertions, 1 deletions
diff --git a/games-fps/quake4-bin/ChangeLog b/games-fps/quake4-bin/ChangeLog
index 1918a5a0af11..366a72eb126a 100644
--- a/games-fps/quake4-bin/ChangeLog
+++ b/games-fps/quake4-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/quake4-bin
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake4-bin/ChangeLog,v 1.23 2006/07/07 19:58:49 augustus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake4-bin/ChangeLog,v 1.24 2006/08/01 16:11:04 wolf31o2 Exp $
+
+*quake4-bin-1.3 (01 Aug 2006)
+
+ 01 Aug 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +quake4-bin-1.3.ebuild:
+ Version bump to 1.3, now get out there fragging...
07 Jul 2006; Kristopher Kersey <augustus@gentoo.org>
quake4-bin-1.2.1.ebuild:
diff --git a/games-fps/quake4-bin/files/digest-quake4-bin-1.3 b/games-fps/quake4-bin/files/digest-quake4-bin-1.3
new file mode 100644
index 000000000000..15e803869b89
--- /dev/null
+++ b/games-fps/quake4-bin/files/digest-quake4-bin-1.3
@@ -0,0 +1,3 @@
+MD5 90f9c1390e38e723e62a5a07fd96cc91 quake4-linux-1.3.x86.run 239447744
+RMD160 7af969998f7ad59fb2bd4f8a8a04708e15bea93e quake4-linux-1.3.x86.run 239447744
+SHA256 3ac59bec1e4b3120677ed062293582fb72d2b2bbb11bdaab35efb8f03500c688 quake4-linux-1.3.x86.run 239447744
diff --git a/games-fps/quake4-bin/quake4-bin-1.3.ebuild b/games-fps/quake4-bin/quake4-bin-1.3.ebuild
new file mode 100644
index 000000000000..38d5820e1d6c
--- /dev/null
+++ b/games-fps/quake4-bin/quake4-bin-1.3.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake4-bin/quake4-bin-1.3.ebuild,v 1.1 2006/08/01 16:11:04 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="Sequel to Quake 2, an id Software 3D first-person shooter"
+HOMEPAGE="http://www.quake4game.com/"
+SRC_URI="mirror://idsoftware/quake4/linux/quake4-linux-${PV}.x86.run"
+
+LICENSE="QUAKE4"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="alsa cdinstall dedicated opengl"
+RESTRICT="strip"
+
+UIDEPEND="virtual/opengl
+ x86? (
+ || (
+ (
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 ) )
+ media-libs/libsdl
+ amd64? (
+ app-emulation/emul-linux-x86-sdl
+ app-emulation/emul-linux-x86-xlibs
+ || (
+ >=app-emulation/emul-linux-x86-xlibs-7.0
+ >=media-video/nvidia-glx-1.0.6629-r3
+ x11-drivers/nvidia-drivers
+ x11-drivers/nvidia-legacy-drivers
+ >=x11-drivers/ati-drivers-8.8.25-r1 ) )
+ alsa? ( >=media-libs/alsa-lib-1.0.6 )"
+
+RDEPEND="sys-libs/glibc
+ dedicated? ( app-misc/screen )
+ amd64? ( app-emulation/emul-linux-x86-baselibs )
+ opengl? ( ${UIDEPEND} )
+ cdinstall? ( games-fps/quake4-data )
+ !dedicated? ( !opengl? ( ${UIDEPEND} ) )"
+
+S=${WORKDIR}
+
+GAMES_CHECK_LICENSE="yes"
+dir=${GAMES_PREFIX_OPT}/quake4
+Ddir=${D}/${dir}
+
+src_unpack() {
+ unpack_makeself quake4-linux-${PV}.x86.run
+}
+
+src_install() {
+ insinto "${dir}"
+ exeinto "${dir}"
+
+ doins *.txt README q4icon.bmp us/version.info README-1.3.htm || die "docs"
+ doins -r pb || die "pb"
+ doexe openurl.sh || die "openurl.sh"
+ doexe bin/Linux/x86/quake4.x86 bin/Linux/x86/q4ded.x86 \
+ bin/Linux/x86/libgcc_s.so.1 bin/Linux/x86/libstdc++.so.* \
+ bin/Linux/x86/libSDL-1.2.id.so.0 bin/Linux/x86/quake4smp.x86 \
+ || die "doexe x86 exes/libs"
+
+ insinto "${dir}"/q4base
+ doins q4base/* us/q4base/* || die "doins q4base"
+ if use dedicated
+ then
+ games_make_wrapper quake4-ded ./q4ded.x86 "${dir}" "${dir}"
+ fi
+
+ if use opengl || ! use dedicated
+ then
+ games_make_wrapper quake4 ./quake4.x86 "${dir}" "${dir}"
+ games_make_wrapper quake4-smp ./quake4smp.x86 "${dir}" "${dir}"
+# doicon ${FILESDIR}/quake4.png || die "copying icon"
+# make_desktop_entry quake4 "Quake IV" quake4.png
+ newicon q4icon.bmp quake4.bmp || die "copying icon"
+ make_desktop_entry quake4 "Quake IV" /usr/share/pixmaps/quake4.bmp
+ make_desktop_entry quake4-smp "Quake IV (SMP)" /usr/share/pixmaps/quake4.bmp
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if ! use cdinstall
+ then
+ einfo "You need to copy pak001.pk4 through pak012.pk4, along with"
+ einfo "zpak*.pk4 from either your installation media or your hard drive"
+ einfo "to ${dir}/q4base before running the game."
+ echo
+ fi
+ if use opengl || ! use dedicated
+ then
+ einfo "To play the game run:"
+ einfo " quake4"
+ echo
+ fi
+}