summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-27 23:34:42 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-27 23:34:42 +0000
commit5d8fbaffeeceed476ec0b541e81df5a2cbbb8f0c (patch)
treefdf1f84dee671e3e67d18c142be3d7ae12ab4c15 /games-fps/quakeforge
parentset ppc in keywords (diff)
downloadgentoo-2-5d8fbaffeeceed476ec0b541e81df5a2cbbb8f0c.tar.gz
gentoo-2-5d8fbaffeeceed476ec0b541e81df5a2cbbb8f0c.tar.bz2
gentoo-2-5d8fbaffeeceed476ec0b541e81df5a2cbbb8f0c.zip
add patch to try to fix #31375
Diffstat (limited to 'games-fps/quakeforge')
-rw-r--r--games-fps/quakeforge/files/0.5.4-com-parse.patch24
-rw-r--r--games-fps/quakeforge/quakeforge-0.5.4.ebuild16
2 files changed, 33 insertions, 7 deletions
diff --git a/games-fps/quakeforge/files/0.5.4-com-parse.patch b/games-fps/quakeforge/files/0.5.4-com-parse.patch
new file mode 100644
index 000000000000..0b5a839e155d
--- /dev/null
+++ b/games-fps/quakeforge/files/0.5.4-com-parse.patch
@@ -0,0 +1,24 @@
+--- quakeforge-0.5.4/libs/util/idparse.c 2003-05-26 15:14:18.000000000 -0400
++++ quakeforge/libs/util/idparse.c 2003-07-27 18:00:25.000000000 -0400
+@@ -33,7 +33,7 @@
+ #endif
+
+ static __attribute__ ((unused)) const char rcsid[] =
+- "$Id: 0.5.4-com-parse.patch,v 1.1 2003/10/27 23:34:42 vapier Exp $";
++ "$Id: 0.5.4-com-parse.patch,v 1.1 2003/10/27 23:34:42 vapier Exp $";
+
+ #include <ctype.h>
+ #include <stdlib.h>
+@@ -107,8 +107,11 @@
+ skipwhite:
+ while (isspace ((byte) *data))
+ data++;
+- if (!*data)
++ if (!*data) {
++ dstring_clearstr (_com_token);
++ com_token = _com_token->str;
+ return 0;
++ }
+ if (data[0] == '/' && data[1] == '/') {
+ while (*data && *data != '\n')
+ data++;
diff --git a/games-fps/quakeforge/quakeforge-0.5.4.ebuild b/games-fps/quakeforge/quakeforge-0.5.4.ebuild
index 050899acc0dd..75191a24667d 100644
--- a/games-fps/quakeforge/quakeforge-0.5.4.ebuild
+++ b/games-fps/quakeforge/quakeforge-0.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/quakeforge-0.5.4.ebuild,v 1.3 2003/09/29 16:35:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/quakeforge-0.5.4.ebuild,v 1.4 2003/10/27 23:34:42 vapier Exp $
inherit games
@@ -33,11 +33,12 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd ${S}
- sed -i \
- -e 's:heavy=.*:heavy=:' \
- -e 's:light=.*:light=:' \
- -e 's:MORE_CFLAGS=".*":MORE_CFLAGS="":' \
- configure || die "removing static cflags from configure"
+ epatch ${FILESDIR}/${PV}-com-parse.patch
+# sed -i \
+# -e 's:heavy=.*:heavy=:' \
+# -e 's:light=.*:light=:' \
+# -e 's:MORE_CFLAGS=".*":MORE_CFLAGS="":' \
+# configure || die "removing static cflags from configure"
}
src_compile() {
@@ -52,7 +53,7 @@ src_compile() {
local debugopts
[ `use debug` ] \
&& debugopts="--enable-debug --disable-optimize --enable-profile" \
- || debugopts="--disable-debug --enable-optimize --disable-profile"
+ || debugopts="--disable-debug --disable-profile"
local clients=${QF_CLIENTS}
[ `use 3dfx` ] && clients="${clients},3dfx"
@@ -89,6 +90,7 @@ src_compile() {
`use_enable alsa` \
`use_enable oss` \
--enable-sound \
+ --disable-optimize \
${debugopts} \
--with-global-cfg=${GAMES_SYSCONFDIR}/quakeforge.conf \
--with-sharepath=${GAMES_DATADIR}/quake-data \