summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-06-18 07:06:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-06-18 07:06:15 +0000
commita152ef1b8de9623442a96f6d8cb1367d076100b1 (patch)
treed7e353d18d39c533a9d5b5ae79c59bcbe2a563cb /games-fps/sauerbraten
parentmark ~ppc (bug #209567) (diff)
downloadgentoo-2-a152ef1b8de9623442a96f6d8cb1367d076100b1.tar.gz
gentoo-2-a152ef1b8de9623442a96f6d8cb1367d076100b1.tar.bz2
gentoo-2-a152ef1b8de9623442a96f6d8cb1367d076100b1.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-fps/sauerbraten')
-rw-r--r--games-fps/sauerbraten/ChangeLog8
-rw-r--r--games-fps/sauerbraten/sauerbraten-2008.06.17.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/games-fps/sauerbraten/ChangeLog b/games-fps/sauerbraten/ChangeLog
index cd2116eebaa3..34f800c38051 100644
--- a/games-fps/sauerbraten/ChangeLog
+++ b/games-fps/sauerbraten/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/sauerbraten
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/sauerbraten/ChangeLog,v 1.9 2008/01/07 22:32:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/sauerbraten/ChangeLog,v 1.10 2008/06/18 07:06:15 mr_bones_ Exp $
+
+*sauerbraten-2008.06.17 (18 Jun 2008)
+
+ 18 Jun 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +sauerbraten-2008.06.17.ebuild:
+ version bump
*sauerbraten-2007.12.27 (07 Jan 2008)
diff --git a/games-fps/sauerbraten/sauerbraten-2008.06.17.ebuild b/games-fps/sauerbraten/sauerbraten-2008.06.17.ebuild
new file mode 100644
index 000000000000..26d63b8c5394
--- /dev/null
+++ b/games-fps/sauerbraten/sauerbraten-2008.06.17.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/sauerbraten/sauerbraten-2008.06.17.ebuild,v 1.1 2008/06/18 07:06:15 mr_bones_ Exp $
+
+inherit eutils multilib games
+
+DESCRIPTION="free multiplayer/singleplayer first person shooter (major redesign of the Cube FPS)"
+HOMEPAGE="http://sauerbraten.org/"
+SRC_URI="mirror://sourceforge/sauerbraten/sauerbraten_${PV//./_}_ctf_edition_linux.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+DEPEND="sys-libs/glibc
+ x86? (
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/libpng
+ virtual/opengl
+ )
+ amd64? (
+ app-emulation/emul-linux-x86-soundlibs
+ app-emulation/emul-linux-x86-sdl
+ )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ find -name CVS -print0 | xargs -0 rm -rf
+}
+
+src_install() {
+ use amd64 && multilib_toolchain_setup x86
+
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe bin_unix/linux_{client,server} || die
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data packages || die
+
+ local x
+ for x in client server ; do
+ newgamesbin "${FILESDIR}"/wrapper ${PN}_${x}-bin || die
+ sed -i \
+ -e "s:@GENTOO_GAMESDIR@:${GAMES_DATADIR}/${PN}:g" \
+ -e "s:@GENTOO_EXEC@:$(games_get_libdir)/${PN}/linux_${x}:g" \
+ "${D}/${GAMES_BINDIR}"/${PN}_${x}-bin
+ done
+
+ dohtml -r README.html docs
+
+ make_desktop_entry ${PN}_client-bin ${PN}
+
+ prepgamesdirs
+}