summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-03-18 22:41:42 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-03-18 22:41:42 +0000
commit19afb744c7536a4cb2d2c3c7ecb814e7599051d4 (patch)
tree28390b5dbc4b45068140ef73f78e43b767bc3dd3 /games-fps
parentStrigiapplet works with 0.5.8, it doesn't work with non-live ebuilds. Update ... (diff)
downloadgentoo-2-19afb744c7536a4cb2d2c3c7ecb814e7599051d4.tar.gz
gentoo-2-19afb744c7536a4cb2d2c3c7ecb814e7599051d4.tar.bz2
gentoo-2-19afb744c7536a4cb2d2c3c7ecb814e7599051d4.zip
Fixing compiling for asm/io.h missing. Bug #212965
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/aaquake2/ChangeLog8
-rw-r--r--games-fps/aaquake2/aaquake2-0.1.ebuild5
-rw-r--r--games-fps/aaquake2/files/aaquake2-0.1-glibc.patch22
3 files changed, 31 insertions, 4 deletions
diff --git a/games-fps/aaquake2/ChangeLog b/games-fps/aaquake2/ChangeLog
index d46e3d30700c..f9a1896f7ccc 100644
--- a/games-fps/aaquake2/ChangeLog
+++ b/games-fps/aaquake2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/aaquake2
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/ChangeLog,v 1.7 2007/02/21 23:37:46 peper Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/ChangeLog,v 1.8 2008/03/18 22:41:41 tupone Exp $
+
+ 18 Mar 2008; Tupone Alfredo <tupone@gentoo.org>
+ +files/aaquake2-0.1-glibc.patch, aaquake2-0.1.ebuild:
+ Fixing compiling for asm/io.h missing. Bug #212965 by GNUtoo@no-log.org
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/games-fps/aaquake2/aaquake2-0.1.ebuild b/games-fps/aaquake2/aaquake2-0.1.ebuild
index bb95d0e78fc2..151786b56d44 100644
--- a/games-fps/aaquake2/aaquake2-0.1.ebuild
+++ b/games-fps/aaquake2/aaquake2-0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/aaquake2-0.1.ebuild,v 1.10 2007/04/09 17:50:11 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/aaquake2-0.1.ebuild,v 1.11 2008/03/18 22:41:41 tupone Exp $
inherit eutils games
@@ -25,6 +25,7 @@ src_unpack() {
cd "${WORKDIR}"/quake2-3.21
epatch \
"${FILESDIR}"/${PV}-gentoo.patch \
+ "${FILESDIR}"/${P}-glibc.patch \
"${FILESDIR}"/${P}-gcc41.patch
cd linux
sed -i \
diff --git a/games-fps/aaquake2/files/aaquake2-0.1-glibc.patch b/games-fps/aaquake2/files/aaquake2-0.1-glibc.patch
new file mode 100644
index 000000000000..806406357a31
--- /dev/null
+++ b/games-fps/aaquake2/files/aaquake2-0.1-glibc.patch
@@ -0,0 +1,22 @@
+--- linux/rw_aa.c.old 2008-03-18 23:29:28.000000000 +0100
++++ linux/rw_aa.c 2008-03-18 23:29:44.000000000 +0100
+@@ -61,7 +61,7 @@
+ #include <signal.h>
+ #include <sys/mman.h>
+
+-#include <asm/io.h>
++#include <sys/io.h>
+
+ #include <aalib.h>
+
+--- linux/rw_in_aa.c.old 2008-03-18 23:29:33.000000000 +0100
++++ linux/rw_in_aa.c 2008-03-18 23:29:54.000000000 +0100
+@@ -46,7 +46,7 @@
+ #include <signal.h>
+ #include <sys/mman.h>
+
+-#include <asm/io.h>
++#include <sys/io.h>
+
+ #include <aalib.h>
+