summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-06-03 21:39:59 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-06-03 21:39:59 +0000
commit332d5539b7f27f3fd3731804485901b5bf73599e (patch)
treee924453eb28a1ec7d43a57ed05b54d32d8d72633 /games-fps
parentPush back to ~x86 (diff)
downloadgentoo-2-332d5539b7f27f3fd3731804485901b5bf73599e.tar.gz
gentoo-2-332d5539b7f27f3fd3731804485901b5bf73599e.tar.bz2
gentoo-2-332d5539b7f27f3fd3731804485901b5bf73599e.zip
Wrapper rewritten, bug #135428
(Portage version: 2.1_rc3-r4)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/alephone/ChangeLog8
-rw-r--r--games-fps/alephone/alephone-20060506-r1.ebuild79
-rw-r--r--games-fps/alephone/files/alephone.sh28
-rw-r--r--games-fps/alephone/files/digest-alephone-20060506-r13
4 files changed, 117 insertions, 1 deletions
diff --git a/games-fps/alephone/ChangeLog b/games-fps/alephone/ChangeLog
index db00ab8b1a87..49f68d5aa7d5 100644
--- a/games-fps/alephone/ChangeLog
+++ b/games-fps/alephone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/alephone
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.10 2006/06/02 23:19:08 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.11 2006/06/03 21:39:59 tupone Exp $
+
+*alephone-20060506-r1 (03 Jun 2006)
+
+ 03 Jun 2006; <Tupone@gentoo.org> +files/alephone.sh,
+ +alephone-20060506-r1.ebuild:
+ Wrapper rewritten, bug #135428 by Ben Urban
*alephone-20060506 (02 Jun 2006)
diff --git a/games-fps/alephone/alephone-20060506-r1.ebuild b/games-fps/alephone/alephone-20060506-r1.ebuild
new file mode 100644
index 000000000000..abf8ce1ca43e
--- /dev/null
+++ b/games-fps/alephone/alephone-20060506-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20060506-r1.ebuild,v 1.1 2006/06/03 21:39:59 tupone Exp $
+
+inherit eutils games
+
+DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
+HOMEPAGE="http://source.bungie.org/"
+SRC_URI="mirror://sourceforge/marathon/AlephOne-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua opengl speex"
+
+DEPEND="lua? ( dev-lang/lua )
+ opengl? ( virtual/opengl )
+ speex? ( media-libs/speex )
+ dev-libs/boost
+ >=media-libs/libsdl-1.2
+ media-libs/sdl-image
+ media-libs/sdl-net"
+
+S=${WORKDIR}/AlephOne-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ cp ${FILESDIR}/alephone.png ./
+ cp ${FILESDIR}/alephone.sh ./
+ sed -i -e "s:GAMES_DATADIR:${GAMES_DATADIR}:g" \
+ alephone.sh || die
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable opengl) || die
+ if ! use lua ; then
+ # stupid configure script doesnt have an option
+ dosed -i \
+ -e '/HAVE_LUA/d' config.h \
+ || die "sed HAVE_LUA"
+ dosed -i \
+ -e '/^LIBS/s:-llua -llualib::' $(find -name Makefile) \
+ || die "sed -llua"
+ fi
+ if ! use speex ; then
+ # stupid configure script doesnt have an option
+ dosed -i \
+ -e '/SPEEX/d:' config.h \
+ || die "sed SPEEX"
+ dosed -i \
+ -e '/^LIBS/s:-lspeex::' $(find -name Makefile) \
+ || die "sed -lspeex"
+ fi
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dogamesbin alephone.sh || die "failed to install wrapper"
+ dodoc AUTHORS README docs/Cheat_Codes
+ dohtml docs/MML.html
+ doicon alephone.png
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "Read the docs and install the data files accordingly to play."
+ echo
+ einfo "If you only want to install one scenario, read"
+ einfo "http://traxus.jjaro.net/traxus/AlephOne:Install_Guide#Single_scenario_3"
+ einfo "If you want to install multiple scenarios, read"
+ einfo "http://traxus.jjaro.net/traxus/AlephOne:Install_Guide#Multiple_scenarios_3"
+ echo
+}
diff --git a/games-fps/alephone/files/alephone.sh b/games-fps/alephone/files/alephone.sh
new file mode 100644
index 000000000000..62ac98f85770
--- /dev/null
+++ b/games-fps/alephone/files/alephone.sh
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+DIR=$(dirname "${0}")
+CMD=$(basename "${0}")
+ALEPHONE=${CMD%%.sh}
+
+if [[ -z "${1}" ]]
+then
+ echo "Usage: ${0} SCENARIO FLAGS"
+ echo "Where SCENARIO is one of:"
+ for d in "GAMES_DATADIR"/alephone-*
+ do
+ echo " ${d##*/alephone-}"
+ done
+ exit 2
+fi
+
+export ALEPHONE_DATA="GAMES_DATADIR/alephone-${1}"
+
+shift
+
+# kill ARTS, because we're just that nice
+if artsshell terminate 2> /dev/null
+then
+ sleep 2
+fi
+
+"${DIR}"/"${ALEPHONE}" "$@"
diff --git a/games-fps/alephone/files/digest-alephone-20060506-r1 b/games-fps/alephone/files/digest-alephone-20060506-r1
new file mode 100644
index 000000000000..01aa3fa7e522
--- /dev/null
+++ b/games-fps/alephone/files/digest-alephone-20060506-r1
@@ -0,0 +1,3 @@
+MD5 7daead26056dfe33732cc8d5169ba489 AlephOne-20060506.tar.gz 6272060
+RMD160 857f0534dd1387fcac4dd9a10628a6250666a970 AlephOne-20060506.tar.gz 6272060
+SHA256 4ab9630ae8e0bb76429d82793c70035c9d1d2a2eeea6abcbccd82e0b7940e402 AlephOne-20060506.tar.gz 6272060