summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-04-06 15:30:10 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-04-06 15:30:10 +0000
commit929d279f6f50709ad8b31df4dbd6d7e0610d4838 (patch)
treef1d4ede2757cb7652e4950851a1837659f43c001 /games-fps
parentadd fixes proposed by Arfrever (diff)
downloadgentoo-2-929d279f6f50709ad8b31df4dbd6d7e0610d4838.tar.gz
gentoo-2-929d279f6f50709ad8b31df4dbd6d7e0610d4838.tar.bz2
gentoo-2-929d279f6f50709ad8b31df4dbd6d7e0610d4838.zip
tidy; detangle patch
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/urbanterror/ChangeLog7
-rw-r--r--games-fps/urbanterror/files/urbanterror-4.2.023-build.patch75
-rw-r--r--games-fps/urbanterror/urbanterror-4.2.023.ebuild7
3 files changed, 84 insertions, 5 deletions
diff --git a/games-fps/urbanterror/ChangeLog b/games-fps/urbanterror/ChangeLog
index 39b4661e38f2..1cf7b5694b60 100644
--- a/games-fps/urbanterror/ChangeLog
+++ b/games-fps/urbanterror/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/urbanterror
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/urbanterror/ChangeLog,v 1.54 2015/02/15 01:05:06 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/urbanterror/ChangeLog,v 1.55 2015/04/06 15:30:10 mr_bones_ Exp $
+
+ 06 Apr 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/urbanterror-4.2.023-build.patch, files/urbanterror-4.2.018-build.patch,
+ files/urbanterror-4.2.021-build.patch, urbanterror-4.2.023.ebuild:
+ tidy; detangle patch
15 Feb 2015; <anarchy@gentoo.org> urbanterror-4.2.023.ebuild:
seed using 4.2.022, missed initial commit update
diff --git a/games-fps/urbanterror/files/urbanterror-4.2.023-build.patch b/games-fps/urbanterror/files/urbanterror-4.2.023-build.patch
new file mode 100644
index 000000000000..daa7e324a677
--- /dev/null
+++ b/games-fps/urbanterror/files/urbanterror-4.2.023-build.patch
@@ -0,0 +1,75 @@
+Author: hasufell <hasufell@gentoo.org>
+Date: Wed Jul 10 01:25:27 2013 +0200
+
+ respect CFLAGS/LDFLAGS
+
+--- a/Makefile
++++ b/Makefile
+@@ -213,7 +213,7 @@
+ endif
+ endif
+
+- BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes -pipe
++ BASE_CFLAGS = -Wall -Wimplicit -Wstrict-prototypes
+
+ ifeq ($(USE_OPENAL),1)
+ BASE_CFLAGS += -DUSE_OPENAL=1
+@@ -239,19 +239,15 @@
+ BASE_CFLAGS += -I/usr/X11R6/include
+ endif
+
+- OPTIMIZE = -O3 -ffast-math -funroll-loops -fomit-frame-pointer
++ OPTIMIZE =
+
+ ifeq ($(ARCH),x86_64)
+- OPTIMIZE = -O3 -fomit-frame-pointer -ffast-math -funroll-loops \
+- -falign-loops=2 -falign-jumps=2 -falign-functions=2 \
+- -fstrength-reduce
++ OPTIMIZE =
+ # experimental x86_64 jit compiler! you need GNU as
+ HAVE_VM_COMPILED = true
+ else
+ ifeq ($(ARCH),i386)
+- OPTIMIZE = -O3 -march=i586 -fomit-frame-pointer -ffast-math \
+- -funroll-loops -falign-loops=2 -falign-jumps=2 \
+- -falign-functions=2 -fstrength-reduce
++ OPTIMIZE =
+ HAVE_VM_COMPILED=true
+ else
+ ifeq ($(ARCH),ppc)
+@@ -265,7 +261,7 @@
+ BASE_CFLAGS += -DNO_VM_COMPILED
+ endif
+
+- DEBUG_CFLAGS = $(BASE_CFLAGS) -g -O0
++ DEBUG_CFLAGS = $(BASE_CFLAGS) $(OPTIMIZE)
+
+ RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG $(OPTIMIZE)
+
+@@ -274,7 +270,7 @@
+ SHLIBLDFLAGS=-shared $(LDFLAGS)
+
+ THREAD_LDFLAGS=-lpthread
+- LDFLAGS=-ldl -lm
++ LDFLAGS+=-ldl -lm
+
+ ifeq ($(USE_SDL),1)
+ CLIENT_LDFLAGS=$(shell sdl-config --libs)
+@@ -1158,13 +1154,13 @@
+
+ $(B)/Quake3-UrT.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ) $(LIBSDLMAIN)
+ $(echo_cmd) "LD $@"
+- $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ) $(CLIENT_LDFLAGS) \
+- $(LDFLAGS) $(LIBSDLMAIN)
++ $(Q)$(CC) $(CFLAGS) -o $@ $(Q3OBJ) $(Q3POBJ) \
++ $(LDFLAGS) $(CLIENT_LDFLAGS) $(LIBSDLMAIN)
+
+ $(B)/Quake3-UrT-smp.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ_SMP) $(LIBSDLMAIN)
+ $(echo_cmd) "LD $@"
+- $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) $(CLIENT_LDFLAGS) \
+- $(THREAD_LDFLAGS) $(LDFLAGS) $(LIBSDLMAIN)
++ $(Q)$(CC) $(CFLAGS) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) \
++ $(LDFLAGS) $(THREAD_LDFLAGS) $(CLIENT_LDFLAGS) $(LIBSDLMAIN)
+
+ ifneq ($(strip $(LIBSDLMAIN)),)
+ ifneq ($(strip $(LIBSDLMAINSRC)),)
diff --git a/games-fps/urbanterror/urbanterror-4.2.023.ebuild b/games-fps/urbanterror/urbanterror-4.2.023.ebuild
index 5e1f5802b7a1..a913e30e8b67 100644
--- a/games-fps/urbanterror/urbanterror-4.2.023.ebuild
+++ b/games-fps/urbanterror/urbanterror-4.2.023.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/urbanterror/urbanterror-4.2.023.ebuild,v 1.2 2015/02/15 01:05:06 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/urbanterror/urbanterror-4.2.023.ebuild,v 1.3 2015/04/06 15:30:10 mr_bones_ Exp $
EAPI=5
-
-inherit check-reqs eutils gnome2-utils games pax-utils
+inherit check-reqs eutils gnome2-utils pax-utils games
ENGINE_PV=${PV}
FULL_P=UrbanTerror42_full022
@@ -82,7 +81,7 @@ src_unpack() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-4.2.021-build.patch
+ epatch "${FILESDIR}"/${PN}-${ENGINE_PV}-build.patch
}
src_compile() {