summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-03-29 16:02:26 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-03-29 16:02:26 +0000
commitb09dba86dc1365ff81fa716da36f390de7d5484b (patch)
tree2e5d63fb9e5e97ead78ad999e9383d02bc1e7908 /games-fps
parentVersion bump (diff)
downloadgentoo-2-b09dba86dc1365ff81fa716da36f390de7d5484b.tar.gz
gentoo-2-b09dba86dc1365ff81fa716da36f390de7d5484b.tar.bz2
gentoo-2-b09dba86dc1365ff81fa716da36f390de7d5484b.zip
use unpack_zip from unpacker.eclass instead of unzip
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/darkplaces/ChangeLog6
-rw-r--r--games-fps/darkplaces/darkplaces-20110628.ebuild8
-rw-r--r--games-fps/darkplaces/darkplaces-20121222.ebuild6
3 files changed, 12 insertions, 8 deletions
diff --git a/games-fps/darkplaces/ChangeLog b/games-fps/darkplaces/ChangeLog
index e5bae7327e7a..f70ee12ae122 100644
--- a/games-fps/darkplaces/ChangeLog
+++ b/games-fps/darkplaces/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/darkplaces
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/darkplaces/ChangeLog,v 1.18 2013/01/22 18:39:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/darkplaces/ChangeLog,v 1.19 2013/03/29 16:02:26 hasufell Exp $
+
+ 29 Mar 2013; Julian Ospald <hasufell@gentoo.org> darkplaces-20110628.ebuild,
+ darkplaces-20121222.ebuild:
+ use unpack_zip from unpacker.eclass instead of unzip
22 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
darkplaces-20121222.ebuild:
diff --git a/games-fps/darkplaces/darkplaces-20110628.ebuild b/games-fps/darkplaces/darkplaces-20110628.ebuild
index d8b01f3871e9..86ca2a32e23f 100644
--- a/games-fps/darkplaces/darkplaces-20110628.ebuild
+++ b/games-fps/darkplaces/darkplaces-20110628.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/darkplaces/darkplaces-20110628.ebuild,v 1.3 2012/06/21 19:34:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/darkplaces/darkplaces-20110628.ebuild,v 1.4 2013/03/29 16:02:26 hasufell Exp $
EAPI=2
-inherit eutils flag-o-matic games
+inherit unpacker eutils flag-o-matic games
# Latest versions are in http://icculus.org/twilight/darkplaces/files/
MY_PV=${PV/_beta/beta}
@@ -69,7 +69,7 @@ opengl_client() { use opengl || ( ! use dedicated && ! use sdl ) }
src_unpack() {
if use lights ; then
unpack "${MY_LIGHTS}"
- unzip -qo "${DISTDIR}"/id1.pk3 || die "unzip id1.pk3 failed"
+ unpack_zip "${DISTDIR}"/id1.pk3
mv *.lit maps/ || die
mv ReadMe.txt rtlights.txt
fi
diff --git a/games-fps/darkplaces/darkplaces-20121222.ebuild b/games-fps/darkplaces/darkplaces-20121222.ebuild
index bb1c43848f94..ae87d3ee44e8 100644
--- a/games-fps/darkplaces/darkplaces-20121222.ebuild
+++ b/games-fps/darkplaces/darkplaces-20121222.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/darkplaces/darkplaces-20121222.ebuild,v 1.2 2013/01/22 18:39:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/darkplaces/darkplaces-20121222.ebuild,v 1.3 2013/03/29 16:02:26 hasufell Exp $
EAPI=2
-inherit eutils flag-o-matic games
+inherit unpacker eutils flag-o-matic games
# Latest versions are in http://icculus.org/twilight/darkplaces/files/
MY_PV=${PV/_beta/beta}
@@ -69,7 +69,7 @@ opengl_client() { use opengl || ( ! use dedicated && ! use sdl ) }
src_unpack() {
if use lights ; then
unpack "${MY_LIGHTS}"
- unzip -qo "${DISTDIR}"/id1.pk3 || die
+ unpack_zip "${DISTDIR}"/id1.pk3
mv *.lit maps/ || die
mv ReadMe.txt rtlights.txt
fi