summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-04-22 12:09:35 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-04-22 12:09:35 +0000
commit1972352aa85c6fe913a6f960888982f3e28e85e8 (patch)
tree0a2f0f79827f610e70ba01b7ea87c79bfd29f244 /games-kids/tuxmathscrabble
parentamd64 stable, bug 313141 (diff)
downloadgentoo-2-1972352aa85c6fe913a6f960888982f3e28e85e8.tar.gz
gentoo-2-1972352aa85c6fe913a6f960888982f3e28e85e8.tar.bz2
gentoo-2-1972352aa85c6fe913a6f960888982f3e28e85e8.zip
Force python2 to fix bug #312255
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-kids/tuxmathscrabble')
-rw-r--r--games-kids/tuxmathscrabble/ChangeLog8
-rw-r--r--games-kids/tuxmathscrabble/tuxmathscrabble-4.5.ebuild19
2 files changed, 18 insertions, 9 deletions
diff --git a/games-kids/tuxmathscrabble/ChangeLog b/games-kids/tuxmathscrabble/ChangeLog
index 86b4fa723c74..6ef8345f054d 100644
--- a/games-kids/tuxmathscrabble/ChangeLog
+++ b/games-kids/tuxmathscrabble/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-kids/tuxmathscrabble
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/ChangeLog,v 1.14 2007/10/24 01:28:06 nyhm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/ChangeLog,v 1.15 2010/04/22 12:09:35 tupone Exp $
+
+ 22 Apr 2010; Tupone Alfredo <tupone@gentoo.org>
+ tuxmathscrabble-4.5.ebuild:
+ Force python2 to fix bug #312255 by arfrever@gentoo.org
*tuxmathscrabble-4.5 (24 Oct 2007)
diff --git a/games-kids/tuxmathscrabble/tuxmathscrabble-4.5.ebuild b/games-kids/tuxmathscrabble/tuxmathscrabble-4.5.ebuild
index d6fc048794c0..15113fcb4d56 100644
--- a/games-kids/tuxmathscrabble/tuxmathscrabble-4.5.ebuild
+++ b/games-kids/tuxmathscrabble/tuxmathscrabble-4.5.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/tuxmathscrabble-4.5.ebuild,v 1.1 2007/10/24 01:28:06 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/tuxmathscrabble-4.5.ebuild,v 1.2 2010/04/22 12:09:35 tupone Exp $
+EAPI="2"
+PYTHON_DEPEND="2"
inherit eutils python multilib games
@@ -21,21 +23,24 @@ DEPEND="dev-python/pygame
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}
+
+src_prepare() {
rm -f $(find . -name '*.pyc')
mv -f ${MY_PN}/{Accounts,Globals,Simulation,StudentData} .
sed -i "s:'/','var','games':'${GAMES_STATEDIR}':" \
asymptopia_0_1_3/environment.py \
|| die "sed failed"
+ python_convert_shebangs -r 2 .
}
src_install() {
newgamesbin ${MY_PN}.py ${PN} || die "newgamesbin failed"
- python_version
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ insinto $(python_get_sitedir)
doins -r ${MY_PN} || die "doins failed"
doins -r asymptopia_0_1_3 || die "doins asymptopia_0_1_2 failed"