summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-10-02 05:36:54 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-10-02 05:36:54 +0000
commit1cc300b91158114d7ef4ef498eb26d7cbac04765 (patch)
treea9bd3c2bc6cf70d758660d59de8d12828b75ef88 /games-kids/tuxmathscrabble
parentStable for HPPA (bug #194466). (diff)
downloadgentoo-2-1cc300b91158114d7ef4ef498eb26d7cbac04765.tar.gz
gentoo-2-1cc300b91158114d7ef4ef498eb26d7cbac04765.tar.bz2
gentoo-2-1cc300b91158114d7ef4ef498eb26d7cbac04765.zip
version bump
(Portage version: 2.1.3.9)
Diffstat (limited to 'games-kids/tuxmathscrabble')
-rw-r--r--games-kids/tuxmathscrabble/ChangeLog8
-rw-r--r--games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-4.33
-rw-r--r--games-kids/tuxmathscrabble/tuxmathscrabble-4.3.ebuild52
3 files changed, 62 insertions, 1 deletions
diff --git a/games-kids/tuxmathscrabble/ChangeLog b/games-kids/tuxmathscrabble/ChangeLog
index eedd57eae005..13567a5be174 100644
--- a/games-kids/tuxmathscrabble/ChangeLog
+++ b/games-kids/tuxmathscrabble/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-kids/tuxmathscrabble
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/ChangeLog,v 1.12 2007/10/02 03:51:36 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/ChangeLog,v 1.13 2007/10/02 05:36:53 mr_bones_ Exp $
+
+*tuxmathscrabble-4.3 (02 Oct 2007)
+
+ 02 Oct 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +tuxmathscrabble-4.3.ebuild:
+ version bump
02 Oct 2007; Ryan Hill <dirtyepic@gentoo.org> tuxmathscrabble-4.2.ebuild:
Lock wxpython to 2.6.
diff --git a/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-4.3 b/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-4.3
new file mode 100644
index 000000000000..7fa1c6b4123a
--- /dev/null
+++ b/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-4.3
@@ -0,0 +1,3 @@
+MD5 15edb9e8ad953425eb09a35135b7bb4e TuxMathScrabble-0.4.3.tgz 4295674
+RMD160 85f291dc115232eaf048a9c47f45985b3c99e1be TuxMathScrabble-0.4.3.tgz 4295674
+SHA256 c5a1b3a2f140a07210866019c6c9094891df3c6afb7fe87b24dd47b6ec3d3839 TuxMathScrabble-0.4.3.tgz 4295674
diff --git a/games-kids/tuxmathscrabble/tuxmathscrabble-4.3.ebuild b/games-kids/tuxmathscrabble/tuxmathscrabble-4.3.ebuild
new file mode 100644
index 000000000000..a53483bdd7cd
--- /dev/null
+++ b/games-kids/tuxmathscrabble/tuxmathscrabble-4.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/tuxmathscrabble-4.3.ebuild,v 1.1 2007/10/02 05:36:53 mr_bones_ Exp $
+
+inherit eutils python multilib games
+
+MY_PN=TuxMathScrabble
+MY_P=${MY_PN}-0.${PV}
+DESCRIPTION="math-version of the popular board game for children 4-10"
+HOMEPAGE="http://www.asymptopia.org/"
+SRC_URI="http://www.asymptopia.org/software/${MY_P}.tgz
+ mirror://sourceforge/${PN}/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygame
+ =dev-python/wxpython-2.6*"
+
+S=${WORKDIR}/${MY_PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -f $(find . -name '*.pyc')
+ rm -rf $(find . -name '.svn')
+ mv -f ${MY_PN}/{Accounts,StudentData,Simulation} .
+ sed -i "s:'/','var','games':'${GAMES_STATEDIR}':" \
+ asymptopia_0_1_2/environment.py \
+ || die "sed failed"
+}
+
+src_install() {
+ newgamesbin ${MY_PN}.py ${PN} || die "newgamesbin failed"
+
+ python_version
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doins -r ${MY_PN} || die "doins failed"
+ doins -r asymptopia_0_1_2 || die "doins asymptopia_0_1_2 failed"
+
+ insinto "${GAMES_STATEDIR}"/${MY_PN}
+ doins -r Accounts StudentData Simulation || die "doins failed"
+
+ newicon tms.ico ${PN}.ico
+ make_desktop_entry ${PN} ${MY_PN} /usr/share/pixmaps/${PN}.ico
+
+ dodoc CHANGES README
+ prepgamesdirs
+ fperms -R g+w "${GAMES_STATEDIR}"/${MY_PN}
+}