summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-10-24 01:28:07 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-10-24 01:28:07 +0000
commit6d9c9f87220895dbc6a15296fa7414165f015ba2 (patch)
tree69888af3e3ff5462cc9e4aee6523460d599e1273 /games-kids/tuxmathscrabble
parentFix test suite and unrestrict it (diff)
downloadgentoo-2-6d9c9f87220895dbc6a15296fa7414165f015ba2.tar.gz
gentoo-2-6d9c9f87220895dbc6a15296fa7414165f015ba2.tar.bz2
gentoo-2-6d9c9f87220895dbc6a15296fa7414165f015ba2.zip
Version bump
(Portage version: 2.1.3.16)
Diffstat (limited to 'games-kids/tuxmathscrabble')
-rw-r--r--games-kids/tuxmathscrabble/ChangeLog7
-rw-r--r--games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-4.53
-rw-r--r--games-kids/tuxmathscrabble/tuxmathscrabble-4.5.ebuild51
3 files changed, 60 insertions, 1 deletions
diff --git a/games-kids/tuxmathscrabble/ChangeLog b/games-kids/tuxmathscrabble/ChangeLog
index 13567a5be174..86b4fa723c74 100644
--- a/games-kids/tuxmathscrabble/ChangeLog
+++ b/games-kids/tuxmathscrabble/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-kids/tuxmathscrabble
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/ChangeLog,v 1.13 2007/10/02 05:36:53 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/ChangeLog,v 1.14 2007/10/24 01:28:06 nyhm Exp $
+
+*tuxmathscrabble-4.5 (24 Oct 2007)
+
+ 24 Oct 2007; Tristan Heaven <nyhm@gentoo.org> +tuxmathscrabble-4.5.ebuild:
+ Version bump
*tuxmathscrabble-4.3 (02 Oct 2007)
diff --git a/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-4.5 b/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-4.5
new file mode 100644
index 000000000000..6852073b548c
--- /dev/null
+++ b/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-4.5
@@ -0,0 +1,3 @@
+MD5 6301d6d5a1572f860cbbe25c243f366a TuxMathScrabble-0.4.5.tgz 4359261
+RMD160 055625a81042ebf1a486efeef8138f0e24f5bcc1 TuxMathScrabble-0.4.5.tgz 4359261
+SHA256 4983dafcc3c5f93bc569715da93739e3aca219a09921c9df934dba48a5dada49 TuxMathScrabble-0.4.5.tgz 4359261
diff --git a/games-kids/tuxmathscrabble/tuxmathscrabble-4.5.ebuild b/games-kids/tuxmathscrabble/tuxmathscrabble-4.5.ebuild
new file mode 100644
index 000000000000..d6fc048794c0
--- /dev/null
+++ b/games-kids/tuxmathscrabble/tuxmathscrabble-4.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/tuxmathscrabble-4.5.ebuild,v 1.1 2007/10/24 01:28:06 nyhm Exp $
+
+inherit eutils python multilib games
+
+MY_PN=TuxMathScrabble
+MY_P=${MY_PN}-0.${PV}
+DESCRIPTION="math-version of the popular board game for children 4-10"
+HOMEPAGE="http://www.asymptopia.org/"
+SRC_URI="http://www.asymptopia.org/software/${MY_P}.tgz
+ mirror://sourceforge/${PN}/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygame
+ =dev-python/wxpython-2.6*"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -f $(find . -name '*.pyc')
+ mv -f ${MY_PN}/{Accounts,Globals,Simulation,StudentData} .
+ sed -i "s:'/','var','games':'${GAMES_STATEDIR}':" \
+ asymptopia_0_1_3/environment.py \
+ || die "sed failed"
+}
+
+src_install() {
+ newgamesbin ${MY_PN}.py ${PN} || die "newgamesbin failed"
+
+ python_version
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doins -r ${MY_PN} || die "doins failed"
+ doins -r asymptopia_0_1_3 || die "doins asymptopia_0_1_2 failed"
+
+ insinto "${GAMES_STATEDIR}"/${MY_PN}
+ doins -r Accounts Globals Simulation StudentData || die "doins failed"
+
+ newicon tms.ico ${PN}.ico
+ make_desktop_entry ${PN} ${MY_PN} /usr/share/pixmaps/${PN}.ico
+
+ dodoc CHANGES README
+ prepgamesdirs
+ fperms -R g+w "${GAMES_STATEDIR}"/${MY_PN}
+}