summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-02-22 21:20:20 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-02-22 21:20:20 +0000
commitc9323eb7a046db9b439d7338c2374368130d6b35 (patch)
tree52a4bb9b422e7fb6b2bc261ca61f7b4664d75b3b /games-misc/gBhed
parentslot dep for gtk+ (diff)
downloadgentoo-2-c9323eb7a046db9b439d7338c2374368130d6b35.tar.gz
gentoo-2-c9323eb7a046db9b439d7338c2374368130d6b35.tar.bz2
gentoo-2-c9323eb7a046db9b439d7338c2374368130d6b35.zip
EAPI=2; tidy
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'games-misc/gBhed')
-rw-r--r--games-misc/gBhed/ChangeLog7
-rw-r--r--games-misc/gBhed/gBhed-0.17.ebuild17
2 files changed, 15 insertions, 9 deletions
diff --git a/games-misc/gBhed/ChangeLog b/games-misc/gBhed/ChangeLog
index 15350741f400..c02f1742e0a2 100644
--- a/games-misc/gBhed/ChangeLog
+++ b/games-misc/gBhed/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-misc/gBhed
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/gBhed/ChangeLog,v 1.6 2008/07/27 08:02:22 nixnut Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/gBhed/ChangeLog,v 1.7 2011/02/22 21:20:20 mr_bones_ Exp $
+
+ 22 Feb 2011; Michael Sterrett <mr_bones_@gentoo.org> gBhed-0.17.ebuild:
+ EAPI=2; tidy
27 Jul 2008; nixnut <nixnut@gentoo.org> gBhed-0.17.ebuild:
Stable on ppc wrt bug 232704
diff --git a/games-misc/gBhed/gBhed-0.17.ebuild b/games-misc/gBhed/gBhed-0.17.ebuild
index 2117c051d699..71b0473a502b 100644
--- a/games-misc/gBhed/gBhed-0.17.ebuild
+++ b/games-misc/gBhed/gBhed-0.17.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/gBhed/gBhed-0.17.ebuild,v 1.5 2008/07/27 08:02:22 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/gBhed/gBhed-0.17.ebuild,v 1.6 2011/02/22 21:20:20 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="An Al Bhed translator"
@@ -13,14 +14,16 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="gtk"
-DEPEND="gtk? ( >=x11-libs/gtk+-2.2 )"
+DEPEND="gtk? ( x11-libs/gtk+:2 )"
-src_compile() {
+src_prepare() {
+ sed -i 's/19/32/' src/gui/translation_fork.c || die
+}
+
+src_configure() {
egamesconf \
--datadir="${GAMES_DATADIR}"/${PN} \
- $(use_enable gtk gbhed) \
- || die
- emake || die "emake failed"
+ $(use_enable gtk gbhed)
}
src_install() {