summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-11-08 01:32:44 +0000
committerMichael Weber <xmw@gentoo.org>2010-11-08 01:32:44 +0000
commitc4477a8eef6b7e52e92f562ed17297d2ba4a27a4 (patch)
tree51103314c6650c050d39aec48c53688f19f77b2b /games-misc/lucidlife/lucidlife-0.9.2.ebuild
parentstable x86, bug 344537 (diff)
downloadgentoo-2-c4477a8eef6b7e52e92f562ed17297d2ba4a27a4.tar.gz
gentoo-2-c4477a8eef6b7e52e92f562ed17297d2ba4a27a4.tar.bz2
gentoo-2-c4477a8eef6b7e52e92f562ed17297d2ba4a27a4.zip
Initial import
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'games-misc/lucidlife/lucidlife-0.9.2.ebuild')
-rw-r--r--games-misc/lucidlife/lucidlife-0.9.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-misc/lucidlife/lucidlife-0.9.2.ebuild b/games-misc/lucidlife/lucidlife-0.9.2.ebuild
new file mode 100644
index 000000000000..24756cebd500
--- /dev/null
+++ b/games-misc/lucidlife/lucidlife-0.9.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/lucidlife/lucidlife-0.9.2.ebuild,v 1.1 2010/11/08 01:32:44 xmw Exp $
+
+EAPI=2
+
+inherit games
+
+DESCRIPTION="A Conway's Life simulator written in GTK+2 - fork from Gtklife"
+HOMEPAGE="http://linux.softpedia.com/get/GAMES-ENTERTAINMENT/Simulation/LucidLife-26633.shtml"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="gnome-base/gnome-vfs
+ x11-libs/gtk+:2"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake install \
+ desktopdir=/usr/share/applications \
+ pixmapdir=/usr/share/pixmaps \
+ DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
+ prepgamesdirs
+}