summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-12-16 03:56:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-12-16 03:56:09 +0000
commit54f396f35e839150cbec3ad7c1b137512b2755c1 (patch)
tree3d70ab46712b1e05ac00938ad333fb9ffd5e7f41 /games-misc
parentDefault to munge library authentication over exec, fixes #532430 (diff)
downloadgentoo-2-54f396f35e839150cbec3ad7c1b137512b2755c1.tar.gz
gentoo-2-54f396f35e839150cbec3ad7c1b137512b2755c1.tar.bz2
gentoo-2-54f396f35e839150cbec3ad7c1b137512b2755c1.zip
EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/sdljoytest/ChangeLog8
-rw-r--r--games-misc/sdljoytest/sdljoytest-11102003.ebuild20
2 files changed, 15 insertions, 13 deletions
diff --git a/games-misc/sdljoytest/ChangeLog b/games-misc/sdljoytest/ChangeLog
index 5e3e476970a3..829cdea581f1 100644
--- a/games-misc/sdljoytest/ChangeLog
+++ b/games-misc/sdljoytest/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-misc/sdljoytest
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/sdljoytest/ChangeLog,v 1.5 2010/11/29 05:08:17 mr_bones_ Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/sdljoytest/ChangeLog,v 1.6 2014/12/16 03:56:09 mr_bones_ Exp $
+
+ 16 Dec 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ sdljoytest-11102003.ebuild:
+ EAPI=5
29 Nov 2010; Michael Sterrett <mr_bones_@gentoo.org>
sdljoytest-11102003.ebuild:
diff --git a/games-misc/sdljoytest/sdljoytest-11102003.ebuild b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
index e420518d85c0..caac75dc2c38 100644
--- a/games-misc/sdljoytest/sdljoytest-11102003.ebuild
+++ b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/sdljoytest/sdljoytest-11102003.ebuild,v 1.4 2010/11/29 05:08:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/sdljoytest/sdljoytest-11102003.ebuild,v 1.5 2014/12/16 03:56:09 mr_bones_ Exp $
-EAPI=2
+EAPI=5
inherit toolchain-funcs
DESCRIPTION="SDL app to test joysticks and game controllers"
@@ -17,14 +17,13 @@ IUSE=""
DEPEND="media-libs/libsdl[joystick,opengl,video]
virtual/opengl
media-libs/sdl-image"
+RDEPEND=${DEPEND}
S=${WORKDIR}/SDLJoytest-GL
src_prepare() {
- make clean || die "cleaning"
- sed -i \
- -e 's:/usr/local:/usr:' \
- joytest.h || die "seding data path"
+ emake clean
+ sed -i -e 's:/usr/local:/usr:' joytest.h || die
sed -i -e 's:SDL/::' *.c || die
}
@@ -32,13 +31,12 @@ src_compile() {
emake \
CC=$(tc-getCC) \
CFLAGS="$(sdl-config --cflags) ${CFLAGS}" \
- LDFLAGS="$(sdl-config --libs) -lGL ${LDFLAGS}" \
- || die
+ LDFLAGS="$(sdl-config --libs) -lGL ${LDFLAGS}"
}
src_install() {
- dobin SDLJoytest-GL || die "dobin"
+ dobin SDLJoytest-GL
insinto /usr/share/SDLJoytest-GL
- doins *.bmp || die "data"
+ doins *.bmp
doman SDLJoytest.1
}