summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-13 08:10:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-13 08:10:45 +0000
commit57622fa077ba3a559a65b5ba6e4782ca9df5f279 (patch)
tree00ab825606a169fab89ad2970983c83bba1c3549 /games-misc
parentfix bug #50442 in -r5 (Manifest recommit) (diff)
downloadgentoo-2-57622fa077ba3a559a65b5ba6e4782ca9df5f279.tar.gz
gentoo-2-57622fa077ba3a559a65b5ba6e4782ca9df5f279.tar.bz2
gentoo-2-57622fa077ba3a559a65b5ba6e4782ca9df5f279.zip
correct S; use flag fixing; error messages; tidy
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/fortune-mod/ChangeLog6
-rw-r--r--games-misc/fortune-mod/fortune-mod-1.0.9708-r1.ebuild24
2 files changed, 19 insertions, 11 deletions
diff --git a/games-misc/fortune-mod/ChangeLog b/games-misc/fortune-mod/ChangeLog
index 311a3322328d..9e14248a4f33 100644
--- a/games-misc/fortune-mod/ChangeLog
+++ b/games-misc/fortune-mod/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-misc/fortune-mod
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/ChangeLog,v 1.4 2004/05/13 07:52:01 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/ChangeLog,v 1.5 2004/05/13 08:10:45 mr_bones_ Exp $
+
+ 13 May 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ fortune-mod-1.0.9708-r1.ebuild:
+ correct S; use flag fixing; error messages; tidy
13 May 2004; Joshua Kinard <kumba@gentoo.org>
fortune-mod-1.0.9708-r1.ebuild, fortune-mod-1.99.1.ebuild:
diff --git a/games-misc/fortune-mod/fortune-mod-1.0.9708-r1.ebuild b/games-misc/fortune-mod/fortune-mod-1.0.9708-r1.ebuild
index cffa4a141aa8..1c5bfcaa2363 100644
--- a/games-misc/fortune-mod/fortune-mod-1.0.9708-r1.ebuild
+++ b/games-misc/fortune-mod/fortune-mod-1.0.9708-r1.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/fortune-mod-1.0.9708-r1.ebuild,v 1.2 2004/05/13 07:52:01 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/fortune-mod-1.0.9708-r1.ebuild,v 1.3 2004/05/13 08:10:45 mr_bones_ Exp $
inherit eutils
-MY_P="${PN}-${P##*.}.tar.gz"
+MY_P="${PN}-${P##*.}"
#The original (http://www.progsoc.uts.edu.au/~dbugger/hacks/hacks.html) is dead
# but the guy setup his 'perm' home with LSM (http://lsm.execpc.com/)
DESCRIPTION="The notorious fortune program"
HOMEPAGE="ftp://sunsite.unc.edu/pub/Linux/games/amusements/fortune/"
-SRC_URI="http://www.ibiblio.org/pub/Linux/games/amusements/fortune/${MY_P}"
+SRC_URI="http://www.ibiblio.org/pub/Linux/games/amusements/fortune/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -29,26 +29,30 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/9708-Makefile.patch
- epatch ${FILESDIR}/9708-ppc-rot.patch
+ epatch "${FILESDIR}/9708-Makefile.patch"
+ epatch "${FILESDIR}/9708-ppc-rot.patch"
}
src_compile() {
- [ `use offensive` ] && off=1 || off=0
+ local off=0
+
+ use offensive && off=1
emake \
OFFENSIVE=${off} \
OPTCFLAGS="${CFLAGS}" \
- || die
+ || die "emake failed"
}
src_install() {
- [ `use offensive` ] && off=1 || off=0
+ local off=0
+
+ use offensive && off=1
make \
OFFENSIVE=${off} \
OPTCFLAGS="${CFLAGS}" \
- DESTDIR=${D} \
+ DESTDIR="${D}" \
install \
- || die
+ || die "make install failed"
dosed /usr/share/man/man6/fortune.6