summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-10-01 00:46:04 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-10-01 00:46:04 +0000
commit5d1aa5ea3315eba62d1b556e5533e4ec3a737bd5 (patch)
tree8caecc66b4f4ef634b87e3bf5cb4d75d4ac29d95 /games-mud/mcl/mcl-0.53.00.ebuild
parentversion bump (in repsonse to bug 30017); convert to use games eclass (diff)
downloadgentoo-2-5d1aa5ea3315eba62d1b556e5533e4ec3a737bd5.tar.gz
gentoo-2-5d1aa5ea3315eba62d1b556e5533e4ec3a737bd5.tar.bz2
gentoo-2-5d1aa5ea3315eba62d1b556e5533e4ec3a737bd5.zip
version bump (in repsonse to bug 30017); convert to use games eclass
Diffstat (limited to 'games-mud/mcl/mcl-0.53.00.ebuild')
-rw-r--r--games-mud/mcl/mcl-0.53.00.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-mud/mcl/mcl-0.53.00.ebuild b/games-mud/mcl/mcl-0.53.00.ebuild
new file mode 100644
index 000000000000..e29ae5c6bff7
--- /dev/null
+++ b/games-mud/mcl/mcl-0.53.00.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/mcl/mcl-0.53.00.ebuild,v 1.1 2003/10/01 00:45:54 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A console MUD client scriptable in Perl and Python"
+SRC_URI="http://www.andreasen.org/mcl/dist/${P}-src.tar.gz"
+HOMEPAGE="http://www.andreasen.org/mcl/"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+IUSE="python perl"
+
+RDEPEND="perl? ( dev-lang/perl )
+ python? ( dev-lang/python )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "/MCL_LIBRARY_PATH/ s:/usr/lib/mcl:${GAMES_LIBDIR}/${PN}:" \
+ h/mcl.h || die "sed h/mcl.h failed"
+}
+
+src_compile() {
+ egamesconf `use_enable perl` `use_enable python` || die
+ emake || die "emake failed"
+}
+
+src_install () {
+ make INSTALL_ROOT=${D} install || die "make install failed"
+ dodoc doc/* || die "dodoc failed"
+ prepgamesdirs
+}