summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-06-14 00:17:47 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-06-14 00:17:47 +0000
commit0241e25c91deea154397954772cc25523825fe11 (patch)
tree4533f0dce7a93e3e4d4640bcd2d0088440201c86 /games-mud
parentFix building with glibc-2.10, bug #273528 (diff)
downloadgentoo-2-0241e25c91deea154397954772cc25523825fe11.tar.gz
gentoo-2-0241e25c91deea154397954772cc25523825fe11.tar.bz2
gentoo-2-0241e25c91deea154397954772cc25523825fe11.zip
Fix building with glibc-2.10, bug #273498
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'games-mud')
-rw-r--r--games-mud/crystal/ChangeLog8
-rw-r--r--games-mud/crystal/crystal-0.2.2.ebuild15
-rw-r--r--games-mud/crystal/files/crystal-0.2.2-glibc2.10.patch11
3 files changed, 24 insertions, 10 deletions
diff --git a/games-mud/crystal/ChangeLog b/games-mud/crystal/ChangeLog
index e82fa874ad46..d5e13adabaeb 100644
--- a/games-mud/crystal/ChangeLog
+++ b/games-mud/crystal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-mud/crystal
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/crystal/ChangeLog,v 1.6 2008/05/01 10:30:07 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/crystal/ChangeLog,v 1.7 2009/06/14 00:17:47 nyhm Exp $
+
+ 14 Jun 2009; Tristan Heaven <nyhm@gentoo.org> crystal-0.2.2.ebuild,
+ +files/crystal-0.2.2-glibc2.10.patch:
+ Fix building with glibc-2.10, bug #273498
01 May 2008; Tristan Heaven <nyhm@gentoo.org>
+files/crystal-0.2.2-64bit.patch, +files/crystal-0.2.2-gcc43.patch,
diff --git a/games-mud/crystal/crystal-0.2.2.ebuild b/games-mud/crystal/crystal-0.2.2.ebuild
index 41a253dcd827..4dd6ca682e70 100644
--- a/games-mud/crystal/crystal-0.2.2.ebuild
+++ b/games-mud/crystal/crystal-0.2.2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/crystal/crystal-0.2.2.ebuild,v 1.2 2008/05/01 10:30:07 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/crystal/crystal-0.2.2.ebuild,v 1.3 2009/06/14 00:17:47 nyhm Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="The crystal MUD client"
@@ -17,18 +18,16 @@ DEPEND="sys-libs/zlib
sys-libs/ncurses
dev-libs/openssl"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch \
"${FILESDIR}"/${P}-64bit.patch \
- "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-glibc2.10.patch
}
-src_compile() {
+src_configure() {
egamesconf \
--disable-scripting || die
- emake || die "emake failed"
}
src_install() {
diff --git a/games-mud/crystal/files/crystal-0.2.2-glibc2.10.patch b/games-mud/crystal/files/crystal-0.2.2-glibc2.10.patch
new file mode 100644
index 000000000000..fc1eaf7679ac
--- /dev/null
+++ b/games-mud/crystal/files/crystal-0.2.2-glibc2.10.patch
@@ -0,0 +1,11 @@
+--- Socket.cc
++++ Socket.cc
+@@ -344,7 +344,7 @@
+
+ const char *srv = 0, *lasth = 0;
+
+- if (char *u=strchr(s, '@')) {
++ if (const char *u=strchr(s, '@')) {
+ printf("We have a username part.\n");
+ username = std::string(s, u-s);
+ has_username = true;