summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-04 20:53:50 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-04 20:53:50 +0000
commitee5e88e0428ca140eb0e9507dbe35138770d9c46 (patch)
treef5145041c6979e9e27d00e4aafb3d6bf117899fc /games-puzzle/amoebax
parentfix DESCRIPTION.toolongs (diff)
downloadgentoo-2-ee5e88e0428ca140eb0e9507dbe35138770d9c46.tar.gz
gentoo-2-ee5e88e0428ca140eb0e9507dbe35138770d9c46.tar.bz2
gentoo-2-ee5e88e0428ca140eb0e9507dbe35138770d9c46.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-puzzle/amoebax')
-rw-r--r--games-puzzle/amoebax/ChangeLog8
-rw-r--r--games-puzzle/amoebax/amoebax-0.2.0.ebuild7
-rw-r--r--games-puzzle/amoebax/files/amoebax-0.2.0-gcc43.patch82
3 files changed, 92 insertions, 5 deletions
diff --git a/games-puzzle/amoebax/ChangeLog b/games-puzzle/amoebax/ChangeLog
index b98808a1ccb0..9b790e3cdd4e 100644
--- a/games-puzzle/amoebax/ChangeLog
+++ b/games-puzzle/amoebax/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/amoebax
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/amoebax/ChangeLog,v 1.2 2007/08/19 17:13:36 angelos Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/amoebax/ChangeLog,v 1.3 2008/05/04 20:53:49 nyhm Exp $
+
+ 04 May 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/amoebax-0.2.0-gcc43.patch, amoebax-0.2.0.ebuild:
+ Fix building with gcc-4.3
19 Aug 2007; Christoph Mende <angelos@gentoo.org> amoebax-0.2.0.ebuild:
Added ~amd64
diff --git a/games-puzzle/amoebax/amoebax-0.2.0.ebuild b/games-puzzle/amoebax/amoebax-0.2.0.ebuild
index d240d7a8192b..6a00609315e9 100644
--- a/games-puzzle/amoebax/amoebax-0.2.0.ebuild
+++ b/games-puzzle/amoebax/amoebax-0.2.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/amoebax/amoebax-0.2.0.ebuild,v 1.2 2007/08/19 17:13:36 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/amoebax/amoebax-0.2.0.ebuild,v 1.3 2008/05/04 20:53:49 nyhm Exp $
-inherit autotools games
+inherit autotools eutils games
DESCRIPTION="a cute and addictive action-puzzle game, similar to tetris"
HOMEPAGE="http://www.emma-soft.com/games/amoebax/"
@@ -20,6 +20,7 @@ DEPEND="media-libs/libsdl
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
sed -i \
-e "/^SUBDIRS/s:doc ::" \
Makefile.am \
diff --git a/games-puzzle/amoebax/files/amoebax-0.2.0-gcc43.patch b/games-puzzle/amoebax/files/amoebax-0.2.0-gcc43.patch
new file mode 100644
index 000000000000..2ee119d5c6c0
--- /dev/null
+++ b/games-puzzle/amoebax/files/amoebax-0.2.0-gcc43.patch
@@ -0,0 +1,82 @@
+--- src/ControlSetupState.cxx
++++ src/ControlSetupState.cxx
+@@ -20,6 +20,7 @@
+ #include <config.h>
+ #endif // !HAVE_CONFIG_H
+ #include <sstream>
++#include <cstdlib>
+ #include "ControlSetupState.h"
+ #include "File.h"
+ #include "Joystick.h"
+--- src/Font.cxx
++++ src/Font.cxx
+@@ -23,6 +23,7 @@
+ #include <config.h>
+ #endif // HAVE_CONFIG_H
+ #include <numeric>
++#include <algorithm>
+ #include <SDL.h>
+ #include "Font.h"
+
+--- src/Joystick.cxx
++++ src/Joystick.cxx
+@@ -19,6 +19,7 @@
+ #if defined (HAVE_CONFIG_H)
+ #include <config.h>
+ #endif // !HAVE_CONFIG_H
++#include <cstdlib>
+ #include "Joystick.h"
+
+ using namespace Amoebax;
+--- src/MainMenuState.cxx
++++ src/MainMenuState.cxx
+@@ -19,6 +19,7 @@
+ #if defined (HAVE_CONFIG_H)
+ #include <config.h>
+ #endif // HAVE_CONFIG_H
++#include <algorithm>
+ #include <SDL.h>
+ #include "AdvancedAIPlayer.h"
+ #include "AnticipatoryAIPlayer.h"
+--- src/OptionsMenuState.cxx
++++ src/OptionsMenuState.cxx
+@@ -20,6 +20,7 @@
+ #include <config.h>
+ #endif // HAVE_CONFIG_H
+ #include <SDL.h>
++#include <algorithm>
+ #include <sstream>
+ #include "ControlSetupState.h"
+ #include "File.h"
+--- src/Sound.h
++++ src/Sound.h
+@@ -19,6 +19,7 @@
+ #if !defined (AMOEBAX_SOUND_H)
+ #define AMOEBAX_SOUND_H
+
++#include <string>
+ #include <SDL_mixer.h>
+
+ namespace Amoebax
+--- src/System.cxx
++++ src/System.cxx
+@@ -19,7 +19,8 @@
+ #if defined (HAVE_CONFIG_H)
+ #include <config.h>
+ #endif // HAVE_CONFIG_H
+-#include <assert.h>
++#include <algorithm>
++#include <cassert>
+ #include <cstdlib>
+ #include <iostream>
+ #include <limits>
+--- src/TwoPlayersState.cxx
++++ src/TwoPlayersState.cxx
+@@ -19,6 +19,7 @@
+ #if defined (HAVE_CONFIG_H)
+ #include <config.h>
+ #endif // HAVE_CONFIG_H
++#include <algorithm>
+ #include <cassert>
+ #include <SDL.h>
+ #include <sstream>