summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-11-05 18:31:24 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-11-05 18:31:24 +0000
commit240da429bd541995192325b28e58d5bc80f74b8d (patch)
tree506a0b9b7b9051d2b22d16b285d1a2fed5766c25 /games-puzzle/biniax2
parentAdd ~ia64/~sparc wrt #289839 (diff)
downloadgentoo-2-240da429bd541995192325b28e58d5bc80f74b8d.tar.gz
gentoo-2-240da429bd541995192325b28e58d5bc80f74b8d.tar.bz2
gentoo-2-240da429bd541995192325b28e58d5bc80f74b8d.zip
Initial commit
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'games-puzzle/biniax2')
-rw-r--r--games-puzzle/biniax2/ChangeLog11
-rw-r--r--games-puzzle/biniax2/biniax2-1.30.ebuild41
-rw-r--r--games-puzzle/biniax2/files/biniax2-1.30-build.patch18
-rw-r--r--games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch60
-rw-r--r--games-puzzle/biniax2/files/biniax2.xpm41
-rw-r--r--games-puzzle/biniax2/metadata.xml5
6 files changed, 176 insertions, 0 deletions
diff --git a/games-puzzle/biniax2/ChangeLog b/games-puzzle/biniax2/ChangeLog
new file mode 100644
index 000000000000..94ff23fdb4c7
--- /dev/null
+++ b/games-puzzle/biniax2/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-puzzle/biniax2
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/biniax2/ChangeLog,v 1.1 2009/11/05 18:31:24 nyhm Exp $
+
+*biniax2-1.30 (05 Nov 2009)
+
+ 05 Nov 2009; Tristan Heaven <nyhm@gentoo.org> +biniax2-1.30.ebuild,
+ +files/biniax2-1.30-build.patch, +files/biniax2-1.30-dotfiles.patch,
+ +files/biniax2.xpm, +metadata.xml:
+ Initial commit
+
diff --git a/games-puzzle/biniax2/biniax2-1.30.ebuild b/games-puzzle/biniax2/biniax2-1.30.ebuild
new file mode 100644
index 000000000000..375fde0e420b
--- /dev/null
+++ b/games-puzzle/biniax2/biniax2-1.30.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/biniax2/biniax2-1.30.ebuild,v 1.1 2009/11/05 18:31:24 nyhm Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Logic game with arcade and tactics modes"
+HOMEPAGE="http://biniax.com/"
+SRC_URI="http://mordred.dir.bg/biniax/${P}-fullsrc.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mikmod]"
+
+S=${WORKDIR}
+
+src_prepare() {
+ rm -f data/Thumbs.db
+ sed -i \
+ -e "s:data/:${GAMES_DATADIR}/${PN}/:" \
+ desktop/{gfx,snd}.c \
+ || die "sed failed"
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-dotfiles.patch
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/* || die "doins failed"
+ doicon "${FILESDIR}"/${PN}.xpm
+ make_desktop_entry ${PN} Biniax-2
+ prepgamesdirs
+}
diff --git a/games-puzzle/biniax2/files/biniax2-1.30-build.patch b/games-puzzle/biniax2/files/biniax2-1.30-build.patch
new file mode 100644
index 000000000000..26c053c2e98e
--- /dev/null
+++ b/games-puzzle/biniax2/files/biniax2-1.30-build.patch
@@ -0,0 +1,18 @@
+--- makefile
++++ makefile
+@@ -4,7 +4,7 @@
+ # To execute the game you need the runtimes of SDL, SDL_mixer and SDL_image.
+
+ FLAGS=-W -WALL
+-CC=gcc
++CC?=gcc
+ FILES=biniax.c hof.c desktop/cfg.c desktop/gfx.c desktop/snd.c desktop/inp.c desktop/sys.c
+ INCLUDES=-I . -I desktop
+ LINKTO=-lSDL -lSDL_mixer -lSDL_image
+@@ -12,4 +12,4 @@
+ TARGET=biniax2
+
+ biniax:
+- $(CC) $(AUTO) $(FILES) $(INCLUDES) -o $(TARGET) $(LINKTO)
+\ No newline at end of file
++ $(CC) $(CFLAGS) $(LDFLAGS) $(AUTO) $(FILES) $(INCLUDES) -o $(TARGET) $(LINKTO)
diff --git a/games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch b/games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch
new file mode 100644
index 000000000000..2cd212d6857c
--- /dev/null
+++ b/games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch
@@ -0,0 +1,60 @@
+--- biniax.c
++++ biniax.c
+@@ -47,6 +47,8 @@
+ INCLUDES
+ ******************************************************************************/
+
++#include <unistd.h>
++
+ #include "game.h"
+ #include "lev.h"
+ #include "inc.h"
+@@ -97,6 +99,8 @@
+ UNREF( argc );
+ UNREF( argv );
+
++ chdir( getenv( "HOME" ) );
++
+ cfgInit();
+ hofInit();
+ if ( gfxInit() == BNX_FALSE )
+--- desktop/cfg.c
++++ desktop/cfg.c
+@@ -36,7 +36,7 @@
+ ******************************************************************************/
+
+ #define _Cfg_Buffer 255
+-#define csConfigName "config.bnx2"
++#define csConfigName ".config.bnx2"
+
+ struct BNX_SETUP
+ {
+--- game.h
++++ game.h
+@@ -37,7 +37,7 @@
+ DEFINITIONS
+ ******************************************************************************/
+
+-#define csSaveGameName "autosave.bnx2"
++#define csSaveGameName ".autosave.bnx2"
+
+ /******************************************************************************
+ CONSTANTS
+--- hof.c
++++ hof.c
+@@ -34,7 +34,7 @@
+ #define chCursor '_' /* Cursor ON */
+ #define chSpace ' ' /* Cursor OFF*/
+
+-#define csHOFName "hof.bnx2" /* File name */
++#define csHOFName ".hof.bnx2" /* File name */
+ #define cHOFFileSize 504 /* File size */
+
+ BNX_HALL Hof;
+@@ -292,4 +292,4 @@
+ BNX_HALL *hofGet()
+ {
+ return (BNX_HALL *) &Hof;
+-}
+\ No newline at end of file
++}
diff --git a/games-puzzle/biniax2/files/biniax2.xpm b/games-puzzle/biniax2/files/biniax2.xpm
new file mode 100644
index 000000000000..da3c5ddd7d1d
--- /dev/null
+++ b/games-puzzle/biniax2/files/biniax2.xpm
@@ -0,0 +1,41 @@
+/* XPM */
+static char * icon_xpm[] = {
+"32 32 6 1",
+" c None",
+". c #800000",
+"+ c #FF8204",
+"@ c #FC4E04",
+"# c #FCA204",
+"$ c #FEC489",
+" ",
+" ",
+" ",
+" . ",
+" ++++++++++ .@. ",
+" +########$ .@@@$ ",
+" +#$$$$$$$$ $@$ ",
+" +#$ $ ",
+" +#$ ",
+" +#$ ",
+" +#$ ++++ +++ +++ ",
+" +#$ +#### +#$ +#$ ",
+" +#$ +####+ +#$ +#$ ",
+" +#$ +#$#### +#$ +#$ ",
+" +#$ +#$ $##+ +#$ +#$ ",
+" +#$ +#$ #### +#$ +#$ ",
+" +#$ +#$ $##+ +#$ +#$ ",
+" +#$ +#$ #### +#$ +#$ ",
+" +#$ +#$ $##+ +#$ +#$ ",
+" +#$ +#$ ######$ +#$ ",
+" +#$ +#$ $####$ +#$ ",
+" +#$ +#$ ####$ +#$ ",
+" $$$ $$$ $$$$ +#$ ",
+" +#$ ",
+" +#$ ",
+" . +#$ ",
+" .@. ++++++++#$ ",
+" .@@@$ +########$ ",
+" $@$ $$$$$$$$$$ ",
+" $ ",
+" ",
+" "};
diff --git a/games-puzzle/biniax2/metadata.xml b/games-puzzle/biniax2/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/biniax2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>