summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 06:36:01 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 06:36:01 +0000
commit2f7b073c1bc54c873666c4522cd6cd49ac1d59df (patch)
tree072f3e7b49f6b078b595b1483277009b1f03d0f6 /games-puzzle/cuyo/cuyo-1.6.1.ebuild
parentgames-puzzle (diff)
downloadgentoo-2-2f7b073c1bc54c873666c4522cd6cd49ac1d59df.tar.gz
gentoo-2-2f7b073c1bc54c873666c4522cd6cd49ac1d59df.tar.bz2
gentoo-2-2f7b073c1bc54c873666c4522cd6cd49ac1d59df.zip
games-puzzle !@
Diffstat (limited to 'games-puzzle/cuyo/cuyo-1.6.1.ebuild')
-rw-r--r--games-puzzle/cuyo/cuyo-1.6.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-puzzle/cuyo/cuyo-1.6.1.ebuild b/games-puzzle/cuyo/cuyo-1.6.1.ebuild
new file mode 100644
index 000000000000..a7cf1fc215e9
--- /dev/null
+++ b/games-puzzle/cuyo/cuyo-1.6.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/cuyo/cuyo-1.6.1.ebuild,v 1.1 2003/09/10 06:36:00 vapier Exp $
+
+inherit games
+
+S=${WORKDIR}/${P/_}
+DESCRIPTION="highly addictive and remotely related to tetris"
+SRC_URI="http://savannah.nongnu.org/download/cuyo/${P//_}.tar.gz"
+HOMEPAGE="http://www.karimmi.de/cuyo/"
+
+KEYWORDS="x86 ppc"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ =x11-libs/qt-2*"
+
+src_compile() {
+ egamesconf \
+ --with-qt \
+ --with-qt-dir=/usr/qt/2 \
+ --with-x \
+ || die
+ emake || die
+}
+
+src_install() {
+ cp data/Makefile{,.old}
+ sed -e 's: $(pkgdatadir: $(DESTDIR)$(pkgdatadir:' \
+ data/Makefile.old > data/Makefile
+ make install DESTDIR=${D} || die
+ dodoc AUTHORS COPYING INSTALL NEWS README TODO ChangeLog
+
+ prepgamesdirs
+}