summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-06 08:38:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-06 08:38:23 +0000
commit6961fc70e604c253383f5a9123e6c86a8732b813 (patch)
treef1b15a7bec6ffb3cab107d04a8b3cca8e9d0e181 /games-puzzle/galaxis/galaxis-1.7.ebuild
parentinitial commit - ebuild submitted by Daniel Fullmer via bug #47649 (Manifest ... (diff)
downloadgentoo-2-6961fc70e604c253383f5a9123e6c86a8732b813.tar.gz
gentoo-2-6961fc70e604c253383f5a9123e6c86a8732b813.tar.bz2
gentoo-2-6961fc70e604c253383f5a9123e6c86a8732b813.zip
initial commit - ebuild submitted by Alexandru Toma via bug #48245
Diffstat (limited to 'games-puzzle/galaxis/galaxis-1.7.ebuild')
-rw-r--r--games-puzzle/galaxis/galaxis-1.7.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-puzzle/galaxis/galaxis-1.7.ebuild b/games-puzzle/galaxis/galaxis-1.7.ebuild
new file mode 100644
index 000000000000..4a74f12d7c6e
--- /dev/null
+++ b/games-puzzle/galaxis/galaxis-1.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/galaxis/galaxis-1.7.ebuild,v 1.1 2004/06/06 08:38:23 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A UNIX-hosted, curses-based clone of the nifty little Macintosh freeware game Galaxis"
+HOMEPAGE="http://www.catb.org/~esr/galaxis/"
+SRC_URI="http://www.catb.org/~esr/galaxis/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.4"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Modify CFLAGS
+ sed -i \
+ -e '/^CFLAGS/s:-g:$(E_CFLAGS):' \
+ Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake E_CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dogamesbin galaxis || die "dogamesbin failed"
+ doman galaxis.6
+ dodoc README
+ prepgamesdirs
+}