summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-16 19:55:52 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-16 19:55:52 +0000
commit00e2673a54fc186bc488f54a1e2fe738cbf92d1a (patch)
tree70aeb59099f637edf31acdf5765b8217149bf9cd /games-puzzle/galaxis
parentUse DOCS and add a call to die(). (diff)
downloadgentoo-2-00e2673a54fc186bc488f54a1e2fe738cbf92d1a.tar.gz
gentoo-2-00e2673a54fc186bc488f54a1e2fe738cbf92d1a.tar.bz2
gentoo-2-00e2673a54fc186bc488f54a1e2fe738cbf92d1a.zip
Respect LDFLAGS. Bug #334635
(Portage version: 2.1.9.14/cvs/Linux i686)
Diffstat (limited to 'games-puzzle/galaxis')
-rw-r--r--games-puzzle/galaxis/ChangeLog7
-rw-r--r--games-puzzle/galaxis/galaxis-1.7.ebuild9
2 files changed, 10 insertions, 6 deletions
diff --git a/games-puzzle/galaxis/ChangeLog b/games-puzzle/galaxis/ChangeLog
index b3e834b0c324..45caa36adb7d 100644
--- a/games-puzzle/galaxis/ChangeLog
+++ b/games-puzzle/galaxis/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/galaxis
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/galaxis/ChangeLog,v 1.10 2009/01/29 02:10:20 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/galaxis/ChangeLog,v 1.11 2010/10/16 19:55:52 tupone Exp $
+
+ 16 Oct 2010; Tupone Alfredo <tupone@gentoo.org> galaxis-1.7.ebuild:
+ Respect LDFLAGS. Bug #334635 by flameeyes@gentoo.org
29 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> galaxis-1.7.ebuild:
EAPI=2; respect CC
diff --git a/games-puzzle/galaxis/galaxis-1.7.ebuild b/games-puzzle/galaxis/galaxis-1.7.ebuild
index 358690d8fc5a..4139635843ad 100644
--- a/games-puzzle/galaxis/galaxis-1.7.ebuild
+++ b/games-puzzle/galaxis/galaxis-1.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/galaxis/galaxis-1.7.ebuild,v 1.10 2009/01/29 02:10:20 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/galaxis/galaxis-1.7.ebuild,v 1.11 2010/10/16 19:55:52 tupone Exp $
EAPI=2
inherit games
@@ -14,7 +14,8 @@ SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
IUSE=""
-DEPEND=">=sys-libs/ncurses-5.3"
+RDEPEND=">=sys-libs/ncurses-5.3"
+DEPEND="${RDEPEND}"
src_prepare() {
# Modify CFLAGS
@@ -25,7 +26,7 @@ src_prepare() {
}
src_compile() {
- emake E_CFLAGS="${CFLAGS}" || die "emake failed"
+ emake E_CFLAGS="${LDFLAGS} ${CFLAGS}" || die "emake failed"
}
src_install() {