summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-12 09:02:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-12 09:02:46 +0000
commit36f033373c281af1793a0bdc033d004e9d129f59 (patch)
tree29e637012cd09fb89fbc62b23f6474d0c4ba2bec /games-puzzle/greedy/greedy-0.2.0-r1.ebuild
parentnative widget stuff now also for gtk (diff)
downloadgentoo-2-36f033373c281af1793a0bdc033d004e9d129f59.tar.gz
gentoo-2-36f033373c281af1793a0bdc033d004e9d129f59.tar.bz2
gentoo-2-36f033373c281af1793a0bdc033d004e9d129f59.zip
IUSE; error check; tidy
Diffstat (limited to 'games-puzzle/greedy/greedy-0.2.0-r1.ebuild')
-rw-r--r--games-puzzle/greedy/greedy-0.2.0-r1.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/games-puzzle/greedy/greedy-0.2.0-r1.ebuild b/games-puzzle/greedy/greedy-0.2.0-r1.ebuild
index 414389ac43fb..c6248bf84797 100644
--- a/games-puzzle/greedy/greedy-0.2.0-r1.ebuild
+++ b/games-puzzle/greedy/greedy-0.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/greedy/greedy-0.2.0-r1.ebuild,v 1.3 2004/03/07 21:50:39 jhuebel Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/greedy/greedy-0.2.0-r1.ebuild,v 1.4 2004/05/12 09:02:45 mr_bones_ Exp $
inherit games
@@ -8,9 +8,10 @@ DESCRIPTION="fun little ncurses puzzle game"
HOMEPAGE="http://www.kotinet.com/juhamattin/linux/index.html"
SRC_URI="http://www.kotinet.com/juhamattin/linux/download/${P}.tar.gz"
-KEYWORDS="x86 ppc amd64"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 ppc amd64"
+IUSE=""
DEPEND="virtual/glibc
sys-libs/ncurses"
@@ -22,13 +23,13 @@ src_compile() {
src_install() {
# It wants a scores file. We need to touch one and install it.
touch greedy.scores
- insinto ${GAMES_STATEDIR}
+ insinto "${GAMES_STATEDIR}"
doins greedy.scores || die "doins failed"
dogamesbin greedy || die "dogamesbin failed"
- dodoc CHANGES README TODO || die "dodoc failed"
+ dodoc CHANGES README TODO
prepgamesdirs
# We need to set the permissions correctly
- chmod 664 ${D}/${GAMES_STATEDIR}/greedy.scores || die "chmod failed"
+ chmod 664 "${D}/${GAMES_STATEDIR}/greedy.scores" || die "chmod failed"
}