summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-06-16 06:16:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-06-16 06:16:17 +0000
commit986261e5522275c66f1e20cc35fdf1f6ca0dd9df (patch)
treedd5bd86e0ae5073eed5d7da85c65f76e1c6fd608 /games-puzzle/scramble/scramble-0.9.5.ebuild
parentVersion bump. (diff)
downloadgentoo-2-986261e5522275c66f1e20cc35fdf1f6ca0dd9df.tar.gz
gentoo-2-986261e5522275c66f1e20cc35fdf1f6ca0dd9df.tar.bz2
gentoo-2-986261e5522275c66f1e20cc35fdf1f6ca0dd9df.zip
EAPI=5; fix build (bug #513412)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle/scramble/scramble-0.9.5.ebuild')
-rw-r--r--games-puzzle/scramble/scramble-0.9.5.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/games-puzzle/scramble/scramble-0.9.5.ebuild b/games-puzzle/scramble/scramble-0.9.5.ebuild
index f55f4c6a981b..e42c15e54625 100644
--- a/games-puzzle/scramble/scramble-0.9.5.ebuild
+++ b/games-puzzle/scramble/scramble-0.9.5.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/scramble/scramble-0.9.5.ebuild,v 1.2 2007/04/26 07:20:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/scramble/scramble-0.9.5.ebuild,v 1.3 2014/06/16 06:16:17 mr_bones_ Exp $
-inherit games
+EAPI=5
+inherit autotools flag-o-matic games
DESCRIPTION="Create as many words as you can before the time runs out"
HOMEPAGE="http://www.shiftygames.com/scramble/scramble.html"
@@ -13,14 +14,19 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
IUSE=""
-DEPEND=">=media-libs/libsdl-1.2
- >=media-libs/sdl-mixer-1.2
- >=media-libs/sdl-image-1.2
+DEPEND=">=media-libs/libsdl-1.2[sound,video]
+ >=media-libs/sdl-mixer-1.2[vorbis]
+ >=media-libs/sdl-image-1.2[png]
media-libs/sdl-ttf"
RDEPEND="${DEPEND}
sys-apps/miscfiles"
+src_prepare() {
+ append-cflags $(sdl-config --cflags)
+ eautoreconf
+}
+
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ default
prepgamesdirs
}