summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-07-19 18:17:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-07-19 18:17:28 +0000
commitf658eaf2c4f65e0632ff031201cfc26d2f5b4ca1 (patch)
tree79987379141c8767c7336fd7e4e264e345d005e0 /games-puzzle/toppler/toppler-1.1.3.ebuild
parentDropped ppc-macos keyword, see you in prefix (diff)
downloadgentoo-2-f658eaf2c4f65e0632ff031201cfc26d2f5b4ca1.tar.gz
gentoo-2-f658eaf2c4f65e0632ff031201cfc26d2f5b4ca1.tar.bz2
gentoo-2-f658eaf2c4f65e0632ff031201cfc26d2f5b4ca1.zip
version bump
(Portage version: 2.1.2.9)
Diffstat (limited to 'games-puzzle/toppler/toppler-1.1.3.ebuild')
-rw-r--r--games-puzzle/toppler/toppler-1.1.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-puzzle/toppler/toppler-1.1.3.ebuild b/games-puzzle/toppler/toppler-1.1.3.ebuild
new file mode 100644
index 000000000000..6177f9818c2e
--- /dev/null
+++ b/games-puzzle/toppler/toppler-1.1.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/toppler/toppler-1.1.3.ebuild,v 1.1 2007/07/19 18:17:28 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Reimplementation of Nebulous using SDL"
+HOMEPAGE="http://toppler.sourceforge.net/"
+SRC_URI="mirror://sourceforge/toppler/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${P/a/}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's/ install-dist_pkgdocDATA//' \
+ -e '/^applicationsdir/ s:$(datadir):/usr/share:' \
+ -e '/^pixmapsdir/ s:$(datadir):/usr/share:' \
+ Makefile.in \
+ || die "sed failed"
+ sed -i \
+ -e '/^localedir/ s:$(datadir):/usr/share:' \
+ po/Makefile.in.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ egamesconf $(use_enable nls) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+ prepgamesdirs
+}