summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-13 02:02:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-13 02:02:32 +0000
commita9a27d5bad3779830bdeb45c8d0bf463c2d02a41 (patch)
treeab4ce598efb9c3e228904a2455efe37c749bb896 /games-puzzle/xlogical
parentnewer gcc uses -pthread (bug #254689) (diff)
downloadgentoo-2-a9a27d5bad3779830bdeb45c8d0bf463c2d02a41.tar.gz
gentoo-2-a9a27d5bad3779830bdeb45c8d0bf463c2d02a41.tar.bz2
gentoo-2-a9a27d5bad3779830bdeb45c8d0bf463c2d02a41.zip
EAPI=2; add use-based deps (bug #209009); add alternate graphics support
(Portage version: 2.1.6.4/cvs/Linux 2.6.27.8 i686)
Diffstat (limited to 'games-puzzle/xlogical')
-rw-r--r--games-puzzle/xlogical/ChangeLog8
-rw-r--r--games-puzzle/xlogical/metadata.xml3
-rw-r--r--games-puzzle/xlogical/xlogical-1.0.7.ebuild32
3 files changed, 31 insertions, 12 deletions
diff --git a/games-puzzle/xlogical/ChangeLog b/games-puzzle/xlogical/ChangeLog
index bb59021958d4..d4620340fd85 100644
--- a/games-puzzle/xlogical/ChangeLog
+++ b/games-puzzle/xlogical/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/xlogical
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xlogical/ChangeLog,v 1.4 2008/05/04 21:08:55 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xlogical/ChangeLog,v 1.5 2009/01/13 02:02:32 mr_bones_ Exp $
+
+ 13 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> metadata.xml,
+ xlogical-1.0.7.ebuild:
+ EAPI=2; add use-based deps (bug #209009); add alternate graphics support
04 May 2008; Tristan Heaven <nyhm@gentoo.org>
+files/xlogical-1.0.7-gcc43.patch, xlogical-1.0.7.ebuild:
diff --git a/games-puzzle/xlogical/metadata.xml b/games-puzzle/xlogical/metadata.xml
index 8be643a7ce06..36ec4edcdc0d 100644
--- a/games-puzzle/xlogical/metadata.xml
+++ b/games-puzzle/xlogical/metadata.xml
@@ -6,4 +6,7 @@
XLogical is a puzzle game based on the Logical! game that was originally
released by Rainbow Arts on the Commodore Amiga computer.
</longdescription>
+ <use>
+ <flag name="alt_gfx">Use alternate graphics which are closer to the original Amiga version</flag>
+ </use>
</pkgmetadata>
diff --git a/games-puzzle/xlogical/xlogical-1.0.7.ebuild b/games-puzzle/xlogical/xlogical-1.0.7.ebuild
index 872f8c1fa509..dd89dfc02c72 100644
--- a/games-puzzle/xlogical/xlogical-1.0.7.ebuild
+++ b/games-puzzle/xlogical/xlogical-1.0.7.ebuild
@@ -1,29 +1,39 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xlogical/xlogical-1.0.7.ebuild,v 1.6 2008/05/04 21:08:55 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xlogical/xlogical-1.0.7.ebuild,v 1.7 2009/01/13 02:02:32 mr_bones_ Exp $
+EAPI=2
inherit autotools versionator eutils games
MY_PV=$(replace_version_separator 2 '-' )
MY_P=${PN}-${MY_PV}
DESCRIPTION="SDL logical clone"
HOMEPAGE="http://changeling.ixionstudios.com/xlogical/"
-SRC_URI="http://changeling.ixionstudios.com/xlogical/downloads/${MY_P}.tar.bz2"
+SRC_URI="http://changeling.ixionstudios.com/xlogical/downloads/${MY_P}.tar.bz2
+ alt_gfx? ( http://changeling.ixionstudios.com/xlogical/downloads/xlogical_gfx.zip )"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 x86"
-IUSE=""
+IUSE="alt_gfx"
-DEPEND="media-libs/libsdl
- media-libs/sdl-image
- media-libs/sdl-mixer"
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-image[jpeg]
+ media-libs/sdl-mixer[mikmod]"
+DEPEND="${RDEPEND}
+ alt_gfx? ( app-arch/unzip )"
S=${WORKDIR}/${PN}-$(get_version_component_range 1-2)
src_unpack() {
- unpack ${A}
- cd "${S}"
+ unpack ${MY_P}.tar.bz2
+ if use alt_gfx ; then
+ cd "${S}/images"
+ unpack xlogical_gfx.zip
+ fi
+}
+
+src_prepare() {
sed -i '/^CXXFLAGS/d' Makefile.am || die "sed failed"
edos2unix properties.h anim.h exception.h
epatch \
@@ -38,11 +48,13 @@ src_install() {
insinto "${GAMES_DATADIR}"/${PN}
doins -r ${PN}.{properties,levels} music sound images \
|| die "installing game data failed"
+ find "${D}" -name "Makefile*" -exec rm -f '{}' +
insinto "${GAMES_STATEDIR}"/${PN}
- insopts -m0660
doins ${PN}.scores || die "installing hi-score failed"
+ fperms 0660 "${GAMES_STATEDIR}"/${PN}/${PN}.scores
dodoc AUTHORS ChangeLog NEWS README TODO
+ make_desktop_entry ${PN} "Xlogical"
prepgamesdirs
}