summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-11-18 23:34:26 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-11-18 23:34:26 +0000
commit3c451cb72cc12b0bb99dec01d7580b76a3f1edf8 (patch)
tree49a36c7e9be6c0e05d8b03a8f4d5228a75ccc9f1 /games-puzzle/xye/xye-0.7.6.2.ebuild
parentVersion bump, bug #154557 (diff)
downloadgentoo-2-3c451cb72cc12b0bb99dec01d7580b76a3f1edf8.tar.gz
gentoo-2-3c451cb72cc12b0bb99dec01d7580b76a3f1edf8.tar.bz2
gentoo-2-3c451cb72cc12b0bb99dec01d7580b76a3f1edf8.zip
Version bump
(Portage version: 2.1.2_rc2)
Diffstat (limited to 'games-puzzle/xye/xye-0.7.6.2.ebuild')
-rw-r--r--games-puzzle/xye/xye-0.7.6.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-puzzle/xye/xye-0.7.6.2.ebuild b/games-puzzle/xye/xye-0.7.6.2.ebuild
new file mode 100644
index 000000000000..795641c8ebcc
--- /dev/null
+++ b/games-puzzle/xye/xye-0.7.6.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xye/xye-0.7.6.2.ebuild,v 1.1 2006/11/18 23:34:26 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="Free version of the classic game Kye"
+HOMEPAGE="http://xye.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xye/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image"
+
+pkg_setup() {
+ if ! built_with_use media-libs/sdl-image png ; then
+ eerror "You need the png useflag enabled on media-libs/sdl-image."
+ eerror "Please emerge media-libs/sdl-image with USE=\"png\""
+ die "Missing png useflag."
+ fi
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i '/^xye_LDFLAGS/d' Makefile.in || die "sed failed"
+}
+
+src_install() {
+ dogamesbin "${PN}" || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r levels res || die "doins failed"
+ dodoc format.txt template.xye.xml GAMEINTRO.txt AUTHORS \
+ ChangeLog README NEWS
+ newicon xyeicon.png ${PN}.png
+ make_desktop_entry ${PN} Xye
+ prepgamesdirs
+}