summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-09-15 20:32:40 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-09-15 20:32:40 +0000
commit0705c3b6d0bde7c108b0ae69b68562eabf67881c (patch)
tree215619fd13fbb056c4864afeb9be735a8c7b9776 /games-puzzle
parentversion bump (diff)
downloadgentoo-2-0705c3b6d0bde7c108b0ae69b68562eabf67881c.tar.gz
gentoo-2-0705c3b6d0bde7c108b0ae69b68562eabf67881c.tar.bz2
gentoo-2-0705c3b6d0bde7c108b0ae69b68562eabf67881c.zip
tidy
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/tod/tod-0.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/games-puzzle/tod/tod-0.ebuild b/games-puzzle/tod/tod-0.ebuild
index dd4f458c0f90..c5c966ab1a41 100644
--- a/games-puzzle/tod/tod-0.ebuild
+++ b/games-puzzle/tod/tod-0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tod/tod-0.ebuild,v 1.2 2005/08/24 03:36:01 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tod/tod-0.ebuild,v 1.3 2005/09/15 20:32:40 mr_bones_ Exp $
inherit eutils games
@@ -13,7 +13,9 @@ SLOT="0"
KEYWORDS="~amd64 x86"
IUSE=""
-DEPEND="media-libs/allegro"
+RDEPEND="media-libs/allegro"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S=${WORKDIR}
@@ -23,16 +25,13 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-makefile.patch
sed -i \
-e "s:idltd\.dat:${GAMES_DATADIR}/${PN}/idltd.dat:" \
- rec.c || die
-}
-
-src_compile() {
- emake -f makefile || die "make failed"
+ rec.c || die "sed failed"
}
src_install() {
- newgamesbin tod-debug.exe tod || die
+ newgamesbin tod-debug.exe tod || die "newgamesbin failed"
insinto "${GAMES_DATADIR}"/${PN}
- doins idltd.dat || die
+ doins idltd.dat || die "doins failed"
dodoc readme.txt
+ prepgamesdirs
}