summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-09-28 10:21:59 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-09-28 10:21:59 +0000
commit075e57ae9c5cc7f9e385e5784dfe10d10928e215 (patch)
tree84f8ba57a92af8c12247a4b570a6c0152b26a4ca /games-puzzle
parentStable on alpha as per bug #148798 (diff)
downloadgentoo-2-075e57ae9c5cc7f9e385e5784dfe10d10928e215.tar.gz
gentoo-2-075e57ae9c5cc7f9e385e5784dfe10d10928e215.tar.bz2
gentoo-2-075e57ae9c5cc7f9e385e5784dfe10d10928e215.zip
Add patch from Thomas Cort to fix 64 bit compile errors, bug #143841
(Portage version: 2.1.2_pre1-r4)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/einstein/ChangeLog6
-rw-r--r--games-puzzle/einstein/einstein-2.0.ebuild3
-rw-r--r--games-puzzle/einstein/files/einstein-2.0-64bit.patch32
3 files changed, 39 insertions, 2 deletions
diff --git a/games-puzzle/einstein/ChangeLog b/games-puzzle/einstein/ChangeLog
index 282da0223add..902cde6dc1b2 100644
--- a/games-puzzle/einstein/ChangeLog
+++ b/games-puzzle/einstein/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/einstein
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/einstein/ChangeLog,v 1.2 2006/03/22 02:18:14 deltacow Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/einstein/ChangeLog,v 1.3 2006/09/28 10:21:59 nyhm Exp $
+
+ 28 Sep 2006; Tristan Heaven <nyhm@gentoo.org>
+ +files/einstein-2.0-64bit.patch, einstein-2.0.ebuild:
+ Add patch from Thomas Cort to fix 64 bit compile errors, bug #143841
22 Mar 2006; Scott Stoddard <deltacow@gentoo.org> einstein-2.0.ebuild:
~amd64 added wrt bug #126858
diff --git a/games-puzzle/einstein/einstein-2.0.ebuild b/games-puzzle/einstein/einstein-2.0.ebuild
index 1576cd7ac3b2..4b0c508317e1 100644
--- a/games-puzzle/einstein/einstein-2.0.ebuild
+++ b/games-puzzle/einstein/einstein-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/einstein/einstein-2.0.ebuild,v 1.2 2006/03/22 02:18:14 deltacow Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/einstein/einstein-2.0.ebuild,v 1.3 2006/09/28 10:21:59 nyhm Exp $
inherit eutils games
@@ -20,6 +20,7 @@ DEPEND="media-libs/libsdl
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-64bit.patch
sed -i \
-e "/PREFIX/s:/usr/local:${GAMES_PREFIX}:" \
-e "s:\$(PREFIX)/share/einstein:${GAMES_DATADIR}/${PN}:" \
diff --git a/games-puzzle/einstein/files/einstein-2.0-64bit.patch b/games-puzzle/einstein/files/einstein-2.0-64bit.patch
new file mode 100644
index 000000000000..4302bd3b40e1
--- /dev/null
+++ b/games-puzzle/einstein/files/einstein-2.0-64bit.patch
@@ -0,0 +1,32 @@
+diff -urN einstein-2.0.orig/formatter.cpp einstein-2.0/formatter.cpp
+--- einstein-2.0.orig/formatter.cpp 2005-08-13 22:40:58.000000000 -0400
++++ einstein-2.0/formatter.cpp 2006-08-15 11:18:28.000000000 -0400
+@@ -58,7 +58,7 @@
+ if ((c.type == INT_ARG) || (c.type == STRING_ARG) ||
+ (c.type == FLOAT_ARG) || (c.type == DOUBLE_ARG))
+ {
+- int no = (int)c.data;
++ long int no = (long int)c.data;
+ args[no - 1] = c.type;
+ }
+ }
+@@ -123,7 +123,7 @@
+ std::wstring Formatter::format(std::vector<ArgValue*> &argValues) const
+ {
+ std::wstring s;
+- int no;
++ long int no;
+
+ for (int i = 0; i < commandsCnt; i++) {
+ Command *cmd = &commands[i];
+@@ -135,8 +135,8 @@
+
+ case STRING_ARG:
+ case INT_ARG:
+- no = (int)cmd->data - 1;
+- if (no < (int)argValues.size())
++ no = (long int)cmd->data - 1;
++ if (no < (long int)argValues.size())
+ s += argValues[no]->format(cmd);
+ break;
+