summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-04-04 19:09:49 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-04-04 19:09:49 +0000
commit0d335e792dce1eae478d01a59c0f0ffd0b735414 (patch)
tree394225556a44d1c3d03487aaad8d801faf077661 /games-puzzle
parentStable on Alpha as per security bug #172293 (diff)
downloadgentoo-2-0d335e792dce1eae478d01a59c0f0ffd0b735414.tar.gz
gentoo-2-0d335e792dce1eae478d01a59c0f0ffd0b735414.tar.bz2
gentoo-2-0d335e792dce1eae478d01a59c0f0ffd0b735414.zip
Fix for tclx-8.4
(Portage version: 2.1.2.3)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/penguzzle/ChangeLog8
-rw-r--r--games-puzzle/penguzzle/files/digest-penguzzle-1.0-r1 (renamed from games-puzzle/penguzzle/files/digest-penguzzle-1.0)0
-rw-r--r--games-puzzle/penguzzle/files/penguzzle-1.0-tclx.patch10
-rw-r--r--games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild49
-rw-r--r--games-puzzle/penguzzle/penguzzle-1.0.ebuild35
5 files changed, 66 insertions, 36 deletions
diff --git a/games-puzzle/penguzzle/ChangeLog b/games-puzzle/penguzzle/ChangeLog
index 06860fa49e74..513599613be6 100644
--- a/games-puzzle/penguzzle/ChangeLog
+++ b/games-puzzle/penguzzle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/penguzzle
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/penguzzle/ChangeLog,v 1.6 2007/02/08 21:18:31 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/penguzzle/ChangeLog,v 1.7 2007/04/04 19:09:49 nyhm Exp $
+
+*penguzzle-1.0-r1 (04 Apr 2007)
+
+ 04 Apr 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/penguzzle-1.0-tclx.patch, +penguzzle-1.0-r1.ebuild:
+ Fix for tclx-8.4
08 Feb 2007; Chris Gianelloni <wolf31o2@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/games-puzzle/penguzzle/files/digest-penguzzle-1.0 b/games-puzzle/penguzzle/files/digest-penguzzle-1.0-r1
index 9254009638b1..9254009638b1 100644
--- a/games-puzzle/penguzzle/files/digest-penguzzle-1.0
+++ b/games-puzzle/penguzzle/files/digest-penguzzle-1.0-r1
diff --git a/games-puzzle/penguzzle/files/penguzzle-1.0-tclx.patch b/games-puzzle/penguzzle/files/penguzzle-1.0-tclx.patch
new file mode 100644
index 000000000000..d8c078de6a91
--- /dev/null
+++ b/games-puzzle/penguzzle/files/penguzzle-1.0-tclx.patch
@@ -0,0 +1,10 @@
+--- bin/penguzzle
++++ bin/penguzzle
+@@ -1,4 +1,6 @@
+-#!/usr/bin/wishx
++#!/usr/bin/wish
++package require Tk
++package require Tclx
+
+ source ~/puzz/lib/init
+
diff --git a/games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild b/games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild
new file mode 100644
index 000000000000..cf8e71067077
--- /dev/null
+++ b/games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild,v 1.1 2007/04/04 19:09:49 nyhm Exp $
+
+inherit games
+
+DESCRIPTION="Tcl/Tk variant of the well-known 15-puzzle game"
+HOMEPAGE="http://www.naskita.com/linux/penguzzle/penguzzle.shtml"
+SRC_URI="http://www.naskita.com/linux/${PN}/${PN}.zip"
+
+LICENSE="penguzzle"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="dev-lang/tk
+ dev-tcltk/tclx"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s:~/puzz/images:${GAMES_DATADIR}/${PN}:" \
+ lib/init \
+ || die "sed init failed"
+ sed -i \
+ -e "s:~/puzz/lib:$(games_get_libdir)/${PN}:" \
+ bin/${PN} \
+ || die "sed ${PN} failed"
+
+ epatch "${FILESDIR}"/${P}-tclx.patch
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins images/img0.gif || die "doins img0.gif failed"
+
+ insinto "$(games_get_libdir)"/${PN}
+ doins lib/init || die "doins init failed"
+
+ dogamesbin bin/${PN} || die "dogamesbin failed"
+
+ dodoc README
+ prepgamesdirs
+}
diff --git a/games-puzzle/penguzzle/penguzzle-1.0.ebuild b/games-puzzle/penguzzle/penguzzle-1.0.ebuild
deleted file mode 100644
index 3462bfc28b3e..000000000000
--- a/games-puzzle/penguzzle/penguzzle-1.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/penguzzle/penguzzle-1.0.ebuild,v 1.8 2004/12/28 16:17:16 josejx Exp $
-
-inherit games
-
-DESCRIPTION="Tcl/Tk variant of the well-known 15-puzzle game"
-HOMEPAGE="http://www.naskita.com/linux/penguzzle/penguzzle.shtml"
-SRC_URI="http://www.naskita.com/linux/penguzzle/${PN}.zip"
-
-LICENSE="penguzzle"
-SLOT="0"
-KEYWORDS="amd64 x86 ppc"
-IUSE=""
-
-RDEPEND="dev-tcltk/tclx"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S="${WORKDIR}/${PN}${PV}"
-
-src_install() {
- insinto "${GAMES_DATADIR}/${PN}"
- doins images/*
-
- insinto "${GAMES_LIBDIR}/${PN}"
- doins lib/*
- dosed "s:~/puzz/images:${GAMES_DATADIR}/${PN}:" "${GAMES_LIBDIR}/${PN}/init"
-
- dogamesbin bin/*
- dosed "s:~/puzz/lib:${GAMES_LIBDIR}/${PN}:" "${GAMES_BINDIR}/penguzzle"
-
- dodoc README
- prepgamesdirs
-}