summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-10-31 08:46:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-10-31 08:46:44 +0000
commit0e2218dbce09728716ed6cb16a7ebced7818962f (patch)
tree3d531c7bf313b5c4696ccc4987754c485245b22b /games-puzzle
parenttouch (diff)
downloadgentoo-2-0e2218dbce09728716ed6cb16a7ebced7818962f.tar.gz
gentoo-2-0e2218dbce09728716ed6cb16a7ebced7818962f.tar.bz2
gentoo-2-0e2218dbce09728716ed6cb16a7ebced7818962f.zip
tidy
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/hoh-bin/hoh-bin-1.01.ebuild13
-rw-r--r--games-puzzle/xbomb/xbomb-2.1-r1.ebuild22
2 files changed, 15 insertions, 20 deletions
diff --git a/games-puzzle/hoh-bin/hoh-bin-1.01.ebuild b/games-puzzle/hoh-bin/hoh-bin-1.01.ebuild
index 2bf58d6b6857..d76acda8d609 100644
--- a/games-puzzle/hoh-bin/hoh-bin-1.01.ebuild
+++ b/games-puzzle/hoh-bin/hoh-bin-1.01.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/hoh-bin/hoh-bin-1.01.ebuild,v 1.6 2005/08/23 19:18:23 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/hoh-bin/hoh-bin-1.01.ebuild,v 1.7 2005/10/31 08:44:16 mr_bones_ Exp $
inherit games
-S="${WORKDIR}/hoh-install-${PV}"
-DESCRIPTION="PC remake of the spectrum game"
+DESCRIPTION="PC remake of the spectrum game, Head Over Heels"
HOMEPAGE="http://retrospec.sgn.net/games/hoh/"
SRC_URI="http://retrospec.sgn.net/download.php?id=63\&path=games/hoh/bin/hohlin-${PV/./}.tar.bz2"
RESTRICT="nostrip"
LICENSE="free-noncomm"
SLOT="0"
-KEYWORDS="x86 ~amd64"
+KEYWORDS="~amd64 x86"
IUSE=""
DEPEND="virtual/x11
amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 )"
+S=${WORKDIR}/hoh-install-${PV}
+
src_compile() {
cat > "${T}/hoh" <<-EOF
#!/bin/bash
@@ -31,8 +32,8 @@ src_install() {
local DATADIR="${GAMES_PREFIX_OPT}/HoH/data"
local DOCDIR="${GAMES_PREFIX_OPT}/HoH/docs"
- dogamesbin "${T}/hoh" || die "dogames bin failed"
- dodir "${DATADIR}" "${DOCDIR}" || die "dodir failed"
+ dogamesbin "${T}/hoh" || die "dogames bin failed"
+ dodir "${DATADIR}" "${DOCDIR}"
cp -pPRf data/* "${D}/${DATADIR}/" || die "cp failed (data)"
cp -pPRf docs/* "${D}/${DOCDIR}/" || die "cp failed (docs)"
prepgamesdirs
diff --git a/games-puzzle/xbomb/xbomb-2.1-r1.ebuild b/games-puzzle/xbomb/xbomb-2.1-r1.ebuild
index fa05d7ef212c..9fef78c65543 100644
--- a/games-puzzle/xbomb/xbomb-2.1-r1.ebuild
+++ b/games-puzzle/xbomb/xbomb-2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xbomb/xbomb-2.1-r1.ebuild,v 1.11 2005/04/15 17:28:06 nigoro Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xbomb/xbomb-2.1-r1.ebuild,v 1.12 2005/10/31 08:46:44 mr_bones_ Exp $
inherit eutils games
@@ -10,35 +10,29 @@ SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/games/strategy/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ia64 ppc x86 ppc64"
+KEYWORDS="amd64 ia64 ppc ppc64 x86"
IUSE=""
-RDEPEND="virtual/x11
- virtual/libc"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
+DEPEND="virtual/x11"
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${P}.diff
+ epatch "${FILESDIR}"/${P}.diff
sed -i \
-e "/^CFLAGS/ { s:=.*:=${CFLAGS}: }" \
-e "s:/usr/bin:${GAMES_BINDIR}:" \
- ${S}/Makefile \
+ "${S}"/Makefile \
|| die "sed Makefile failed"
sed -i \
-e "s:/var/tmp:/var/games:g" \
- ${S}/hiscore.c \
+ "${S}"/hiscore.c \
|| die "sed hiscore.c failed"
}
-src_compile() {
- emake || die "emake failed"
-}
-
src_install() {
- make install DESTDIR="${D}" || die
+ make DESTDIR="${D}" install || die "make install failed"
dodoc README LSM
+ # FIXME: need to use GAMES_STATEDIR here
dodir /var/games
touch ${D}/var/games/xbomb{3,4,6}.hi || die "touch failed"
fperms 664 /var/games/xbomb{3,4,6}.hi || die