summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-15 00:15:32 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-15 00:15:32 +0000
commit38b3ccdbcc4f768df7303633ca06f9f082849973 (patch)
tree91f2a3f8691018c418d6c388a403a4afc2c2d68a /games-puzzle
parentMore whitespaces clean up (diff)
downloadgentoo-2-38b3ccdbcc4f768df7303633ca06f9f082849973.tar.gz
gentoo-2-38b3ccdbcc4f768df7303633ca06f9f082849973.tar.bz2
gentoo-2-38b3ccdbcc4f768df7303633ca06f9f082849973.zip
Initial ebuild #258960 by Vladimir Berezhnoy.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/world-of-goo/ChangeLog10
-rw-r--r--games-puzzle/world-of-goo/metadata.xml5
-rw-r--r--games-puzzle/world-of-goo/world-of-goo-1.40.ebuild60
3 files changed, 75 insertions, 0 deletions
diff --git a/games-puzzle/world-of-goo/ChangeLog b/games-puzzle/world-of-goo/ChangeLog
new file mode 100644
index 000000000000..d39ccb0bf2ec
--- /dev/null
+++ b/games-puzzle/world-of-goo/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-puzzle/world-of-goo
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/world-of-goo/ChangeLog,v 1.1 2009/02/15 00:15:32 vapier Exp $
+
+*world-of-goo-1.40 (15 Feb 2009)
+
+ 15 Feb 2009; Mike Frysinger <vapier@gentoo.org> +metadata.xml,
+ +world-of-goo-1.40.ebuild:
+ Initial ebuild #258960 by Vladimir Berezhnoy.
+
diff --git a/games-puzzle/world-of-goo/metadata.xml b/games-puzzle/world-of-goo/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/world-of-goo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/world-of-goo/world-of-goo-1.40.ebuild b/games-puzzle/world-of-goo/world-of-goo-1.40.ebuild
new file mode 100644
index 000000000000..1e5563d962e5
--- /dev/null
+++ b/games-puzzle/world-of-goo/world-of-goo-1.40.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/world-of-goo/world-of-goo-1.40.ebuild,v 1.1 2009/02/15 00:15:32 vapier Exp $
+
+inherit games
+
+DESCRIPTION="World of Goo is a puzzle game with a strong emphasis on physics"
+HOMEPAGE="http://2dboy.com/"
+
+if [[ ${PN} == *-demo ]] ; then
+ MY_PN="WorldOfGooDemo"
+ SRC_URI="${MY_PN}.${PV}.tar.gz"
+else
+ MY_PN="WorldOfGoo"
+ SRC_URI="${MY_PN}Setup.${PV}.tar.gz"
+fi
+
+LICENSE="2dboy-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch strip"
+
+# the package includes SDL/ogg/vorbis already
+RDEPEND="sys-libs/glibc
+ virtual/opengl
+ virtual/glu
+ >=sys-devel/gcc-3.4
+ amd64? (
+ app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-xlibs
+ )"
+DEPEND=""
+
+S=${WORKDIR}/${MY_PN}
+
+QA_EXECSTACK="opt/${MY_PN}/WorldOfGoo.bin"
+
+pkg_nofetch() {
+ elog "To download the demo, visit http://worldofgoo.com/dl2.php?lk=demo"
+ elog "and download ${A} and place it in ${DISTDIR}"
+}
+
+src_install() {
+ local d="/opt/${MY_PN}"
+ insinto ${d}
+ doins -r */ ${MY_PN%Demo}* || die
+
+ dodoc readme.html linux-issues.txt
+ newicon icon.png ${MY_PN}.png
+ make_desktop_entry ${MY_PN} "World Of Goo (Demo)" ${MY_PN}.png
+
+ dosym ${d}/${MY_PN%Demo} "${GAMES_BINDIR}"/${MY_PN}
+ pushd "${D}"${d} >/dev/null
+ chmod a+rx ${MY_PN%Demo}* libs/lib* || die
+ games_make_wrapper ${MY_PN} ${d}/${MY_PN%Demo}
+ popd >/dev/null
+
+ prepgamesdirs ${d}
+}