summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-22 10:01:17 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-22 10:01:17 +0000
commit3b2e77faf87b90cedd04b835fa3ed4dc19b632d9 (patch)
treeb90561b8d15cb1b38b514aeb5bdaba96649f90de /games-puzzle
parenthandle vdeo cards properly #41261 (diff)
downloadgentoo-2-3b2e77faf87b90cedd04b835fa3ed4dc19b632d9.tar.gz
gentoo-2-3b2e77faf87b90cedd04b835fa3ed4dc19b632d9.tar.bz2
gentoo-2-3b2e77faf87b90cedd04b835fa3ed4dc19b632d9.zip
set cuyo to use qt2 or qt3 *again* #41718
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/cuyo/cuyo-1.8.1.ebuild16
1 files changed, 5 insertions, 11 deletions
diff --git a/games-puzzle/cuyo/cuyo-1.8.1.ebuild b/games-puzzle/cuyo/cuyo-1.8.1.ebuild
index e9e382333084..d116e6417c02 100644
--- a/games-puzzle/cuyo/cuyo-1.8.1.ebuild
+++ b/games-puzzle/cuyo/cuyo-1.8.1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/cuyo/cuyo-1.8.1.ebuild,v 1.3 2004/02/03 00:41:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/cuyo/cuyo-1.8.1.ebuild,v 1.4 2004/02/22 10:01:17 vapier Exp $
inherit games
-S=${WORKDIR}/${P/_}
DESCRIPTION="highly addictive and remotely related to tetris"
HOMEPAGE="http://www.karimmi.de/cuyo/"
SRC_URI="http://savannah.nongnu.org/download/cuyo/${P//_}.tar.gz"
@@ -15,23 +14,19 @@ KEYWORDS="x86 ppc"
DEPEND="virtual/glibc
virtual/x11
- =x11-libs/qt-2*"
+ x11-libs/qt"
+
+S=${WORKDIR}/${P/_}
src_unpack() {
unpack ${A}
cd ${S}
- sed -i 's:-O2:@CXXFLAGS@:' src/Makefile.in
+ sed -i 's:-O2:@CXXFLAGS@ -Wno-long-long:' src/Makefile.in
}
src_compile() {
-# local qtver=
-# has_version =x11-libs/qt-3* \
-# && qtver=3 \
-# || qtver=2
- qtver=2
egamesconf \
--with-qt \
- --with-qt-dir=/usr/qt/${qtver} \
--with-x \
|| die
emake || die
@@ -45,6 +40,5 @@ src_install() {
dogamesbin ${D}/${GAMES_PREFIX}/games/cuyo
rm -rf ${D}/${GAMES_PREFIX}/games
dodoc AUTHORS INSTALL NEWS README TODO ChangeLog
-
prepgamesdirs
}