summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-09-11 12:02:02 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-09-11 12:02:02 +0000
commiteff0050d74c1584202aebf4255d6789379abb461 (patch)
treea9cf332f9596e093d790bfe6d44b2fa9eb71894c /games-puzzle
parentFix DEPEND/RDEPEND assignment. (diff)
downloadgentoo-2-eff0050d74c1584202aebf4255d6789379abb461.tar.gz
gentoo-2-eff0050d74c1584202aebf4255d6789379abb461.tar.bz2
gentoo-2-eff0050d74c1584202aebf4255d6789379abb461.zip
Fix --as-needed as reported by Bug #281990
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/sgt-puzzles/ChangeLog6
-rw-r--r--games-puzzle/sgt-puzzles/files/sgt-puzzles-8605-gentoo.patch29
-rw-r--r--games-puzzle/sgt-puzzles/sgt-puzzles-8605.ebuild6
3 files changed, 37 insertions, 4 deletions
diff --git a/games-puzzle/sgt-puzzles/ChangeLog b/games-puzzle/sgt-puzzles/ChangeLog
index 23b2431c7b1b..de8195679c7d 100644
--- a/games-puzzle/sgt-puzzles/ChangeLog
+++ b/games-puzzle/sgt-puzzles/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/sgt-puzzles
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/ChangeLog,v 1.1 2009/08/18 09:52:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/ChangeLog,v 1.2 2009/09/11 12:02:01 tupone Exp $
+
+ 11 Sep 2009; Tupone Alfredo <tupone@gentoo.org>
+ +files/sgt-puzzles-8605-gentoo.patch, sgt-puzzles-8605.ebuild:
+ Fix --as-needed as reported by Bug #281990 by James Rowe <jnrowe@gmail.com>
*sgt-puzzles-99999999 (18 Aug 2009)
*sgt-puzzles-8605 (18 Aug 2009)
diff --git a/games-puzzle/sgt-puzzles/files/sgt-puzzles-8605-gentoo.patch b/games-puzzle/sgt-puzzles/files/sgt-puzzles-8605-gentoo.patch
new file mode 100644
index 000000000000..89638f60944d
--- /dev/null
+++ b/games-puzzle/sgt-puzzles/files/sgt-puzzles-8605-gentoo.patch
@@ -0,0 +1,29 @@
+--- mkfiles.pl.old 2009-09-11 13:39:57.000000000 +0200
++++ mkfiles.pl 2009-09-11 13:44:40.000000000 +0200
+@@ -1110,8 +1110,8 @@
+ "\n".
+ &splitline("CFLAGS = -O2 -Wall -Werror -ansi -pedantic -g " .
+ (join " ", map {"-I$dirpfx$_"} @srcdirs) .
+- " `\$(GTK_CONFIG) --cflags`")."\n".
+- "XLDFLAGS = `\$(GTK_CONFIG) --libs`\n".
++ " `pkg-config gtk+-2.0 --cflags`")."\n".
++ "XLDLIBS = `pkg-config gtk+-2.0 --libs`\n".
+ "ULDFLAGS =#\n".
+ "INSTALL=install\n",
+ "INSTALL_PROGRAM=\$(INSTALL)\n",
+@@ -1130,8 +1130,13 @@
+ $objstr = &objects($p, "X.o", undef, undef);
+ print &splitline($prog . ": " . $objstr), "\n";
+ $libstr = &objects($p, undef, undef, "-lX");
+- print &splitline("\t\$(CC)" . $mw . " \$(${type}LDFLAGS) -o \$@ " .
+- $objstr . " $libstr", 69), "\n\n";
++ if ($type eq "X") {
++ print &splitline("\t\$(CC)" . $mw . " \$(LDFLAGS) -o \$@ " .
++ $objstr . " $libstr \$(XLDLIBS)", 69), "\n\n";
++ } else {
++ print &splitline("\t\$(CC)" . $mw . " \$(LDFLAGS) -o \$@ " .
++ $objstr . " $libstr", 69), "\n\n";
++ }
+ }
+ foreach $d (&deps("X.o", undef, $dirpfx, "/")) {
+ print &splitline(sprintf("%s: %s", $d->{obj}, join " ", @{$d->{deps}})),
diff --git a/games-puzzle/sgt-puzzles/sgt-puzzles-8605.ebuild b/games-puzzle/sgt-puzzles/sgt-puzzles-8605.ebuild
index 4953d853de59..91f8630f9754 100644
--- a/games-puzzle/sgt-puzzles/sgt-puzzles-8605.ebuild
+++ b/games-puzzle/sgt-puzzles/sgt-puzzles-8605.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/sgt-puzzles-8605.ebuild,v 1.1 2009/08/18 09:52:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/sgt-puzzles-8605.ebuild,v 1.2 2009/09/11 12:02:01 tupone Exp $
EAPI="2"
@@ -29,9 +29,9 @@ DEPEND="${RDEPEND}
doc? ( >=app-doc/halibut-1.0 )"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ ./mkfiles.pl
sed -i \
- -e '1iPKG_CONFIG ?= pkg-config' \
- -e '/^GTK_CONFIG/s:=.*:= $(PKG_CONFIG) gtk+-2.0:' \
-e 's:= -O2 -Wall -Werror -ansi -pedantic -g:+= $(CPPFLAGS):' \
-e '/LDFLAGS/s:=:=$(LDFLAGS) :' \
Makefile || die