summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 04:59:58 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 04:59:58 +0000
commit12c9973915d478c72a31e83a2dcd74a9d85f9329 (patch)
treed37cf05165786ebbb579f87068d6e4ac5c678a32 /games-roguelike/falconseye/falconseye-1.9.3-r1.ebuild
parentrepoman: fix leading whitespace (diff)
downloadgentoo-2-12c9973915d478c72a31e83a2dcd74a9d85f9329.tar.gz
gentoo-2-12c9973915d478c72a31e83a2dcd74a9d85f9329.tar.bz2
gentoo-2-12c9973915d478c72a31e83a2dcd74a9d85f9329.zip
hello rogues
Diffstat (limited to 'games-roguelike/falconseye/falconseye-1.9.3-r1.ebuild')
-rw-r--r--games-roguelike/falconseye/falconseye-1.9.3-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/games-roguelike/falconseye/falconseye-1.9.3-r1.ebuild b/games-roguelike/falconseye/falconseye-1.9.3-r1.ebuild
new file mode 100644
index 000000000000..1d3000019820
--- /dev/null
+++ b/games-roguelike/falconseye/falconseye-1.9.3-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/falconseye/falconseye-1.9.3-r1.ebuild,v 1.1 2003/09/10 04:59:58 vapier Exp $
+
+DESCRIPTION="A graphical version of nethack"
+SRC_URI="mirror://sourceforge/falconseye/nethack_source_331_jtp_193.zip"
+HOMEPAGE="http://falconseye.sourceforge.net/"
+
+KEYWORDS="x86 ppc"
+LICENSE="nethack"
+SLOT="0"
+
+DEPEND="media-libs/libsdl
+ dev-util/yacc
+ app-arch/unzip"
+RDEPEND="media-libs/libsdl
+ sys-apps/gzip
+ media-sound/timidity++"
+
+src_unpack() {
+ unpack ${A}
+ patch -p1 < ${FILESDIR}/${PV}-gzip.diff || die
+ patch -p1 < ${FILESDIR}/${PV}-midiplayer.diff || die
+ patch -p1 < ${FILESDIR}/${PV}-musicsavefix.diff || die
+}
+
+src_compile() {
+ cd ${WORKDIR}/sys/unix
+ source setup.sh
+ cd ../../
+ make PREFIX=/usr GAME=falconseye GAMEDIR=/usr/share/falconseye SHELLDIR=/usr/bin || die
+ cd doc
+ make || die
+}
+
+src_install() {
+ cd ${WORKDIR}
+ make PREFIX=${D}/usr GAME=falconseye GAMEDIR=${D}/usr/share/falconseye SHELLDIR=${D}/usr/bin install
+ # Have to remake the shell script with real path information
+ sed -e 's;/usr/games/lib/nethackdir;/usr/share/falconseye;' \
+ -e 's;HACKDIR/nethack;HACKDIR/falconseye;' \
+ -e '7a\
+ if [ -f ${HOME}/.falconseyerc ]; then\
+ export NETHACKOPTIONS=${HOME}/.falconseyerc;\
+ else\
+ echo 'OPTIONS=noautopickup,toptenwin,showexp,rest_on_space' > ${HOME}/.falconseyerc;\
+ export NETHACKOPTIONS=${HOME}/.falconseyerc;\
+ fi' \
+ < ${WORKDIR}/sys/unix/nethack.sh \
+ > ${D}/usr/bin/falconseye
+ cd doc
+ doman *.6
+}
+
+pkg_postinst() {
+ einfo "Falconseye now supports a ~/.falconseyerc file to set options."
+ einfo "Click ? then 'List of game options' in falconseye for more info."
+}