summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-01-05 17:34:58 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-01-05 17:34:58 +0000
commit775cfd20c8295430199c789e9a7191bc8e374f50 (patch)
tree95b40b12c0567d3b50e48628c7081f02e69d9386 /games-roguelike/tomenet/tomenet-070104.ebuild
parentConvert to use elog. (diff)
downloadgentoo-2-775cfd20c8295430199c789e9a7191bc8e374f50.tar.gz
gentoo-2-775cfd20c8295430199c789e9a7191bc8e374f50.tar.bz2
gentoo-2-775cfd20c8295430199c789e9a7191bc8e374f50.zip
New ebuild. Bug #90283
(Portage version: 2.1.1-r2)
Diffstat (limited to 'games-roguelike/tomenet/tomenet-070104.ebuild')
-rw-r--r--games-roguelike/tomenet/tomenet-070104.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/games-roguelike/tomenet/tomenet-070104.ebuild b/games-roguelike/tomenet/tomenet-070104.ebuild
new file mode 100644
index 000000000000..b8ed7ee55374
--- /dev/null
+++ b/games-roguelike/tomenet/tomenet-070104.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tomenet/tomenet-070104.ebuild,v 1.1 2007/01/05 17:34:58 tupone Exp $
+
+inherit games
+
+DESCRIPTION="A massively-multiplayer online RPG based on the works of J.R.R.
+Tolkien. Client"
+HOMEPAGE="http://tomenet.net/"
+SRC_URI="http://angband.oook.cz/${PN}-nightly/${PN}-cvs-snapshot-${PV}.tar.bz2"
+
+LICENSE="Moria"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X Xaw3d"
+
+DEPEND="X? ( x11-libs/libX11 )
+ Xaw3d? ( x11-libs/libXaw )"
+
+S="${WORKDIR}/${PN}/src"
+
+src_compile() {
+ local GENTOO_DEFINES="-DUSE_GCU "
+ local GENTOO_LIBS="-lncurses -lcrypt "
+ if use Xaw3d; then
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_XAW"
+ elif use X; then
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_X11"
+ fi
+ if use X; then
+ GENTOO_LIBS="${GENTOO_LIBS} -lX11 "
+ fi
+ if use Xaw3d; then
+ GENTOO_LIBS="${GENTOO_LIBS} -lXaw "
+ fi
+ emake CFLAGS="${CFLAGS} ${GENTOO_DEFINES} -Iserver -Iserver/lua" \
+ LIBS="${GENTOO_LIBS}" tomenet \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "installing the binary failed"
+ cd ..
+ dodoc ChangeLog TomeNET-Guide.txt changes.txt \
+ || die "installing docs failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "To start playing right away:"
+ einfo "$ tomenet europe.tomenet.net"
+}